Introduction

 Top Next

This documentation is a supporting publication that provides information about using debug commands to troubleshoot UltraWAVE network entities, including:

8ECP | AAS | AIF | AUC | BICC | DEBUG | EIR | GCP
HLR | iPALIM | iRLS | IIF | IPTRANS | ISDN | ISUP | MGC
MNP | MRFC | MSC | MTP3 | OPPS | PPS | SCCP | SIP
SMPP | SMSC | SNMP | SSF | TCAP | UES | VLR | XAPP
XUA |  |  |  |  |  |  |

The audiences of this documentation could be test, support and field engineers. The procedures and commands in this manual have to be used carefully especially when working on a live network.

Caution!

Please thoroughly understand an action before implementing it.

Command Syntax Conventions

Command descriptions use the following conventions:

Conventions | Description
screen | Courier plain shows the debugging output displayed on the screen.
boldface | Boldface text indicates commands and keywords that you enter.
<x> | Angle brackets indicate arguments for which you supply values.
[x] | Braces indicate a required element (keyword or argument).
[x | y | z] | Braces and vertical lines within square brackets indicate required choice within optional elements.
# | A pound point at the beginning of a line indicates a comment line.

1


Using Debug Commands

 Top Previous Next

This chapter explains how you logon to debug module and use debug commands to diagnose and resolve system problems. Specifically, it covers the following topics:

· Logon to debug module
· Entering debug commands
· Using the help command
· Using the log all command
· Displaying debug command output

Caution!

Because debugging output is assigned high priority in the system process, so use debug commands only to troubleshoot specific problems or during troubleshooting sessions with technical support staff. Moreover, it is best to use debug commands during periods of lower network traffic and fewer users. Debugging during these periods decreases the likelihood that increased debug command processing overhead will affect system use.

Logon to Debug Module

There are two methods to use debug module:

Methods | Description
Serial Port (rarely use) | Use PC-to-PC serial line to connect to the monitored server and log on by Telix software.
Telnet | Use telnet software to log on the monitored server's 4965 port. The telnet software PUTTY is recommended. For example: Telnet to MSS0 : telnet 172.18.98.1 4965 Telnet to MSS1: telnet 172.18.99.1 4965

Entering Debug Commands

All debug commands are entered in EXEC mode, and most debug commands take no arguments. For example, to enable the debug log error command, enter the following in EXEC mode at the command line:

>log error on

To turn off the debug command, in EXEC mode, enter the off form of the command at the command line:

>log error off

Using the Help Command

To list and see a brief description of all the debugging command options, enter the following command in privileged EXEC mode at the command line:

>help

Not all debugging commands listed in the help output are described in this document. Commands are included here based on the their usefulness in assisting you to diagnose network problems. Commands not included are typically used internally by engineering during the development process and are not intended for use outside this environment.

Using the Log All Command

To enable all system diagnostics, enter the following command in privileged EXEC mode at the command line:

>log all

The log none command turns off all diagnostic output. Using the log none command is a convenient way to ensure that you have not accidentally left any debug commands turned on.

Caution!

Because debugging output takes priority over other network traffic, and because the log all command generates more output than any other debug command, it can severely diminish the server's performance or even render it unusable. In virtually all cases, it is best to use more specific debug commands.

Displaying Debug Command Output

Enabling a debug command can result in output similar to the following example for the MTP3 log primitive on command:

MTP3>log primitive on

primitive between MTP3 and MTP2 on

(14:3:20.161433)MTP3 send IP to MTP2 16

00 00 0C FF EE FF EE EE EE EE EE EE EE EE 00

(14:3:20.161449)MTP3 send IP to MTP2 17

00 00 0C FF EE FF EE EE EE EE EE EE EE EE 00

(14:3:21.61217)MTP3 send IP to MTP2 18

00 00 0C FF EE FF EE EE EE EE EE EE EE EE 00

The module continues to generate such output until you enter the corresponding off form of this command (in this case, log primitive off) or log none command.

If you enable a debug command and no output is displayed, consider the following possibilities:

· It an operation command to set parameter.
· The module may not be properly configured to generate the type of traffic you want to monitor.
· Even if the module is properly configured, it may not generate the type of traffic you want to monitor during the particular period that debugging is turned on.

2


Debug Commands

This chapter contains a listing of the debug commands for each modules and their descriptions. Documentation for each command includes a brief description of its usage guidelines, command syntax, and sample output.

Output formats vary with each debug command. Some commands generate a single line of output per packet, whereas others generate multiple lines of output per packet. Some generate large amounts of output; others generate only occasional output. Some generate lines of text, and others generate information in field format. Thus, the way debug command output is documented also varies. For example, the output for debug commands that generate lines of text is usually described line by line, and the output for debug commands that generate information in field format is usually described in tables.

Select a module for debug command details:

8ECP | AAS | AIF | AUC | BICC | DEBUG | EIR | GCP
HLR | iPALIM | iRLS | IIF | IPTRANS | ISDN | ISUP | MGC
MNP | MRFC | MSC | MTP3 | OPPS | PPS | SCCP | SIP
SMPP | SMSC | SNMP | SSF | TCAP | UES | VLR | XAPP
XUA |  |  |  |  |  |  |

3


Main Menu

The main menu displays the basic information of the server under debugging and provides key index to access available sub-modules. Operation descriptions use the following keypad keys:

Keys | Description
1-2 | The main menu has two sub-pages. Click 1 or 2 to switch between sub-pages.
a-p, r-w, y, z | Click a index key to switch to the associated module's debugging page.
x | Click x to return to the main menu.
q | Click q to exit the debugging terminal.

Main Menu Sub-page 1

Main Menu Sub-page 2

3.1


8ECP

8ECP Debug Commands:

· log all
· log none
· log mg -<mg> [on | off]
· log trk -<mg> -<trunk> [on | off]
· log chl -<mg> -<trunk> -<channel> [on | off]

log all

Usage Guidelines

Use the log all command to display debugging information on all 8ECP component activities.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

8ECP>log all

Command OK!

Receive: 01 03 aa aa a2 aa 01 99 99 99 99 ff ff ff 00 00 ff 31 08 02 08 00 ff ff 00 ff 00 0d 07 09 22 aa 0f 0b 0f 0b 0f 0b 0f 0b 0f

Receive: 01 04 71 71 51 71 01 99 99 99 99 ff ff ff 00 00 ff 31 08 02 08 00 ff ff 00 ff 00 0d 07 00 22 71 00 00 00 00 00 00 00 00 00

...

log none

Usage Guidelines

Use the log none command to disable all 8ECP debugging output.

Syntax Description

This command has no arguments or keywords.

log mg

Usage Guidelines

Use the log mg command to display message flows occurring in the specified media gateway. The off form of this command disables debugging output.

This command is useful for filtering message flows in a specified media gateway.

Syntax Description

log mg -<mg> [on | off]

mg

Specify debugging for a media gateway.

Examples

The following is sample output from the log mg command.

8ECP>log mg -8 on

Command OK!

...

log trk

Usage Guidelines

Use the log trk command to display message flows occurring in a specified trunk. The off form of this command disables debugging output.

This command is useful for filtering message flows in a specified trunk.

Syntax Description

log trk -<mg> -<trunk> [on | off]

mg | Specify a media gateway.
trunk | Specify debugging for a trunk in the specified media gateway.

Examples

The following is sample output from the log trk command.

8ECP>log trk -8 -1 on

Command OK!

...

log chl

Usage Guidelines

Use the log chl command to display message flows occurring in a specified channel. The off form of this command disables debugging output.

This command is useful for filtering message flows in a specified channel.

Syntax Description

log chl -<mg> -<trunk> -<channel> [on | off]

mg | Specify a media gateway.
trunk | Specify a trunk.
channel | Specify debugging for a channel in the specified trunk.

Examples

The following is sample output from the log chl command.

8ECP>log chl -8 -1 -11 on

Command OK!

...

3.2


AAS

AAS Debug Commands:

· log all
· log none
· log error [on | off]
· log mgcp [on | off]
· log cap [on | off]
· log msg [on | off]
· select mode [global | trace]
· trace msisdn <msisdn>
· trace pid <pid>
· list debug
· save
· reset
· information pages
· page 1
· page 2
· page 3

log all

Usage Guidelines

Use the log all command to activate the log error, log mgcp, log cap, and log msg commands simultaneously. It displays debugging information on all AAS and SRF component activities.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

AAS>log all

OK

[pid 1]msg:

mgcp=>aas CRCX  ip=1fd12ac, port=5000, payload type=118, a_ptype=0, ptime=20, voice file=1

error: mgcp g729 endpoint not exist

[pid 1]msg:

aas=>mgcp 500 fail

...

log none

Usage Guidelines

Use the log none command to disable all AAS and SRF debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display AAS and SRF related messages only when errors occur. The off form of this command disables debugging output.

It is useful for troubleshooting audio announcement and SRF problems because it produces little output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

AAS>log error on

...

log mgcp

Usage Guidelines

Use the log mgcp on command to display debugging output from the Media Gateway Control Protocol (MGCP) routines. The off form of this command disables debugging output.

Syntax Description

log mgcp [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log mgcp on command.

AAS>log mgcp on

...

log cap

Usage Guidelines

Use the log cap on command to display CAP application-layer message flows occurring in the AAS module. The off form of this command disables debugging output.

Syntax Description

log cap [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log cap on command.

AAS>log cap on

...

log msg

Usage Guidelines

Use the log msg on command to enable debugging of audio announcement and SRF activities. The off form of this command disables debugging output.

Syntax Description

log msg [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log msg on command.

AAS>log msg on

...

select mode

Usage Guidelines

Use the select mode command to choose the current debugging mode. Select trace mode to display call flows related to predefined objects.

Syntax Description

select mode [global | trace]

global | Enable log commands debugging output.
trace | Enable trace commands debugging output.

trace msisdn

Usage Guidelines

Use the trace msisdn command to track the SRF transaction process related with a certain subscriber by given its MSISDN. Use log none command to disable tracking.

Syntax Description

trace msisdn <msisdn>

msisdn

Up to 31-digit MSISDN (CC+NDC+SN).

Examples

The following is sample output from the trace msisdn command.

AAS>trace msisdn 86755920023

...

trace pid

Usage Guidelines

Use the trace pid command to display a SRF transaction process by specifying its task ID. Use log none command to disable tracking.

Syntax Description

trace pid <pid>

pid

Specify a working task ID.

Examples

The following is sample output from the trace pid command.

AAS>test called 86755

...

list debug

Usage Guidelines

Use the list debug command to display the current AAS debug setting.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list debug command.

AAS>list debug

------Debug Information------

[mode: global]          msisdn: --              pid: --

error:  ON

mgcp:   ON

cap:    ON

msg:    ON

save

Usage Guidelines

Use the save command to save AAS system parameters residing in memory to hard disk.

Syntax Description

This command has no arguments or keywords.

reset

Usage Guidelines

Use the reset command to reload AAS system parameters and initialize AAS status.

Syntax Description

This command has no arguments or keywords.

page 1

Usage Guidelines

The AAS debug page 1 displays the information of SRF system parameters.

Examples

The following is page 1 sample output.

PAGE-01         SRF System Param.

                0  1  2  3  4  5  6  7  8  9  10 11 12 13 14 15

subPage

sys no          00

nw attrib       01

dpc             04 00 00

cc              66 FF

ndc             75 5F FF

local msisdn    66 75 59 00 00 9F FF FF

enable link     01 01

OMC-0           AC 12 80 01

OMC-1           00 00 00 00

MGCP STAT       00 00

opc             05 00 00

page 2

Usage Guidelines

The AAS debug page 2 displays the information of SRF voice group.

Examples

The following is page 2 sample output.

PAGE-02         SRF system param.

                0  1  2  3  4  5  6  7  8  9  10 11 12 13 14 15

subPage         00 00

voice group     01 21 FF FF FF FF FF FF FF FF FF FF FF FF FF FF

                FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

                FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

                FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

page 3

Usage Guidelines

The AAS debug page 3 displays the information of AAS voice group.

Examples

The following is page 3 sample output.

PAGE-03         Extend function param. (VAS)

                0  1  2  3  4  5  6  7  8  9  10 11 12 13 14 15

subPage

vas prefix      BB FF FF FF FF FF FF FF

play times      03

voice group     BB 00 01 00 FF FF FF FF FF FF FF FF FF FF FF FF

                FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

                FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

                FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

3.3


AIF

AIF Debug Commands:

· log all
· log none
· log error [on | off]
· log event [on | off]
· list cg
· list sap
· list link
· wa link <link>
· list port
· wa port <pid>
· msg stat
· clear msg stat

log all

Usage Guidelines

Use the log all command to display all message flows related to A-Interface processing. This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

AIF>log all

Command OK.

(16:57:59.899874):SCCP => AIFG: ID:ASSIGN COMPLETE,APP_PORT:2565,AIFG_PORT:7063,LINK_ID:7331

(16:57:59.899996):SCCP => AIFG: ID:PAGING RESPONSE,APP_PORT:2583,AIFG_PORT:7066,LINK_ID:7336

(16:57:59.919807):SCCP => AIFG: ID:CLEAR COMPLETE,APP_PORT:1271,AIFG_PORT:6884,LINK_ID:7070

(16:57:59.919843):Link 7070 released!

(16:57:59.919849):Port 6884 released!

...

log none

Usage Guidelines

Use the log none command to disable all A-Interface debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display A-Interface related messages only when errors occur. The off form of this command disables debugging output.

This command is useful for troubleshooting mobile call fail problems because it produces little output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

MSC>log error on

Log error: 1

Log event: 0

Log internal: 0

[01005] MT_SM_Transfer_MSC return SDL_FAIL

[06743] OG_Call_Setup_MSC return OCS_FAILURE

[06879] CAMEL_MT_GMSC_DISC6 return SDL_FAIL

[07242] Complete_Call_In_MSC return SDL_ABORT

PID 6879 invalid at ssf_inter_msc

numbering_analysis: invalid nai(0)

[08790] Activate_CF_Process return SDL_FAIL

...

log event

Usage Guidelines

Use the log event on command to enable A-Interface event debugging. Use the off form of this command to disable debugging output.

Syntax Description

log event [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log event on command.

MSC>log event on

Log error: 0

Log event: 1

Log internal: 0

New CC_BICC_Incoming

[24423] msc_bicc_setup_ind

[24423] add_pid_to_timeslot ts_id=3 pid_num=1

[24423] CC_BICC_Incoming transfer to sub-state 1

New CC_BICC_Incoming

[24424] msc_bicc_setup_ind

[24424] add_pid_to_timeslot ts_id=4 pid_num=1

[24424] CC_BICC_Incoming transfer to sub-state 1

[24419] msc_mgc_cnf

[23166] isdn_rel_cnf

...

list cg

Usage Guidelines

Use the list cg command to list all AIF trunk groups configured in the system.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list cg command.

AIF>list cg

#               SAP             NI              DPC

000             MSC             00              2

001             MSC             00              4

002             MSC             02              88

003             MSC             02              2

004             MSC             02              3

...

NI (Network Indicator): 00=International, 01=International-Spare, 02=National, 03=National-Spare

list sap

Usage Guidelines

Use the list sap command to display the current A-Interface Service Access Point (SAP).

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list sap command.

AIF>list sap

Current opened SAP:

MSC

Command OK.

list link

Usage Guidelines

Use the list link command to display the index number of all A-Interface links in the system.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list link command.

AIF>list link

3144 3150 3153 3154 3159 3202 3205 3206 3214 3216 3217 3218 3226 3228 3231 3237

3238 3239 3240 3247 3250 3269 3275 3276 3284 3291 3292 3294 3295 3305 3309 3311

...

wa link

Usage Guidelines

Use the wa link command to display the information of a specific A-Interface link.

Syntax Description

wa link <link>

link

Specify a link index which can be inquired by list link command.

Examples

The following is sample output from the wa link command.

AIF>wa link 5936

=======AIFG Link 5936=======

en_flag: 1

sapid: 0

cur_port: 3084

ti_number: 1

==========================

Command OK.

list port

Usage Guidelines

Use the list port command to display all opened A-Interface process IDs in the system.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list port command.

AIF>list port

653  654  662  687  689  706  709  710  714  715  718  731  740  778  795  800

824  828  830  842  845  848  850  870  873  892  896  906  908  910  912  914

...

wa port

Usage Guidelines

Use the wa port command to display the information of a processing A-Interface task.

Syntax Description

wa port <pid>

pid

Specify a processing task ID which can be inquired by list port command.

Examples

The following is sample output from the wa port command.

AIF>wa port 2995

=======AIFG Port 2995=======

stat: 4

sapid: 0

cgid: 3

linkid: 3964

app_port: 31748

timer: 0

ti: 8

ti_type: 3

ti_stat: 2

ho_stat: 0

app_ho_port: 0

rel_cause: 0

imsi:

pNextOpenPort: 2987

pPrevOpenPort: 3006

pNextPort: -647553832

pPrevPort: -647553832

==========================

Command OK.

msg stat

Usage Guidelines

Use the msg stat command to display the statistics of AIF messages occurred in the system since the last initialization.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the msg stat command.

AIF>msg stat

==========================AIFG Message Statistics==========================

Message                                   Sent                   Received

TRANSPARENT DTAP MESSAGE                   0                         0

PAGING RESPONSE                            0                      8018

RR HANDOVER COMMAND                        0                         0

...

clear msg stat

Usage Guidelines

Use the clear msg stat command to initialize the AIF message statistics.

Syntax Description

This command has no arguments or keywords.

3.4


AUC

AUC Debug Commands:

· log all
· log none
· log error [on | off]
· log send [on | off]
· log recv [on | off]
· log map-h [on | off]
· log auth [on | off]
· log submng [on | off]
· log import [on | off]
· log pid [<pid> | off]
· log imsi [<imsi> | off]
· list imsi <imsi>
· stat imsi
· information pages
· page 2
· page 3

log all

Usage Guidelines

Use the log all command to display all message flows in authentication processing.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

AUC>log all

...

log none

Usage Guidelines

Use the log none command to disable all authentication debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display authentication related messages only when errors occur. The off form of this command disables debugging output.

This command is useful for troubleshooting authentication fail problems because it produces little output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

AUC>log error on

...

log send

Usage Guidelines

Use the log send on command to display AUC sending direction message flows. The off form of this command disables debugging output.

Syntax Description

log send [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log send on command.

AUC>log send on

...

log recv

Usage Guidelines

Use the log recv on command to display AUC receiving direction message flows. The off form of this command disables debugging output.

Syntax Description

log recv [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log recv on command.

AUC>log recv on

...

log map-h

Usage Guidelines

Use the log map-h on command to display messages exchanged between AUC and HLR. The off form of this command disables debugging output.

Syntax Description

log map-h [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log map-h on command.

AUC>log map-h on

...

log auth

Usage Guidelines

Use the log auth on command to display information on authentication. The off form of this command disables debugging output.

Syntax Description

log auth [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log auth on command.

AUC>log auth on

...

log submng

Usage Guidelines

Use the log submng on command to display messages associated with AUC subscriber management processing. The off form of this command disables debugging output.

Syntax Description

log submng [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log submng on command.

AUC>log submng on

...

log import

Usage Guidelines

Use the log import on command to display information in Ki import processing. The off form of this command disables debugging output.

Syntax Description

log import [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log import on command.

AUC>log import on

...

log pid

Usage Guidelines

Use the log pid command to display information of a processing authentication task. The off form of this command disables debugging output.

Syntax Description

log pid [<pid> | off]

pid | Specify a processing authentication task ID.
off | Disable debugging output.

Examples

The following is sample output from the log pid command.

AUC>log pid 231

...

log imsi

Usage Guidelines

Use the log imsi command to display authentication procedures associated with a specified IMSI. The off form of this command disables debugging output.

Syntax Description

log imsi [<imsi> | off]

imsi | Specify a 15-digit IMSI.
off | Disable debugging output.

Examples

The following is sample output from the log imsi command.

AUC>log imsi 460029000003744

...

list imsi

Usage Guidelines

Use the list imsi command to display an AUC subscriber's information by given its IMSI.

Syntax Description

list imsi <imsi>

imsi

Specify a 15-digit IMSI.

Examples

The following is sample output from the list imsi command.

AUC>list imsi 460029000003744

IMSI: 0460029000003744

A3A8 version: 02

Status: 01

Triplets available flag: 01

Ki: 1F42FD0C94C84F282241B5D230A63E64

stat imsi

Usage Guidelines

Use the stat imsi command to display total number of AUC subscribers in the AUC database.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the stat imsi command.

AUC>stat imsi

Total IMSIs: 6259

page 2

Usage Guidelines

The AUC debug page 2 displays the statistics of authentication procedures.

Examples

The following is page 2 sample output.

Page02

Statistics:

Instance           26 00 00 00

Start Time         49 1A A2 18

01.AuthenSuc       00 00 00 00

02.AuthenFail      00 00 00 00

03.HLRProvSubSuc   00 00 00 00

04.HLRProvSubFail  00 00 00 00

05.HLRDelSubSuc    00 00 00 00

06.HLRDelSubFail   00 00 00 00

07.AUCCreatSubSuc  00 00 00 00

08.AUCCreatSubFail 00 00 00 00

09.AUCDelSubSuc    00 00 00 00

10.AUCDelSubFail   00 00 00 00

11.AUCInterrSuc    00 00 00 00

12.AUCInterrFail   00 00 00 00

page 3

Usage Guidelines

The AUC debug page 3 displays the information of AUC system setting and subscriber capacity.

Examples

The following is page 3 sample output.

Page03

AUC System Parameter:

SysNum             00

AUC MSISDN         66 75 59 00 02 2E EE EE

System Control     00 00 00

Sync Control       02 02

DbgLogCtrl         00 00 00 00

MaxLicenses        00 00 9C 40

UsedLicenses       00 00 00 00

ProvSubs           00 00 00 00

AllUsers           00 00 9C 40

MaxMem             00 0F E4 00

watchdog           00 00 00 00

                   00 00 00 00

3.5


BICC

BICC Debug Commands:

· log all
· log none
· log error [on | off]
· list cg
· list circuit
· list port
· list dmp
· trace [on | off] <pid>

log all

Usage Guidelines

Use the log all command to display debugging output from the Bearer Independent Call Control (BICC) protocol routines in the system. This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

BICC>log all

Command OK!

01 00 00 00 0a 00 02 08 06 00 90 28 00 52 30 0a 06 02 10 28 00 42 30 00

Send:IAM:Initial address(message type=0x1  cic=678)

01 00 00 00 0a 00 02 08 06 00 90 28 00 92 22 0a 06 02 10 28 00 82 22 00

Send:IAM:Initial address(message type=0x1  cic=679)

01 00 00 00 0a 00 02 08 06 00 90 28 00 92 32 0a 06 02 10 28 00 82 32 00

Send:REL:Release(message type=0xc  cic=780)

0c 02 00 02 05 90

...

log none

Usage Guidelines

Use the log none command to disable all BICC debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display BICC related information only when errors occur. The off form of this command disables debugging output.

This command is useful for troubleshooting call fail problems because it produces little output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

BICC>log error on

...

list cg

Usage Guidelines

Use the list cg command to display all BICC trunk groups configured in the system.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list cg command.

BICC>list cg

Index  SAP  Circuit(s)  NetInd  DPC  OPC   TG

 0     1       2        3      123  122    0    # SAP 1 = AAS trunk group

 2     3      31        2        4    1    7    # SAP 3 = MSC trunk group

 9     3       1        3      127  126   30    # Circuit = Number of trunks in the TG

10     3       1        3      126  127   31

12     3       2        3      122  123  122

13     3       2        3      124  125  124

...

list circuit

Usage Guidelines

Use the list circuit command to display all BICC trunks configured in the system.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list circuit command.

BICC>list circuit

Index  CG  PLAT     CIC(s)

 0     0    1      32 (0~~32)     # PLAT 0 = MSS0

 0     0    1      32 (32~~64)    # PLAT 1 = MSS1

 2     2    0      32 (0~~32)     # CIC = Number of channels in the trunk

 2     2    0      32 (32~~64)

 2     2    0      32 (64~~96)

 2     2    0      32 (96~~128)

...

list port

Usage Guidelines

Use the list port command to display all BICC channels configured in the system.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list port command.

BICC>list port

134    868           INCOMING

135    869           INCOMING

136    870           INCOMING

137    871           INCOMING

138    872           INCOMING

...

list dmp

Usage Guidelines

Use the list dmp command to display the status of Distribute Multiple Processor (DMP).

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list dmp command.

BICC>list dmp

dmp active: 1

local plat id: 1     # 0 = MSS0, 1 = MSS1

remote ip: 16212ac   # Peer IP: 16212ac = AC126201 = 172.18.98.1

Command OK!

trace

Usage Guidelines

Use the trace on command to display BICC messages occurring in a specified channel. The off form of this command disables debugging output.

Syntax Description

trace [on | off] <pid>

on | Enable debugging output.
off | Disable debugging output.
port | Specify a channel index which can be inquired by list port command.

Examples

The following is sample output from the trace command.

BICC>trace on 871

Command OK!

...

3.6


DEBUG

Debug Commands:

· log all
· log none
· log error [on | off]
· [module] [command]
· log status
· cfg
· menu
· x
· q

log all

Usage Guidelines

Use the log all command to turn on debugging output for all modules simultaneously. Messages are displayed in the same terminal by receive or transmit sequence.

This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

log none

Usage Guidelines

Use the log none command to disable all modules' debugging output simultaneously.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to turn on error output for all modules simultaneously. Error information is displayed in the same terminal. The off form of this command disables all error output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

module command

Usage Guidelines

Use the module command to display conditionally triggered debugging for specified modules in the same terminal. You can specify the modules and commands explicitly. This feature is useful to see debugging messages for different modules at the same time.

Syntax Description

[module] [command]

module | Specify a debugging module.
command | Specify a command for the module. Refer to each module's introduction for details.

Examples

The following is sample output from the module command.

CMM>isup log error on

OK!

[ISUP]:

Command OK!

...

log status

Usage Guidelines

Use the log status command to display the current active debug setting.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log status command.

CMM>log status

...

cfg

Usage Guidelines

Use the cfg command to change to the configuration oid tree mode.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the cfg command.

CMM>cfg

...

menu

Usage Guidelines

Use the menu command to change to the configuration menu tree mode.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the menu command.

CMM>menu

...

x

Usage Guidelines

Use the x command to return to the main menu.

Syntax Description

This command has no arguments or keywords.

q

Usage Guidelines

Use the q command to exit the current debugging terminal.

Syntax Description

This command has no arguments or keywords.

3.7


EIR

EIR Debug Commands:

· log all
· log none
· information pages
· page 2
· page 3

log all

Usage Guidelines

Use the log all command to display all message flows in the equipment identification processing.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

EIR>log all

...

log none

Usage Guidelines

Use the log none command to disable all equipment identification debugging output.

Syntax Description

This command has no arguments or keywords.

page 2

Usage Guidelines

The EIR debug page 2 displays the statistics of equipment identification procedures.

Examples

The following is page 2 sample output.

Page02

Statistics:

Instance            25 00 00 00

Start Time          49 1A 9E 94

01.AddToBlackSuc    00 00 00 00

02.AddToBlackFail   00 00 00 00

03.AddToGreySuc     00 00 00 00

04.AddToGreyFail    00 00 00 00

05.DelFromBlackSuc  00 00 00 00

06.DelFromBlackFail 00 00 00 00

07.DelFromGreySuc   00 00 00 00

08.DelFromGreyFail  00 00 00 00

09.CheckIMEISuc     00 00 00 00

10.CheckIMEIFail    00 00 00 00

page 3

Usage Guidelines

The EIR debug page 3 displays the information of EIR system setting and subscriber capacity.

Examples

The following is page 3 sample output.

Page03

Para(OID+Name):

1.1 MSISDN          EE EE EE EE EE EE EE EE

1.2 OMC IP0         00 00 00 00

        IP1         00 00 00 00

1.3 EIR IP0         00 00 00 00

        IP1         00 00 00 00

1.6 Max  Licenses   00 00 9C 40

    Used Licenses   00 00 00 00

2.1 Svr Number      00

2.3 Svc State       00

2.5 ImportCtrl      03 00 13 88 00 13 884

3.8


GCP

GCP Debug Commands:

· log all
· log none
· log error [on | off]
· log mg-<domain> [on | off]
· list

log all

Usage Guidelines

Use the log all command to display debugging output from the Media Gateway Control Protocol (MGCP) routines in the system. This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

GCP>log all

Command OK!

Send Message: CRCX 330564408 ds/e1-22/25@172.18.248.1 MGCP 1.0

C: 152049257c64

L: p:20, a:PCMU, nt:IN

M: recvonly

Send Message: DLCX 330629942 ds/e1-11/25@172.18.254.1 MGCP 1.0

C: 12e249257c61

Send Message: DLCX 330695479 ds/e1-11/26@172.18.254.1 MGCP 1.0

C: 12eb49257c61

...

log none

Usage Guidelines

Use the log none command to disable all MGCP debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display MGCP related information only when errors occur. The off form of this command disables debugging output.

This command is useful for troubleshooting call fail problems because it produces little output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

GCP>log error on

Command OK!

mdcx para encode fault

...

log mg

Usage Guidelines

Use the log mg command to track the MGCP transaction process related to a specific media gateway by given its domain name. The off form of this command disables debugging output. Up to 3 media gateways can be traced simultaneously.

Syntax Description

log mg-<domain> [on | off]

domain | Specify a media gateway by domain name.
on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log mg on command.

GCP>log mg-172.18.251.1 on

Command OK!

Send Message: DLCX 292094797 ds/e1-19/11@172.18.251.1 MGCP 1.0

C: 137849257e9a

Send Message: CRCX 292488012 ds/e1-24/9@172.18.251.1 MGCP 1.0

C: 196749257ea3

L: p:20, a:PCMA, nt:IN

M: recvonly

...

list

Usage Guidelines

Use the list command to display media gateways under tracking. Use log none command to disable all tracking.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list command.

GCP>list

MG :172.18.251.1  on

MG :  off

MG :  off

Command OK!

3.9


HLR

HLR Debug Commands:

· log all
· log none
· log error
· log map
· log map c
· log map d
· log map h
· log lu
· log lir
· log sai
· log ss
· log sms
· log smng
· log port <pid>
· log imsi <imsi>
· log msisdn <msisdn>
· list system param
· list imsi <imsi>
· list msisdn <msisdn>
· stat subs
· save hlr subs data
· save ussd conf
· save hlr param
· reload ussd conf
· information pages
· page 1
· page 2

log all

Usage Guidelines

Use the log all command to turn on all of the HLR debug commands simultaneously. It displays debugging information on all HLR component activities.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

HLR>log all

HLR all switch open

HLR recv        <- OPEN ind

Dialogue id:2317

05 03 00 00 00 00 00 00 00 00 04 08 00 04 00 01 00 04 0B 68 57 95 02 00 F0 01 00 00 00 01 01 63 12 AC 00 00 00 01 04 06 00 04 80 01 00 04 0B 68 57 95 19 37 F1 D0 4F E0 BF 4C 01 00

HLR recv        <- OPEN ind

Dialogue id:2781

05 03 00 00 00 00 00 00 00 00 04 08 00 04 00 01 00 04 0B 68 57 95 02 00 F0 01 00 00 00 01 01 63 12 AC 00 00 00 01 04 06 00 04 80 01 00 04 0B 68 57 95 19 39 F5 D0 4F E0 BF 4C 01 00

HLR recv        <- DELIM ind

Dialogue id:2387

...

log none

Usage Guidelines

Use the log none command to disable all HLR debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error command to display HLR related messages only when errors occur. The log none command disables debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log error command.

HLR>log error

...

log map

Usage Guidelines

Use the log map command to display the MAP application-layer message flows occurring in the HLR module. The log none command disables debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log map command.

HLR>log map

HLR MAP switch open

HLR recv        <- OPEN ind

Dialogue id:1664

05 03 00 00 00 00 00 00 00 00 04 08 00 04 00 01 00 04 0B 68 57 95 02 00 F0 01 00 00 00 01 01 63 12 AC 00 00 00 01 04 06 00 04 80 01 00 04 0B 68 57 95 19 18 F1 D0 4F E0 BF 41 01 00

HLR send        -> SndRoutInfo rsp

Dialogue id:2172        Invoke id:64

01 01 00 65 A3 63 89 08 64 00 92 00 00 19 86 F1 A8 3F A0 3D A0 19 30 14 30 12 0A 01 0C 02 01 00 80 07 91 68 57 95 02 10 F2 81 01 00 80 01 00 A1 19 30 14 30 12 0A 01 02 02 01 00 80 07 91 68 57 95 02 10 F2 81 01 00 80 01 02 A3 05 30 03 0A 01 02 A7 16 A0 14 81 07 91 68 57 95 02 00 F1 A3 09 80 07 64 00 20 00 61 00 09 00

HLR send        -> CLOSE req

Dialogue id:2172

01 01 00

...

log map c

Usage Guidelines

Use the log map c command to observe activities between HLR and MSC. Use log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log map c command.

HLR>log map c

HLR MAP-C switch open

MSISDN 86755991846 receives send rout info indicate

MSISDN 86755991588 receives send rout info indicate

MSISDN 86755903987 receives SRI for SM

MSISDN 86755903987 sends SRI for SM response

...

log map d

Usage Guidelines

Use the log map d command to observe activities between HLR and VLR. Use log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log map d command.

HLR>log map d

HLR MAP-D switch open

MSISDN 86755901104 sends PRN to vlr

MSISDN 86755901186 sends PRN to vlr

MSISDN 86755901104 receives PRN response

MSISDN 86755901186 receives PRN response

...

log map h

Usage Guidelines

Use the log map h command to observe activities between HLR and AUC. Use log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log map h command.

HLR>log map h

...

log lu

Usage Guidelines

Use the log lu command to display HLR related messages when location update procedures occur in the system. Use log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log lu command.

HLR>log lu

...

log lir

Usage Guidelines

Use the log lir command to display HLR related messages when location information retrieve procedures proceed in the system. Use log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log lir command.

HLR>log lir

HLR Location Information Retrieve switch open

MSISDN 86755991564 receives send rout info indicate

MSISDN 86755991564 sends PRN to vlr

MSISDN 86755991750 receives send rout info indicate

MSISDN 86755991750 sends PRN to vlr

...

log sai

Usage Guidelines

Use the log sai command to display HLR related messages when authentication information exchange procedures proceed in the system. Use log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log sai command.

HLR>log sai

...

log ss

Usage Guidelines

Use the log ss command to display HLR related messages when supplementary services proceed in the system. Use log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log ss command.

HLR>log ss

...

log sms

Usage Guidelines

Use the log sms command to display HLR related messages when short message services proceed in the system. Use log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log sms command.

HLR>log sms

HLR Short Message Services witch open

MSISDN 86755903726 receives SRI for SM

MSISDN 86755903726 sends SRI for SM response

MSISDN 86755903158 receives SRI for SM

MSISDN 86755903158 sends SRI for SM response

...

log smng

Usage Guidelines

Use the log smng command to display HLR subscriber management processes. Use log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log smng command.

HLR>log smng

...

log port

Usage Guidelines

Use the log port command to display the information of a processing HLR task.

Syntax Description

log port <pid>

pid

Specify a processing task ID.

Examples

The following is sample output from the log port command.

HLR>log port 2

HLR monitor the port of 2

MSISDN 86755991846 receives send rout info indicate

MSISDN 86755991846 responses send rout info with CSI data

MSISDN 86755991850 receives send rout info indicate

MSISDN 86755991850 responses send rout info with CSI data

...

log imsi

Usage Guidelines

Use the log imsi command to track the HLR transaction processes related with a specific subscriber by given its IMSI. Use log none command to disable tracking.

Syntax Description

log imsi <imsi>

imsi

Specify a 15-digit IMSI.

Examples

The following is sample output from the log imsi command.

HLR>log imsi 460029000091550

MSISDN 86755991550 receives send rout info indicate

MSISDN 86755991550 responses send rout info with CSI data

MSISDN 86755991550 receives send rout info indicate

MSISDN 86755991550 sends PRN to vlr

MSISDN 86755991550 receives PRN response

MSISDN 86755991550 responses send rout info with MSRN

...

log msisdn

Usage Guidelines

Use the log msisdn command to track the HLR transaction processes related with a specific subscriber by given its MSISDN. Use log none command to disable tracking.

Syntax Description

log msisdn <msisdn>

msisdn

Specify a valid MSISDN in CC+NDC+SN format.

Examples

The following is sample output from the log msisdn command.

HLR>log msisdn 86755991550

MSISDN 86755991550 receives send rout info indicate

MSISDN 86755991550 responses send rout info with CSI data

MSISDN 86755991550 receives send rout info indicate

MSISDN 86755991550 sends PRN to vlr

MSISDN 86755991550 receives PRN response

MSISDN 86755991550 responses send rout info with MSRN

...

list sys param

Usage Guidelines

Use the list sys param command to display HLR and AUC node numbers.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list sys param command.

HLR>list sys param

--------------------------------------------------------

Now list the system parameter of HLR:

HLR number: 86755920002

AUC number: 86755920003

--------------------------------------------------------

list imsi

Usage Guidelines

Use the list imsi command to display details of a specified HLR subscriber by given its IMSI.

Syntax Description

list imsi <imsi>

imsi

Specify a 15-digit IMSI.

Examples

The following is sample output from the list imsi command.

HLR>list imsi 460029000091550

--------------------------------------------------------

Used flag = 1

IMSI: 460029000091550   MSISDN: 86755991550

Fax num: 0000000000000000       Data num: 0000000000000000

NAM: 0x01               MS category: 0x0a

ODB flag: 0x00          ODB general data: 0x00000000

Bearer: 0x07ffffff      Tele: 0x0f00

CAMEL flag: 0x801f      GPRS flag: 0x0000       MWD status: 00 00 00 00

This subscriber is in network.

VLR number: 86755920001

MSC number: 86755920000

CLI data:       CLIP: 0x04      CLIR: 0x00      COLP: 0x04      COLR: 0x00

BOC data:       BAOC: 0x04      BOIC: 0x04      BOIC_exHPLMN: 0x00

BIC data:       BAIC: 0x04      BIC_Roam: 0x04

CFU data:       State: 0x04     Number :

CFB data:       State: 0x04     Number :

CFNRY data:     State: 0x04     Number :

CFNRC data:     State: 0x04     Number :

Call waiting state: 0x04

Call hold state: 0x04

--------------------------------------------------------

list msisdn

Usage Guidelines

Use the list msisdn command to display details of a specified HLR subscriber by given its MSISDN.

Syntax Description

list msisdn <msisdn>

msisdn

Specify a valid MSISDN in CC+NDC+SN format.

Examples

The following is sample output from the list msisdn command.

HLR>list msisdn 86755991550

--------------------------------------------------------

Used flag = 1

IMSI: 460029000091550   MSISDN: 86755991550

Fax num: 0000000000000000       Data num: 0000000000000000

NAM: 0x01               MS category: 0x0a

ODB flag: 0x00          ODB general data: 0x00000000

Bearer: 0x07ffffff      Tele: 0x0f00

CAMEL flag: 0x801f      GPRS flag: 0x0000       MWD status: 00 00 00 00

This subscriber is in network.

VLR number: 86755920001

MSC number: 86755920000

CLI data:       CLIP: 0x04      CLIR: 0x00      COLP: 0x04      COLR: 0x00

BOC data:       BAOC: 0x04      BOIC: 0x04      BOIC_exHPLMN: 0x00

BIC data:       BAIC: 0x04      BIC_Roam: 0x04

CFU data:       State: 0x04     Number :

CFB data:       State: 0x04     Number :

CFNRY data:     State: 0x04     Number :

CFNRC data:     State: 0x04     Number :

Call waiting state: 0x04

Call hold state: 0x04

--------------------------------------------------------

stat subs

Usage Guidelines

Use the stat subs command to display the overview of HLR capacity.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the stat subs command.

HLR>stat subs

HLR Subscriber's information             User Total Sum [99999 ]

Max User Numer             : 100000      Provisioned Subs stat      : 99999

Max Licenses Number        : 100000      Used Licence Number        : 99999

Registered Subs stat       : 90919       Roaming Subsribers stat    : 90919

IMSI    Index Table Length : 99999       ISDN    Index Table Length : 99999

FaxNum  Index Table Length : 0           DataNum Index Table Length : 0

save hlr subs data

Usage Guidelines

Use the save hlr subs data command to save HLR subscriber data to hard disk.

Syntax Description

This command has no arguments or keywords.

save ussd conf

Usage Guidelines

Use the save ussd conf command to save USSD parameters residing in memory to hard disk.

Syntax Description

This command has no arguments or keywords.

save hlr param

Usage Guidelines

Use the save hlr param command to save HLR system parameters residing in memory to hard disk.

Syntax Description

This command has no arguments or keywords.

reload ussd conf

Usage Guidelines

Use the reload ussd conf command to reload USSD parameters and initialize USSD status.

Syntax Description

This command has no arguments or keywords.

page 1

Usage Guidelines

The HLR debug page 1 displays the information of HLR system parameters.

Examples

The following is page 1 sample output.

R9V2_00B0 Page 01  HLR Conf and State

System ID          00

MCC                04 60

MNC                02 EE

CC                 66 EE

NDC                75 5E EE

Inter Prefix       00 EE

National Prefix    0E EE

HLR Number         91 66 75 59 00 00 3E EE EE

AUC Number         91 66 75 59 00 02 2E EE EE

UG-CSI gsmSCF Num  91 66 75 59 00 01 0E EE EE

UG-CSI ServiceCode 01 11

HLR state          00

CDR Control        00

USSD Control       64

GR Control         64

Used TCAP DID      00 00 00 00

HLR DID static     00 00 00 00

HLR SID NUM        00 00 00 00

Sync percent       00 00

page 2

Usage Guidelines

The HLR debug page 2 displays the information of HLR capacity and statistic information.

Examples

The following is page 2 sample output.

R9V2_00B0 Page 02  HLR Conf and State

Max User           00 04 00 00

Max  Licenses      00 02 00 00

Used Licenses      00 00 00 04

Provisioned Subs   00 00 00 04

Registered  Subs   00 00 00 04

Roaming Subs       00 00 00 04

imsi tlen          00 00 00 04

isdn tlen          00 00 00 04

fax tlen           00 00 00 00

data tlen          00 00 00 00

send psync msg     00 00 00 02

send psync circle  00 02 25 48

recv psync msg     00 00 00 00

recv psync circle  00 00 00 50

index err counter  00 00 00 00

resort counter     00 00 00 00

3.10


iPALIM

iPALIM Debug Commands:

· log all
· log none
· log error [on | off]
· log info [on | off]
· log warn [on | off]
· list imsi <imsi>
· log record -f <file>
· print sysConfig
· print tg <tg>
· print user list
· print mg <mg>
· print lac <lac>
· print task list
· print syc task list
· print csta
· csta clear
· print tmsi list
· purge all
· read user config

log all

Usage Guidelines

Use the log all command to turn on all of the iPALIM debug commands simultaneously. It displays debugging information on all iPALIM component activities.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

PALIM>log all

...

log none

Usage Guidelines

Use the log none command to disable all iPALIM debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display iPALIM related messages only when errors occur in the network. The off form of this command disables debugging output.

This command is useful for troubleshooting call fail problems because it produces little output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

PALIM>log error on

...

log info

Usage Guidelines

Use the log info on command to enable iPALIM event debugging. The off form of this command disables debugging output.

Syntax Description

log info [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log info on command.

PALIM>log info on

...

log warn

Usage Guidelines

Use the log warn on command to display iPALIM warning information. The off form of this command disables debugging

Syntax Description

log warn [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log warn on command.

PALIM>log warn on

...

list imsi

Usage Guidelines

Use the list imsi command to display details of a specified iPALIM subscriber by given its IMSI.

Syntax Description

list imsi <imsi>

imsi

Specify a 15-digit IMSI.

Examples

The following is sample output from the list imsi command.

PALIM>list imsi 460029000000355

LOG:<user2>

 <imsi>460029000000355</imsi>

 <tmsi>1*000036</tmsi>

 <msisdn></msisdn>

 <msisdn_local>66755900061</msisdn_local>

 <mcc>4.6.0</mcc>

 <mnc>6.6.15</mnc>

 <lac>134</lac>

 <ci>2</ci>

 <type>hybrid</type>

</user2>

command ok

log record -f

Usage Guidelines

Use the log record -f command to save debugging output to a specified file.

Syntax Description

log record -f <file>

file

Specify name to a file which will be created in the /usr/local/wxc2/bin.

Examples

The following is sample output from the print record -f command.

PALIM>log record -f test.log

...

print sysConfig

Usage Guidelines

Use the print sysConfig command to display iPALIM system configuration.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the print sysConfig command.

PALIM>print sysConfig

LOG:<palim_sysconfig>

 <mcc>4.6.0</mcc>

 <mnc>6.6.15</mnc>

 <maxlicense>10000</maxlicense>

 <usedlicense>10000</usedlicense>

 <pstn_route>PALIM_ROUTE_REMOTE</pstn_route>

 <emergency_route>PALIM_ROUTE_REMOTE</emergency_route>

 <ues_flag>DISABLE</ues_flag>

 <public_forbid>DISABLE</public_forbid>

 <private_forbid>DISABLE</private_forbid>

 <hybrid_forbid>DISABLE</hybrid_forbid>

 <hybrid_priority>ENABLE</hybrid_priority>

   <hotline_0>800</hotline_0>

   <hotline_1></hotline_1>

   <hotline_2></hotline_2>

   <hotline_3></hotline_3>

   <hotline_4></hotline_4>

   <hotline_5></hotline_5>

   <hotline_6></hotline_6>

   <hotline_7></hotline_7>

   <mtIsdn_0>66355900181</mtIsdn_0>

   <mtIsdn_1>66355900124</mtIsdn_1>

   <mtIsdn_2></mtIsdn_2>

   <mtIsdn_3></mtIsdn_3>

   <mtIsdn_4></mtIsdn_4>

   <mtIsdn_5></mtIsdn_5>

   <mtIsdn_6></mtIsdn_6>

   <mtIsdn_7></mtIsdn_7>

 <smc>66355920004</smc>

 <maxUser>40000</maxUser>

 <purge>0</purge>

</palim_sysconfig>

LOG:WORK_DUAL

command ok

print tg

Usage Guidelines

Use the print tg command to display a specified trunk group's states, attributes and trunks info.

Syntax Description

print tg <tg>

tg

Specify a trunk group by its ID.

Examples

The following is sample output from the print tg command.

PALIM>print tg 1

LOG:       type | index |      admin | proto |   opc |   dpc |   aif |  mtp3

LOG:  PALIM_OUT |     1 |     unlock |   AIF |     4 |     9 |     3 | ENABLE

LOG:index |  mgNo | portId |   cic | status

LOG:    1 |     1 |      0 |     0 |   OFF

command ok

print user list

Usage Guidelines

Use the print user list command to display the information of all iPALIM subscribers.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the print user list command.

PALIM>print user list

LOG:           IMSI |    TYPE | TMSI | PUB_ISDN |  LOCAL_ISDN |   LAC |    CI |   MCC |   MNC

LOG:460029000000000 | private |      |          | 66755900500 | 65535 | 65535 | 0.0.0 | 0.0.0

LOG:460029000000001 | private |      |          | 66755900501 | 65535 | 65535 | 0.0.0 | 0.0.0

LOG:460029000000002 | private |      |          | 66755900502 | 65535 | 65535 | 0.0.0 | 0.0.0

...

print mg

Usage Guidelines

Use the print mg command to display details of a specified iPALIM media gateway.

Syntax Description

print mg <mg>

mg

Specify index number of an iPALIM media gateway.

Examples

The following is sample output from the print mg command.

PALIM>print mg 1

LOG:mg[1] MG_CTL_PALIM  title HPLMN mgcSocket 10

LOG:<MG_1>

 <index>1</index>

 <title>HPLMN</title>

 <userType>MGC_USER_TYPE_MG</userType>

 <ctl>MG_CTL_PALIM</ctl>

 <admin>unlock</admin>

 <attr>

   <ptime>20</ptime>

   <mgType>MGC_MG_TYPE_PALIM</mgType>

   <ctrlType>MGC_MG_CTRL_TYPE_MGCP</ctrlType>

   <epDes>1</epDes>

   <toneCap>0</toneCap>

   <maxPort>1</maxPort>

   <maxChnl>32</maxChnl>

   <ip>155.226.202.65</ip>

   <domain>155.226.202.65</domain>

   <e1cardNo>0</e1cardNo>

   <auditTimer>0</auditTimer>

   <codec_num>1</codec_num>

     <codec_0>GSM-EFR</codec_0>

     <codec_1>UNSUPPORT</codec_1>

     <codec_2>UNSUPPORT</codec_2>

     <codec_3>UNSUPPORT</codec_3>

     <codec_4>UNSUPPORT</codec_4>

     <codec_5>UNSUPPORT</codec_5>

     <codec_6>UNSUPPORT</codec_6>

     <codec_7>UNSUPPORT</codec_7>

     <codec_8>UNSUPPORT</codec_8>

     <codec_9>UNSUPPORT</codec_9>

     <codec_10>UNSUPPORT</codec_10>

     <codec_11>UNSUPPORT</codec_11>

     <codec_12>UNSUPPORT</codec_12>

     <codec_13>UNSUPPORT</codec_13>

 </attr>

</MG_1>

command ok

print lac

Usage Guidelines

Use the print lac command to display details of a specified location area and its cells.

Syntax Description

print lac <lac>

lac

Specify location area code of the target location area.

Examples

The following is sample output from the print lac command.

PALIM>print lac 134

LOG:            type |   lac |        mcc |        mnc

LOG:   PALIM_LAC_OUT |   134 |   4.  6. 0 |   6.  6.15

LOG:  cell | tgIndex

LOG:     2 |     1

command ok

print task list

Usage Guidelines

Use the print task list command to list active call tasks processing in the monitored iPALIM.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the print task list command.

PALIM>print task list

...

print syc task list

Usage Guidelines

Use the print syc task list command to list active synchronization tasks processing in the monitored iPALIM.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the print syc task list command.

PALIM>print syc task list

...

print csta

Usage Guidelines

Use the print csta command to display iPALIM statistics since the last data initialization.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the print csta command.

PALIM>print csta

LOG:---------------1 , TG-1  current zone 63---------------

LOG:     LU |ATTEMP |SUCCESS |NORMAL |RES_FAIL |SER_FAIL |SER_ERR |MSG_ERR |PRO_ERR

LOG: RESULT |     0 |      0 |     0 |       0 |       0 |      0 |      0 |      0

LOG:     MO |ATTEMP |SUCCESS |NORMAL |DENY |NET_FAIL |LOC_CLR |PEER_ERR |NO_ANS |SIG_ERR

LOG: RESULT |     0 |      0 |     0 |   0 |       0 |      0 |       0 |     0 |      0

LOG:     MT |ATTEMP |SUCCESS |NORMAL |DENY |NET_FAIL |LOC_CLR |PEER_ERR |NO_ANS |SIG_ERR

LOG: RESULT |     0 |      0 |     0 |   0 |       0 |      0 |       0 |     0 |      0

LOG:    SMO |ATTEMP |SUCCESS |NORMAL |SUB_ERR |SER_ERR |NET_ERR |MSG_ERR |PRO_ERR |RES_ERR

LOG: RESULT |     0 |      0 |     0 |      0 |      0 |      0 |      0 |      0 |      0

LOG:    SMT |ATTEMP |SUCCESS |NORMAL |SUB_ERR |SER_ERR |NET_ERR |MSG_ERR |PRO_ERR |RES_ERR

LOG: RESULT |     0 |      0 |     0 |      0 |      0 |      0 |      0 |      0 |      0

LOG:-----------------------end---------------------------

LOG:---------------1 , TG-1  current zone 63---------------

LOG:req_fail 0

LOG:page_attemp 0

LOG:page_fail 0

LOG:intra_ho_success 0

LOG:intra_ho_failure 0

LOG:inter_handover_success 0

LOG:-----------------------end---------------------------

command ok

csta clear

Usage Guidelines

Use the csta clear command to initialize iPALIM statistics data.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the csta clear command.

PALIM>csta clear

command ok

print tmsi list

Usage Guidelines

Use the print tmsi list command to display the information of all iPALIM subscribers with assigned TMSI.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the print tmsi list command.

PALIM>print tmsi list

...

purge all

Usage Guidelines

Use the purge all command to perform purging procedures on all iPALIM public users.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the purge all command.

PALIM>purge all

command ok

read user config

Usage Guidelines

Use the read user config command to reload iPALIM subscriber data from configuration file (palim_user.config).

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the read user config command.

PALIM>read user config

command ok

3.32


iRLS

iRLS Debug Commands:

· log all
· log none
· log error
· list mg
· list port
· list port-<pid>
· list rz

log all

Usage Guidelines

Use the log all command to turn on all of the iRLS debug commands simultaneously. It displays debugging information on all local switching activities.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

RLS>log all

...

log none

Usage Guidelines

Use the log none command to disable all iRLS debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error command to display iRLS related messages only when errors occur in the network. The log none command disables debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log error command.

RLS>log error

...

list mg

Usage Guidelines

Use the list mg command to display details of all configured VIM media gateways.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list mg command.

RLS>list mg

Indexmg Admin   Title   Demain  MaxPorts

1       0       MG-1    vim-0   2

Command OK!

list port

Usage Guidelines

Use the list port command to display the information of all processing iRLS tasks.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list port command.

RLS>list port

PID     Flag    Peer    Cflag   Rz      UUI     Caller  Called

...

list port-

Usage Guidelines

Use the list port- command to display the information of a processing iRLS task.

Syntax Description

list port-<pid>

pid

Specify a processing task ID.

Examples

The following is sample output from the list mg command.

RLS>list port-12

...

list rz

Usage Guidelines

Use the list rz command to display the information of all 32 iRLS routing zones.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list rz command.

RLS>list rz

list rz

RZ_Id   Remote(1)\Local(0)

1       1

2       1

...

3.33


IIF

IIF Debug Commands:

· log all
· log none
· log error [on | off]
· log hi1 [on | off]
· log hi2 [on | off]
· log hi3 [on | off]
· log msg [on | off]

log all

Usage Guidelines

Use the log all command to display all debugging output of the lawful call interception processing.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

IIF>log all

...

log none

Usage Guidelines

Use the log none command to disable all lawful call interception debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display lawful call interception related information only when errors occur. The off form of this command disables debugging output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

IIF>log error on

[pid 0] error: iif target msisdn is NULL!

[pid 0] error: iif target msisdn is NULL!

[pid 0] error: iif target msisdn is NULL!

...

log hi1

Usage Guidelines

Use the log hi1 on command to display lawful call interception administrative information. The off form of this command disables debugging output.

Syntax Description

log hi1 [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log hi1 on command.

IIF>log hi1 on

...

log hi2

Usage Guidelines

Use the log hi2 on command to display lawful call interception call data and signaling. The off form of this command disables debugging output.

Syntax Description

log hi2 [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log hi2 on command.

IIF>log hi2 on

...

log hi3

Usage Guidelines

Use the log hi3 on command to display lawful call interception communication content. The off form of this command disables debugging output.

Syntax Description

log hi3 [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log hi3 on command.

IIF>log hi3 on

...

log msg

Usage Guidelines

Use the log msg on command to enable call interception event debugging. The off form of this command disables debugging output.

Syntax Description

log msg [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log msg on command.

IIF>log msg on

...

3.11


IPTrans

IPTRANS Debug Commands:

· log all
· log none
· log error [on | off]
· log src <port>
· log dst <port>
· log src <port1> and dst <port2>
· set on <port>=<capability>
· information pages
· page 1
· page 2
· page 3

log all

Usage Guidelines

Use the log all command to display all messages processing in the IP transaction layer. This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

IPTR>log all

Read Subscript: 082 Write Subscript: 083 Port: 4964

Current time: Fri Nov 21 11:32:38 2008

got packet from 172.18.98.1 4964 #0

packet is 100 bytes (chars) long, contains:

30 62 02 01 01 04 06 70 75 62 6C 69 63 A7 55 02 01 01 02 01 00 02 01 00 30 4A 3048 06 10 2B 06 01 04 01 8A 5D 02 03 03 0C 02 04 83 AC 62 04 34 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 0000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

...

log none

Usage Guidelines

Use the log none command to disable all IPTRANS debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display errors occurring in the IP transaction layer. The off form of this command disables debugging output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

IPTR>log error on

...

log src

Usage Guidelines

Use the log src command to track IP packets transit form a specific port. Use the log none command to disable debugging output.

Syntax Description

log src <port>

port

Specify a source port.

Examples

The following is sample output from the log src command.

IPTR>log src 4957

Read Subscript: 028 Write Subscript: 029 Port: 4957

Current time: Fri Nov 21 11:34:25 2008

got packet from 172.18.98.1 4957 #0

packet is 45 bytes (chars) long, contains:

30 2B 02 01 01 04 06 70 75 62 6C 69 63 A7 1E 02 01 01 02 01 00 02 01 00 30 13 3011 06 0C 2B 06 01 04 01 8A 5D 02 03 03 01 06 04 01 01

...

log dst

Usage Guidelines

Use the log dst command to track IP packets transit to a specific port. Use the log none command to disable debugging output.

Syntax Description

log dst <port>

port

Specify a destination port.

Examples

The following is sample output from the log dst command.

IPTR>log dst 4957

Read Subscript: 422 Write Subscript: 423 Port: 4957

Current time: Fri Nov 21 11:34:49 2008

Sent packet to 172.18.98.1 4957 #0

packet is 48 bytes long, contains:

30 2E 02 01 01 04 06 70 75 62 6C 69 63 A7 21 02 01 01 02 01 00 02 01 00 30 16 3014 06 0F 2B 06 01 04 01 8A 5D 02 03 03 01 05 00 06 12 04 01 00

...

log src and dst

Usage Guidelines

Use the log src and dst command to track IP packets transit from the source port to the destination port. Use the log none command to disable debugging output.

Syntax Description

log src <port1> and dst <port2>

port1 | Specify the source port.
port2 | Specify the destination port.

Examples

The following is sample output from the log src and dst command.

IPTR>log src 4957 and dst 4957

Read Subscript: 296 Write Subscript: 296 Port: 4957

Current time: Fri Nov 21 11:35:07 2008

Sent packet to 172.18.98.1 4957 #0

packet is 45 bytes long, contains:

30 2B 02 01 01 04 06 70 75 62 6C 69 63 A7 1E 02 01 01 02 01 00 02 01 00 30 13 3011 06 0C 2B 06 01 04 01 8A 5D 02 03 03 01 06 04 01 02

...

set on

Usage Guidelines

Use the set on command to change the packet transit capability of a specified port.

Syntax Description

set on <port>=<capability>

port | Specify a port.
capability | IP packets transit capability from 0 to 6. Set 0 to disable the port.

Examples

The following is sample of set on command.

IPTR>set on 4970=3

page 1

Usage Guidelines

The IPTRANS debug page 1 displays the IP packet transit capability from port 4950 to 4981.

Examples

The following is page 1 sample output.

IPTRANS         Version R9V0_01                         Page 01

Port state      00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F

Port Status

4950-4965       06 00 03 03 03 03 03 04 02 02 03 00 00 00 02 03

4966-4981       03 03 02 03 03 06 02 03 00 00 00 00 00 00 00 00

Port Overflow

4950-4965       00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

4966-4981       00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

page 2

Usage Guidelines

The IPTRANS debug page 2 displays the packet statistic from port 4950 to 4965.

Examples

The following is page 2 sample output.

IPTRANS         Version  R9V0_01                                    Page 02

Flow Statistics (PORT 4950 - 4965)

PortNo          Received                Sent                    Error

                Packets     Bytes       Pakcets     Bytes       Packets

4950            9D D8 00 00 D1 93 49 00 BA EF 00 00 55 A7 47 00 10 00 00 00

4951            00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

4952            00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

4953            C8 82 00 00 68 CE 9C 00 00 00 00 00 00 00 00 00 00 00 00 00

4954            00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

4955            00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

4956            00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

4957            AC 55 06 00 9D 2B 13 04 29 33 09 00 2C CB BB 05 00 00 00 00

4958            00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

4959            00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

4960            00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

4961            00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

4962            00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

4963            00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

4964            CB 73 01 00 CC FA 90 00 00 00 00 00 00 00 00 00 00 00 00 00

4965            8E 00 00 00 85 02 00 00 F5 0F 00 00 FC 77 05 00 00 00 00 00

page 3

Usage Guidelines

The IPTRANS debug page 3 displays the packet statistic from port 4966 to 4981.

Examples

The following is page 3 sample output.

IPTRANS         Version R9V0_01                                     Page 03

Flow Statistics (PORT 4966 - 4981)

PortNo          Received                Sent                    Error

                Packets     Bytes       Pakcets     Bytes       Packets

4966            2A 0E 00 00 93 84 01 00 3B 79 00 00 39 EC 40 00 00 00 00 00

4967            D2 75 00 00 B1 5A 34 00 96 0F 00 00 78 B7 01 00 00 00 00 00

4968            00 00 00 00 00 00 00 00 0A 01 00 00 C1 60 00 00 00 00 00 00

4969            05 23 00 00 9D DA 93 00 FC 22 00 00 9C B4 93 00 00 00 00 00

4970            9A 4C 00 00 09 6A C7 00 ED 29 00 00 12 12 6D 00 00 00 00 00

4971            78 3E 02 00 91 C1 2D 03 21 F2 00 00 84 C9 2B 01 00 00 00 00

4972            05 23 00 00 1D DE 93 00 FC 22 00 00 1C B8 93 00 00 00 00 00

4973            DA 21 00 00 E4 12 8F 00 00 00 00 00 00 00 00 00 00 00 00 00

4974            03 00 00 00 06 00 00 00 01 00 00 00 04 00 00 00 01 00 00 00

4975            01 00 00 00 01 00 00 00 02 00 00 00 03 00 00 00 01 00 00 00

4976            02 00 00 00 01 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

4977            00 00 00 00 01 00 00 00 01 00 00 00 03 00 00 00 06 00 00 00

4978            04 00 00 00 01 00 00 00 5D 05 00 00 01 00 00 00 01 00 00 00

4979            03 00 00 00 01 00 00 00 02 00 00 00 02 00 00 00 03 00 00 00

4980            00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 01 00 00 00

4981            06 00 00 00 01 00 00 00 04 00 00 00 01 00 00 00 5D 05 00 00

3.12


ISDN

ISDN Debug Commands:

· log all
· log none
· log error [on | off]
· log state [on | off]
· list cg
· list cg-<cg>
· list circuit-<circuit>

log all

Usage Guidelines

Use the log all command to display debugging output from the Integrated Services Digital Network (ISDN) protocol routines in the system.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

ISDN>log all

Command OK!

[17:35:28.761109]RV=> msg send to originating side

Release complete(message type=0x5a)

--cic=0x01e1,cref=0x70a6,link=175,proto=8,pid=3585->

08 02 83 90

[17:35:28.790269]RV=> msg send to originating side

Disconnect(message type=0x45)

--cic=0x01e2,cref=0x70a7,link=175,proto=8,pid=3586->

08 02 83 90

[17:35:28.800231]RV=> msg send from originating side

Connect acknowledge(message type=0xf)

--cic=0x011d,cref=0x1786,link=168,proto=8,pid=3389->

[17:35:28.804371]SD<= msg send to originating side

Disconnect(message type=0x45)

--cic=0x01d6,cref=0x173a,link=174,proto=8,pid=3574->

08 02 84 90

...

log none

Usage Guidelines

Use the log none command to disable all ISDN debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display ISDN related information only when errors occur. The off form of this command disables debugging output.

This command is useful for troubleshooting call fail problems because it produces little output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

ISDN>log error on

...

log state

Usage Guidelines

Use the log state on command to display ISDN circuit state information. The off form of this command disables debugging output.

Syntax Description

log state [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log state on command.

ISDN>log state on

...

list cg

Usage Guidelines

Use the list cg command to display overview of all ISDN circuit groups in the system.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list cg command.

ISDN>list cg

CgId    SapId   CircirtNum      Variant Prior   TgId    NFAS    PRI     BackUp

6       4       16              0       1       27      0       0       0

Command OK!

list cg-

Usage Guidelines

Use the list cg- command to display details of a specified ISDN circuit group.

Syntax Description

log cg-<cg>

cg

Specify a circuit group by index.

Examples

The following is sample output from the list cg- command.

ISDN>list cg-6

               #ISDN CG- 6 Info

               enable:1

               sap_id:4

               circuit_num:16

               Attrib-->

               variant_type(0)

               priority(1)

               tg_id(27)

               NFAS(0)

               pri_link(0)

               backup_link(0)

               ---------------------

--->circuit:

CircuitId       CgId    PlatId  HeatCic Range   D_Chnl  LinkId  Lk2Status      Lk3Status        DcStatus

97              6       0       0       32      16      40      0              00

98              6       0       32      32      16      41      0              00

...

list circuit-

Usage Guidelines

Use the list circuit- command to display details of a specified ISDN circuit.

Syntax Description

log circuit-<circuit>

circuit

Specify a circuit by index.

Examples

The following is sample output from the list circuit- command.

ISDN>list circuit-98

               #ISDN Circuit-98 Info

               enable:1

               cg_id:6

               Attrib->

               plat_id(0)

               head_cic(32)

               cic_range(32)

               d_channel(16)

               link_id(41)

               lk2_status(0)

               lk3_status(0)

               dc_status(0)

               -------------------

-->port:

CIC     Port    SuID    call_state      main_state      cpc_state       m_state

32      3136    0       0               0               0               0

33      3137    0       0               0               0               0

...

3.13


ISUP

ISUP Debug Commands:

· log all
· log none
· log error [on | off]
· log state [on | off]
· list cg
· list cg-<cg>
· list circuit-<circuit>
· list port-<port>

log all

Usage Guidelines

Use the log all command to display debugging output from the ISDN User Part (ISUP) protocol routines in the system.

This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

ISUP>log all

Command OK!

[17:33:30.668019]RV=> REL:Release(message type=0xc)--cic=0x27d,dpc=1,opc=32,ni=2,pid=1725->

0c 02 00 02 85 90

[17:33:30.668048]APP => function trace: isup_release_ind

(pid=1725)

[17:33:30.668056]RV=> ACM:Address complete(message type=0x6)--cic=0x32d,dpc=1,opc=32,ni=2,pid=1901->

06 00 14 00

[17:33:30.668067]APP => function trace: isup_alert_ind

(pid=1901)

[17:33:30.673310]APP => function trace: isup_release_req

(pid=1666)

...

log none

Usage Guidelines

Use the log none command to disable all ISUP debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display ISUP related information only when errors occur. The off form of this command disables debugging output.

This command is useful for troubleshooting call fail problems because it produces little output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

ISUP>log error on

...

log state

Usage Guidelines

Use the log state on command to display ISUP circuit state information. The off form of this command disables debugging output.

Syntax Description

log state [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log state on command.

ISUP>log state on

Command OK!

->port:

CIC  Port  SuID      call  sus  blo  cpc  blr  bls  mgbs  mgbr  crs  crr  cgrs  cgrr

589  1677  16175(0)  0     0    0    0    0    0    0     0     0    0    0     0

->port:

CIC  Port  SuID      call  sus  blo  cpc  blr  bls  mgbs  mgbr  crs  crr  cgrs  cgrr

867  1955  17083(0)  2     0    2    3    2    0    0     0     0    0    0     0

...

list cg

Usage Guidelines

Use the list cg command to display overview of all ISUP circuit groups in the system.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list cg command.

ISUP>list cg

CgId    SapId   DPC     OPC     NI      Variant Prior   TgId

1       2       247     1       2       0       0       3

3       2       32      1       2       3       1       8

4       2       25      24      2       0       1       24

5       2       24      25      2       0       1       25

7       2       512     8       1       0       1       28

...

list cg-

Usage Guidelines

Use the list cg- command to display details of a specified ISUP circuit group.

Syntax Description

log cg-<cg>

cg

Specify a circuit group by index.

Examples

The following is sample output from the list cg- command.

ISUP>list cg-3

CgId    SapId   DPC     OPC     NI      Variant Prior   TgId

3       2       32      1       2       3       1       8

->circuit:

ID      CgID    PlatNo  HeadCIC Range   Enable

34      3       0       0       32      1

35      3       0       32      32      1

36      3       0       64      32      1

37      3       0       96      32      1

...

list circuit-

Usage Guidelines

Use the list circuit- command to display details of a specified ISUP circuit.

Syntax Description

log circuit-<circuit>

circuit

Specify a circuit.

Examples

The following is sample output from the list circuit- command.

ISUP>list circuit-34

Circuit CgID    PlatNo  HeadCIC Range   Enable

34      3       0       0       32      1

->port:

CIC  Port  SuID      call  sus  blo  cpc  blr  bls  mgbs  mgbr  crs  crr  cgrs  cgrr

0    1088  0(0)      0     0    0    0    0    0    0     0     0    0    0     0

1    1089  0(0)      0     0    0    0    0    0    0     0     0    0    0     0

2    1090  0(0)      0     0    0    0    0    0    0     0     0    0    0     0

...

list port-

Usage Guidelines

Use the list port- command to display details of a specified ISUP port.

Syntax Description

log port-<port>

port

Specify a port by index.

Examples

The following is sample output from the list port- command.

ISUP>list port-1088

       #ISUP  CG   Info

               cg_id=3

               sap_id=2

               Attrib->

               variant_type(3)

               priority(1)

               network_id(2)

               dpc(32)

               opc(1)

               tg_id(8)

       -------------------

       #ISUP  CIRCUIT   Info

               circuit_id=34

               cg_id=3

               Attrib->

               plat_id(0)

               head_cic(0)

               cic_range(32)

       -------------------

       #ISUP  PORT   Info

               pid=1088

               su_proc_id=0

               sm_proc_id=0

               ---------------

               call_state=0

               sus_state=0

               blo_state=0

               ---------------

               cpc_state=0

               blr_state=0

               bls_state=0

               mgbs_state=0

               mgbr_state=0

               crs_state=0

               crr_state=0

               cgrs_state=0

               cgrr_state=0

       -------------------

Command OK!

3.14


MGC

MGC Debug Commands:

· log all
· log none
· log error [on | off]
· log info [on | off]
· log warn [on | off]
· print mg <id | domain>
· print tandem status
· log record -f <file>

log all

Usage Guidelines

Use the log all command to display debugging output of media gateway control processes. This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

MGC>log all

Command OK!

DEBUG:func mgc_connect_chnl

DEBUG:Org mg[8]port[22]chnl[27]conNo[0]  ==> conn[1015]

DEBUG:mgcPort[1164]step[1] set conn[1024] to do MGC_CMD_MDCX

DEBUG:mgcPort[1164] set MGC_OPER_ID_CONNECT_CHNL

INFO:mgc_connect_chnl mg[8]port[22]chnl[27]conNo[0] and mg[8]port[27]chnl[26]conNo[0] ==> MGC_OPER_ID_CONNECT_CHNL

DEBUG:func mgc_connect_chnl

DEBUG:Org mg[8]port[22]chnl[28]conNo[0]  ==> conn[1016]

DEBUG:Dest mg[8]port[27]chnl[25]conNo[0]  ==> conn[1030]

DEBUG:mgcPort[1165]step[0] set conn[1016] to do MGC_CMD_MDCX

...

log none

Usage Guidelines

Use the log none command to disable all MGC debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display media gateway control related information only when errors occur. The off form of this command disables debugging output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

MGC>log error on

Command OK!

ERROR:mg[1]port[255]chnl[1]conNo[0] MGC_CMD_CRCX get 509 mgcPort[5644]step[0] MGC_OPER_ID_CONNECT_TONE

ERROR:req cnf failure!

ERROR:mgcPort[5644] MGC_OPER_ID_CONNECT_TONE failure

ERROR:mgcPort[5644]step[0] is not in the list!

ERROR:mg[1]port[255]chnl[1]conNo[0] still has 1 step to be done!

ERROR:mg[21]port[12]chnl[14]conNo[0] MGC_CMD_MDCX get 406 mgcPort[5643]step[1] MGC_OPER_ID_CONNECT_CHNL

...

log info

Usage Guidelines

Use the log info on command to enable MGC event debugging. The off form of this command disables debugging output.

Syntax Description

log info [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log info on command.

MGC>log info on

Command OK!

INFO:release virtual mg[0]port[37]chnl[500]connNo[0]

INFO:mgc_dlcx_chnl mg[19]port[26]chnl[2]conNo[0] ==> MGC_OPER_ID_DLCX

INFO:mgc_connect_chnl mg[19]port[26]chnl[27]conNo[0] and mg[19]port[13]chnl[7]conNo[0] ==> MGC_OPER_ID_CONNECT_CHNL

INFO:mgc_connect_chnl mg[19]port[13]chnl[10]conNo[0] and mg[19]port[26]chnl[30]conNo[0] ==> MGC_OPER_ID_CONNECT_CHNL

INFO:mgc_connect_tone mg[5]port[25]chnl[26]conNo[0] ==> MGC_OPER_ID_CONNECT_TONE

INFO:mgc_connect_chnl mg[8]port[29]chnl[2]conNo[0] and mg[8]port[22]chnl[2]conNo[0] ==> MGC_OPER_ID_CONNECT_CHNL

...

log warn

Usage Guidelines

Use the log warn on command to display MGC warning information. The off form of this command disables debugging

Syntax Description

log warn [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log warn on command.

MGC>log warn on

Command OK!

WARN:lost sdp

WARN:mg[19]port[17]chnl[9]conNo[0] suspend by mgcPort[4696]step[1] MGC_OPER_ID_CONNECT_TONE!

WARN:lost sdp

WARN:mg[19]port[17]chnl[9]conNo[0] suspend by mgcPort[4696]step[2] MGC_OPER_ID_CONNECT_TONE!

WARN:internal usrport[29898] lost owner

...

print mg

Usage Guidelines

Use the print mg command to display details of a specified media gateway.

Syntax Description

print mg <id | domain>

id | Specify index number of a media gateway.
domain | Specify domain name of a media gateway.

Examples

The following is sample output from the print mg command.

MGC>print mg 2

INFO:--------mgInfo[2] DISABLE---------

INFO:Domain : 172.18.136.1

INFO:Type : MGC_MG_TYPE_SSW_CSS

INFO:Ip : 172.18.136.1

INFO:CTL TYPE : MGC_MG_CTRL_TYPE_MGCP

INFO:epDes : MGCP_EP_NAME_STRUCTURED

INFO:tonCap : ON

INFO:ptime : 0

INFO:audit time : 1000

INFO:e1cardNo : 0

INFO:maxPort : 8

INFO:maxChnl : 0

INFO:codelist len 8 : PCMA PCMA PCMA PCMA PCMA PCMA PCMA PCMA

INFO:mgInfo[2]Port[1] ==>> mgcPhyPort[3]

INFO:mgInfo[2]Port[1] ==>> MSC MGC_USER_TYPE_MGC

INFO:mgInfo[2]Port[1] off

INFO:  ChnlNo      Status        Mode       Codec               LocalIP

INFO:chnl[00]        IDLE    INACTIVE     UNKNOWN             0.0.0.0:0

INFO:chnl[01]        IDLE    INACTIVE     UNKNOWN             0.0.0.0:0

INFO:chnl[02]        IDLE    INACTIVE     UNKNOWN             0.0.0.0:0

INFO:chnl[03]        IDLE    INACTIVE     UNKNOWN             0.0.0.0:0

INFO:chnl[04]        IDLE    INACTIVE     UNKNOWN             0.0.0.0:0

INFO:chnl[05]        IDLE    INACTIVE     UNKNOWN             0.0.0.0:0

...

print tandem status

Usage Guidelines

Use the print tandem status command to display used tandem status.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the print tandem status command.

MGC>print tandem status

log record -f

Usage Guidelines

Use the log record -f command to save debugging output to a specified file.

Syntax Description

log record -f <file>

file

Specify name to a file which will be created in the /usr/local/wxc2/bin.

Examples

The following is sample output from the print record -f command.

MGC>log record -f test.log

...

3.15


MNP

MNP Debug Commands:

· log all
· log none
· log error [on | off]
· log msisdn=<msisdn>
· log msisdn off
· log msg [on | off]
· list index
· list subs
· delete sub=<msisdn>
· information pages
· page 1
· page 2
· page 3
· page 4

log all

Usage Guidelines

Use the log all command to activate the log error and log msg commands simultaneously. It displays debugging information on all MNP component activities. .

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

MNP>log all

MNP_SRF received SCCP message

- SCCP Address

-- src: DPC+SSN=0000 + 08, TT+NP=00+01, GT:86755920004

-- dst: DPC+SSN=0000 + 06, TT+NP=00+01, GT:86755903653

- TCAP message length: 73

-- message flow:

62 47 48 04 01 63 09 6F 6B 1E 28 1C 06 07 00 11

86 05 01 01 01 A0 11 60 0F 80 02 07 80 A1 09 06

07 04 00 00 01 00 14 03 6C 1F A1 1D 02 01 40 02

01 2D 30 15 80 07 91 68 57 95 30 56 F3 81 01 01

82 07 91 68 57 95 02 00 F4

...

log none

Usage Guidelines

Use the log none command to disable all MNP debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display MNP related information only when errors occur. The off form of this command disables debugging output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

MNP>log error on

...

log msisdn=

Usage Guidelines

Use the log msisdn= command to track the MNP transaction process related with a specific subscriber by given its MSISDN.

Syntax Description

log msisdn=<msisdn>

msisdn

Specify a valid MSISDN. It supports the following formats:

· CC+NDC+SN
· NDC+SN
· SN

Examples

The following is sample output from the log msisdn= command.

MNP>log msisdn=

...

log msisdn off

Usage Guidelines

Use the log msisdn off command to disable MNP subscriber tracking.

Syntax Description

This command has no arguments or keywords.

log msg

Usage Guidelines

Use the log msg command to display MNP event debugging output. The off form of this command disables debugging output.

Syntax Description

log msg [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log msg on command.

MNP>log msg on

MNP_SRF received SCCP message

- SCCP Address

-- src: DPC+SSN=0000 + 08, TT+NP=00+01, GT:86755920000

-- dst: DPC+SSN=0000 + 06, TT+NP=80+01, GT:86755991584

- TCAP message length: 79

-- message flow:

62 4D 48 04 01 63 0F 33 6B 1E 28 1C 06 07 00 11

86 05 01 01 01 A0 11 60 0F 80 02 07 80 A1 09 06

07 04 00 00 01 00 05 03 6C 25 A1 23 02 01 40 02

01 16 30 1B 80 07 91 68 57 95 19 85 F4 83 01 00

86 07 91 68 57 95 02 00 F0 AB 04 03 02 00 00

...

list index

Usage Guidelines

Use the list index command to record MNP subscriber info in file: /usr/local/subsManage/npdb_index.txt.

Syntax Description

This command has no arguments or keywords.

list subs

Usage Guidelines

Use the list subs command to display the total MNP subscriber number and information of the first 25 subscribers.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list subs command.

MNP>list subs

Total subs : 1452

#       msisdn          rn      status  donor -> recipient

0000    594694460000    60063   3        R8.3 -> R9.1

0001    594694460001    60063   3        R8.3 -> R9.1

0002    594694460002    60063   3        R8.3 -> R9.1

0003    594694460003    60063   3        R8.3 -> R9.1

0004    594694460004    60063   3        R8.3 -> R9.1

...

delete sub=

Usage Guidelines

Use the delete sub= command to delete a specified subscriber from MNP database.

Syntax Description

delete sub=<msisdn>

msisdn

Specify a valid MSISDN in CC+NDC+SN format.

Examples

The following is sample output from the delete sub= command.

MNP>delete sub=594694460004

Delete subs 594694460004 ,stored at: 1.1451!

page 1

Usage Guidelines

The MNP debug page 1 displays the information of MNP public parameters.

Examples

The following is page 1 sample output.

MNPF    Version R9V00_01                                Page 01

Parameter List

                00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F

flag            01

gtt             36 36 37 35 35 39 30 30 30 31 31 00 00 00 00 00

routing number  36 30 36 36 00 00 00 00

routing method  01

rn at           02

sn              31 30 31 30 30 30 30 31

local prefix1   36 36 37 35 35 00 00 00 00 00 00 00 00 00 00 00

local prefix2   00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix3   00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix4   00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix5   00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix6   00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix7   00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix8   00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

page 2

Usage Guidelines

The MNP debug page 2 displays the information of MNP local prefixes.

Examples

The following is page 2 sample output.

MNPF    Version R9V00_01                                Page 02

Parameter List

                00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F

local prefix09  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix10  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix11  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix12  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix13  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix14  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix15  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix16  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix17  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix18  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix19  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix20  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix21  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix22  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix23  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

local prefix24  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

page 3

Usage Guidelines

The MNP debug page 3 displays the information of MNP system status and subscriber capacity.

Examples

The following is page 3 sample output.

MNPF    Version R9V00_01            -NPDB-              Page 03

System Status

                00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F

Master          01

System state    00

Peer state      10

Data source     02

Init progress   64

Server IP       AC 12 62 01 AC 12 63 01

Capability      40 9C 00 00

License Users   20 4E 00 00

Real Users      01 00 00 00

Peer users      01 00 00 00

User type       00 00 00 00 01 00 00 00 00 00 00 00 00 00 00 00

Define

  State:0=NORMAL,1=START,2=INIT,3=SUSPEND,4=SHUTDOWN

  Data source:0=NO DATA,1=PEER SERVER,2=LOCAL HD

  User type: Every 4 bytes represent a type user:

             own ported out

             foreign ported in

             foreign ported to foreign network

             not known

page 4

Usage Guidelines

The MNP debug page 4 displays the status of MNP subscribers import process.

Examples

The following is page 4 sample output.

MNPF    R9V00_01                 -NPDB-                 Page 04

User info

                00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F

imp subs time   00 00 00 00

result          00

imp subs        00 00 00 00

load subs       00 00 00 00

write ptr       9F 86 01 00

Result:

  1 = import subs command

  2 = reading data file

  3 = succeed

  4 = failed

3.16


MRFC

MRFC Debug Commands:

· log all
· log none
· log error [on | off]
· log conf-<index> [on | off]

log all

Usage Guidelines

Use the log all command to display information about Multimedia Resource Function Controller (MRFC) activity.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

MRFC>log all

...

log none

Usage Guidelines

Use the log none command to disable all MRFC debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display MRFC related messages only when errors occur in the system. The off form of this command disables debugging output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

MRFC>log error on

...

log conf-

Usage Guidelines

Use the log conf- on command to display information of a predefined Multimedia Resource Function Processor (MRFP). The off form of this command disables debugging output.

Syntax Description

log conf-<index> [on | off]

index | Index of a predefined Multimedia Resource Function Processor (MRFP).
on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log conf- on command.

MRFC>log conf-1 on

...

3.17


MSC

MSC Debug Commands:

· log all
· log none
· log error [on | off]
· log event [on | off]
· log internal [on | off]
· list tg <tg>
· list trunk <tg.trunk>
· list mg <mg>
· list task
· watch task <pid>
· bt [on | off]
· test called <prefix>
· tone [on | off]
· assumeInSipNai <tg> <nai>
· trace function:

- trace imsi <imsi>

- trace isdn <msisdn>

- list trace

- del <index>

- disable <index>

- enable <index>

log all

Usage Guidelines

Use the log all command to turn on the log error, log event, and log internal commands simultaneously. It displays information related to MSC processing.

This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

MSC>log all

Log error: 1

Log event: 1

Log internal: 1

[21295] isdn_alert_ind

[20244] isup_release_cnf

[21277] msc_recv_assignComplete

[21235] MSC receive RP Ack

[21236] MSC receive RP Ack

Recv L3 Info, pid=-1, msgID=17

New Co_SMS_MSC

[21332] msc_recv_cmReq

Recv L3 Info, pid=-1, msgID=17

New Co_SMS_MSC

[21333] msc_recv_cmReq

New CC_ISDN_Incoming

[21334] isdn_setup_ind

[20739] msc_mgc_cnf

[20742] msc_mgc_cnf

...

log none

Usage Guidelines

Use the log none command to disable all MSC debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display MSC related messages only when errors occur in the network. The off form of this command disables debugging output.

This command is useful for troubleshooting call fail problems because it produces little output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

MSC>log error on

Log error: 1

Log event: 0

Log internal: 0

[01005] MT_SM_Transfer_MSC return SDL_FAIL

[06743] OG_Call_Setup_MSC return OCS_FAILURE

[06879] CAMEL_MT_GMSC_DISC6 return SDL_FAIL

[07242] Complete_Call_In_MSC return SDL_ABORT

PID 6879 invalid at ssf_inter_msc

numbering_analysis: invalid nai(0)

[08790] Activate_CF_Process return SDL_FAIL

...

log event

Usage Guidelines

Use the log event on command to enable MSC event debugging. Use the off form of this command to disable debugging output.

This command is useful for solving network problems because it provides an overall picture of the stability of the network.

Syntax Description

log event [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log event on command.

MSC>log event on

Log error: 0

Log event: 1

Log internal: 0

New CC_BICC_Incoming

[24423] msc_bicc_setup_ind

[24423] add_pid_to_timeslot ts_id=3 pid_num=1

[24423] CC_BICC_Incoming transfer to sub-state 1

New CC_BICC_Incoming

[24424] msc_bicc_setup_ind

[24424] add_pid_to_timeslot ts_id=4 pid_num=1

[24424] CC_BICC_Incoming transfer to sub-state 1

[24419] msc_mgc_cnf

[23166] isdn_rel_cnf

...

log internal

Usage Guidelines

Use the log internal on command to enable MSC internal process debugging. Use the off form of this command to disable debugging output.

Syntax Description

log internal [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log internal on command.

MSC>log internal on

Log error: 0

Log event: 0

Log internal: 1

[27762] BICC INCOMING send_internal_iam. my chnl: 0-37-283

[28115] BICC OUTGOING recv_internal_iam

[27933] MSC ==> SSF : Int_Invoke_gsmSSF[CAMEL_T_CSI]

[27933] SSF ==> MSC : Int_gsmSSF_Invoked [(null)]

Apply SSF Port = 0957

[27980] MT __send_internal_apm, my chnl: 7-16-24

[27593] GMSC recv_internal_apm

[27593] GMSC __send_internal_apm, peer chnl: 7-16-24

[27434] MO recv_internal_apm

[27981] MT __send_internal_apm, my chnl: 7-16-25

[27612] GMSC recv_internal_apm

[27612] GMSC __send_internal_apm, peer chnl: 7-16-25

[27452] MO recv_internal_apm

[27987] ISDN OUTGOING send_internal_acm

[27985] ISDN INCOMING recv_internal_acm

[27988] ISDN OUTGOING send_internal_acm

[27986] ISDN INCOMING recv_internal_acm

[27993] ISDN OUTGOING send_internal_acm

[27991] ISDN INCOMING recv_internal_acm

[28098] ISDN INCOMING send_internal_iam. my chnl: 21-12-14

[28116] ISDN OUTGOING recv_internal_iam

[28099] BICC OUTGOING __send_internal_apm, my chnl: 0-37-361

[27737] BICC INCOMING recv_internal_apm

[28100] BICC OUTGOING __send_internal_apm, my chnl: 0-37-362

...

list tg

Usage Guidelines

Use the list tg command to display a specified trunk group's states, attributes and trunks info.

Syntax Description

list tg <tg>

tg

Specify a trunk group by its ID.

Examples

The following is sample output from the list tg command.

MSC>list tg 5

TG ID: 5

Title: SSW_AIF_CS0

Admin: Unlocked

Oper: Enable

Avail: Online

OPC: 1

DPC: 2

Network: NAT

Protocol: AIF

CIC select: Clockwise

Socket ID: 3

Trunks: 31

Index   Title   MgID    PortID  Group   Socket  PID     Oper    Avail   Admin

1       Trunk-1 3       0       msc-0   -1      0       Enable  Online  Unlocked

2       Trunk-2 3       1       msc-0   -1      0       Enable  Online  Unlocked

...

Sort trunks: 15

17 18 19 20 21 22 23 24

25 26 27 28 29 30 31

sort trunks

Trunks configured in this trunk group which controlled by the other MSC.

list trunk

Usage Guidelines

This command displays states, attributes and timeslot info for a specified trunk.

Syntax Description

list tg <tg.trunk>

tg | Trunk group ID
trunk | Trunk ID in the specified trunk group

Examples

The following is sample output from the list trunk command.

MSC>list trunk 5.1

Trk ID: 1

Title: Trunk-1

Admin: Unlocked

Oper: Enable

Avail: Online

MG ID: 3

Port ID: 0

Group: msc-0

CIC: 0-31 (0-1F)

Used TS: 0

Socket: -1

PID: 0

Index   Type    Status  L-Blo   R-Blo   CIC     PID1    PID2    PID3

0       DIS     Oos     0       0       0       0       0       0

1       BI      Oos     0       0       1       0       0       0

2       BI      Oos     0       0       2       0       0       0

3       BI      Oos     0       0       3       0       0       0

...

list mg

Usage Guidelines

This command displays attributes and port info for a specified media gateway.

Syntax Description

list mg <mg>

mg

Media gateway ID

Examples

The following is sample output from the list mg command.

MSC>list mg 3

MG ID: 3

Title: MG-3

SwitchMode: MGCP

MgType: LGC CS

Socket ID: 4

Port 0 is used by trunk 5-1, status: 1

Port 1 is used by trunk 5-2, status: 1

Port 2 is used by trunk 5-3, status: 1

...

list task

Usage Guidelines

Use the list task command to list active call tasks processing in the monitored MSC.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list task command.

MSC>list task

Working task id:

  1    2    3    4   81   82   83   84

 85   86   87   88   89   90   91

 92   93   94   95   96  120  122

123 13041 13278 13653 20125 20290 20325

20399 20535 20558 20641 20769 20780 20807

20942 21039 21057 21075 21080 21354 21431

21432 21433 21499 21622 21721 21781 22009

...

watch task

Usage Guidelines

Use the watch task command to display information of a specific task process.

Syntax Description

watch task <pid>

pid

Specify a processing task ID.

Examples

The following is sample output from the watch task command.

MSC>watch task 13041

[13041] OCH_MSC state: 1-1

[13041] OG_Call_Setup_MSC state: 5-0

[13041] MO_Answered_Overall state: 0-0

=== Signal Received ===

aif:  0x00              mapb: 0x00

mapc: 0x00              mape: 0x00

mapf: 0x00              oxch: 0x00

dxch: 0x00              ssf:  0x00

isup: 0x00              bicc: 0x00

=== Process Link ===

aif port: 6589          vlr port: 853

org exch port: 0        dst exch port: 13278

ssf port: 3584          buddy port: 0

sap id: 0               tg socket: 3

=== Service Data ===

IMSI: 460029000001606

Called: 86755901638

Caller: 86755901606

bt

Usage Guidelines

Use the bt on command to display the backtrace information of a failed task .

Syntax Description

bt [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the watch task command.

MSC>bt on

[31227] Page_MS_MSC return SDL_FAIL

***** backtrace info *****

[31227] MTSM_VMSC state: 1-1

[31227] MT_SM_Transfer_MSC state: 1-1

[31227] Page_MS_MSC state: 1-0

__check_expired: 1

***** backtrace end *****

test called

Usage Guidelines

Use the test called command to display the chosen dial plan for a specific prefix.

Syntax Description

test called <prefix>

prefix

Provide a prefix for testing its out going route.

Examples

The following is sample output from the watch task command.

MSC>test called 86755

Match dial plan 1-21, prefix: , attribute: Unknown

Match dial plan 1-1, prefix: 86755, attribute: INT

tone

Usage Guidelines

Use the tone on command to generate and play all call progress tones (ring-back tone, busy tone, etc) by local network.

Syntax Description

tone [on | off]

on | Generate and play all call progress tones by local network.
off | Detect and play call progress tones according to the generator. Normally, local network generates tones for local mobile terminated calls, while remote networks generates tones for PSTN terminated calls.

Examples

The following is sample output from the tone on command.

MSC>tone on

...

assumeInSipNai

Usage Guidelines

Use the assumeInSipNai command to manipulate the type of calling number for a SIP trunk group. It doesn't take effect when the calling number's attribute is International.

This command is used for Calling Line Identification Presentation (CLIP) of incoming SIP calls.

Syntax Description

assumeInSipNai <tg> <nai>

tg

Specify a SIP-I trunk group by its ID.

nai

Determine the attribute of the incoming Caller Line ID (CLI).

· 0 = CLIR: Calling Line Identification Restriction
· 1 = Subscriber
· 2 = Unknown
· 3 = National
· 4 = International

Examples

The following is sample output from the assumeInSipNai command.

MSC>assumeInSipNai 25 4

...

trace imsi

Usage Guidelines

Use the trace imsi command to track the call transaction process related with a specific subscriber by given its IMSI. Up to 8 objects (both IMSI and MSISDN) can be traced simultaneously.

This command must cooperate with the log all command to display debugging output.

Syntax Description

trace imsi <imsi>

imsi

Specify a 15-digit IMSI.

Examples

The following is sample output from the trace imsi command.

MSC>trace imsi 460029000000005

MSC>log all

...

trace isdn

Usage Guidelines

Use the trace isdn command to track the call transaction process related with a specific subscriber by given its MSISDN. Up to 8 objects (both IMSI and MSISDN) can be traced simultaneously.

This command must cooperate with the log all command to display debugging output.

Syntax Description

trace isdn <msisdn>

msisdn

Specify a valid subscriber number. It supports the following formats:

· CC+NDC+SN
· NDC+SN
· SN

Examples

The following is sample output from the trace isdn command.

MSC>trace isdn 86755900005

MSC>log all

...

list trace

Usage Guidelines

Use the list trace command to list current trace tasks processing in the monitored MSC.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list trace command.

MSC>list trace

Num     Type    Enb     Pattern

0       imsi    y       460029000001615

1       imsi    y       460029000001610

2       imsi    y       460029000001605

3       imsi    y       460029000001600

del

Usage Guidelines

Use the del command to delete a tracing task from the existing trace list.

Syntax Description

del <index>

index

(Optional) Index of an existing trace task.

If no index is specified, then debugging is to delete all tracing tasks.

Examples

The following is sample output from the del command.

MSC>del 0

MSC>list trace

Num     Type    Enb     Pattern

1       imsi    y       460029000001610

2       imsi    y       460029000001605

3       imsi    y       460029000001600

disable

Usage Guidelines

Use the disable command to deactivate a tracing task in the existing trace list.

Syntax Description

disable <index>

index

(Optional) Index of an existing trace task.

If no index is specified, then debugging is to disable all tracing tasks.

Examples

The following is sample output from the disable command.

MSC>disable 1

MSC>list trace

Num     Type    Enb     Pattern

1       imsi    n       460029000001610

2       imsi    y       460029000001605

3       imsi    y       460029000001600

enable

Usage Guidelines

Use the enable command to activate a quiescent trace task in the existing trace list.

Syntax Description

enable <index>

index

(Optional) Index of an existing trace task.

If no index is specified, then debugging is to enable all quiescent trace tasks.

Examples

The following is sample output from the enable command.

MSC>enable 1

MSC>list trace

Num     Type    Enb     Pattern

1       imsi    y       460029000001610

2       imsi    y       460029000001605

3       imsi    y       460029000001600

3.18


MTP3

MTP3 Debug Commands:

· log all
· log none
· log error [on | off]
· log event [on | off]
· log mtp3hb [on | off]
· log primitive [on | off]
· log tup [on | off]
· log isup [on | off]
· log bicc [on | off]
· log sccp [on | off]
· log snm [on | off]
· log link all [on | off]
· log link=<link> on
· log linkset=<linkset> on
· list par.[opc | link | ls | int | ints | nat | nats] <32xn>
· list route.[0 | 1 | 2 | 3]
· list log status
· information pages
· page 2
· page 6

log all

Usage Guidelines

Use the log all command to display all MTP3 component activities in the system. This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

MTP3>log all

SCCP-UDTS(14:42:38.893903):MTP3<==MTP3,14B NAT SPC(1->1) SLS=3 LI=59 srcIP=172.18.98.1

FF 00 59 83 01 40 00 30 0A 01 03 10 1D 0D 53 01 00 93 00 11 04 66 57 95 00 00 07 0D 13 01 00 08 00 12 04 44 87 29 91 99 75 32 62 30 48 04 01 62 04 03 6B 1E 28 1C 06 07 00 11 86 05 01 01 01 A0 11 60 0F 80 02 07 80 A1 09 06 07 04 00 00 01 00 32 02 6C 08 A1 06 02 01 40 02 01 37

SCCP(14:42:38.893929):Perform routing:transfer to SCCP

SCCP-UDT(14:42:39.573838):MTP3<==USER, INATs  DPC=200  SLS=9

Routing by UP:MTP3==>MTP3,14B SPC(200->200) LI=59 dstIP=172.18.98.1

FF 00 59 43 00 02 80 90 09 00 03 10 1D 0D 53 00 02 16 00 11 04 66 57 95 00 00 09 0D 13 00 02 93 00 11 04 66 57 95 00 00 07 32 62 30 48 04 01 63 01 D9 6B 1E 28 1C 06 07 00 11 86 05 01 01 01 A0 11 60 0F 80 02 07 80 A1 09 06 07 04 00 00 01 00 32 02 6C 08 A1 06 02 01 40 02 01 37

...

log none

Usage Guidelines

Use the log none command to disable all MTP3 debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display MTP3 related messages only when errors occur. The off form of this command disables debugging output.

This command is useful for troubleshooting call fail problems because it produces little output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

MTP3>log error on

error logs on

(14:44:38.575759)MTP3<==MTP2,14BIT,SIO=41,SPC(200->15),link=254

FE 00 09 41 15 00 80 00 11 20 FF 00

(14:44:38.575771)Perform routing:STP failed

(14:44:46.274541)MTP3<==MTP2,14BIT,SIO=41,SPC(200->15),link=254

FE 00 09 41 15 00 80 00 21 20 FE 00

...

log event

Usage Guidelines

Use the log event on command to display MTP3 link maintenance events. The off form of this command disables debugging output.

Syntax Description

log event [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log event on command.

MTP3>log event on

event on

[lsac]link 255 emergent alignment

[lsac]link 255 emergent alignment

link 254 L2 in service

link 255 L2 in service

[lsac]link 255 L2 in service,start testing procedure

[lsac]link 254 emergent alignment

[lsac]link 254 L2 in service,start testing procedure

[lsac]link 255 complete test procedure,test failed

link 254 L2 out of service

[lsac]link 255 emergent alignment

link 254 L2 in service

link 255 L2 in service

...

log mtp3hb

Usage Guidelines

Use the log mtp3hb on command to display debugging output of heartbeat receive and transit processes. The off form of this command disables debugging output.

Syntax Description

log mtp3hb [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log mtp3hb on command.

MTP3>log mtp3hb on

mtp3 heartbeat on

(15:5:9.338597)get platform heartbeat from 172.18.199.1

09 01 38 6F DF 9E 00 99 99 00 00 00 00 00 00 00 00 00 FA 00 00 00 08 08 03 01 01 FE 8C FF 00 00 01 00 86 09 01 05 01 57 5F CF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF F5 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF 57 55 CF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

(15:5:11.998187)get platform heartbeat from 172.18.198.1

09 00 38 6F DF A0 00 99 99 00 00 00 00 00 01 19 00 00 FB 00 00 00 08 08 03 01 01 FE 8C FF 00 00 01 00 86 09 01 05 01 57 5F CF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF F5 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF 57 55 DF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

...

log primitive

Usage Guidelines

Use the log primitive on command to display primitive messages between MTP layer 2 and layer 3. The off form of this command disables debugging output.

Syntax Description

log primitive [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log primitive on command.

MTP3>log primitive on

primitive between MTP3 and MTP2 on

(15:5:29.425687)MTP3 send IP to MTP2 15

00 00 0C FF EE FF EE EE EE EE EE EE EE EE 00

(15:5:30.325515)MTP3 send IP to MTP2 16

00 00 0C FF EE FF EE EE EE EE EE EE EE EE 00

(15:5:54.771723)get M2UA heartbeat from 16212ac

FF 00 04 EF 00 00

(15:5:55.951488)get MTP2 heartbeat from 172.18.16.1

01 00 00 00 00 00 01 01 01 01 01 01 01 01 00 00 00 00 02 02 02 02 02 02 02 02 FF FF FF 43 FF FF FF FF 80 80 80 80 80 80 80 80 44 00 00 06 08 D9 00 00 00 00 00 00 00 2A EA 98 AA AB AA 00

...

log tup

Usage Guidelines

Use the log tup on command to display information about Telephone User Part (TUP) protocol activities in the system. The off form of this command disables debugging output.

Syntax Description

log tup [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log tup on command.

MTP3>log tup on

...

log isup

Usage Guidelines

Use the log isup on command to display information about ISDN User Part (ISUP) protocol activities in the system. The off form of this command disables debugging output.

Syntax Description

log isup [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log isup on command.

MTP3>log isup on

...

log bicc

Usage Guidelines

Use the log bicc on command to display information about Bearer Independent Call Control (BICC) protocol activities in the system. The off form of this command disables debugging output.

Syntax Description

log bicc [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log bicc on command.

MTP3>log bicc on

log sccp

Usage Guidelines

Use the log sccp on command to display message transactions between MTP3 and SCCP. The off form of this command disables debugging output.

Syntax Description

log sccp [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log sccp on command.

MTP3>log sccp on

...

log snm

Usage Guidelines

Use the log snm on command to display MTP3 Signaling Network Management (SNM) messages. The off form of this command disables debugging output.

Syntax Description

log snm [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log snm on command.

MTP3>log snm on

snm message on

SLT-SLTM(15:12:37.910213):MTP3==>MTP2,14B INATs SPC(200->15) SLS=0 LI=09 dstLINK=255 dstIP=172.18.99.1

FF 00 09 41 15 00 80 00 11 20 FF 00

SLT-SLTM(15:12:45.908995):MTP3==>MTP2,14B INATs SPC(200->15) SLS=0 LI=09 dstLINK=255 dstIP=172.18.99.1

FF 00 09 41 15 00 80 00 11 20 FF 00

...

log link all

Usage Guidelines

Use the log link all on command to display MTP3 message transactions on all links. The off form of this command disables debugging output.

Syntax Description

log link all [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log link all on command.

MTP3>log link all on

all link on

BICC-UNK(11:40:31.996135):MTP3<==MTP2,14B NAT SPC(4->1) SLS=9 LI=94 srcLINK=193 srcIP=172.18.250.1

C1 00 94 8D 01 00 01 90 19 03 00 00 41 01 78 86 80 00 80 01 02 80 03 07 02 80 04 08 75 80 20 20 76 3D 30 0D 0A 6F 3D 2D 20 30 20 30 20 49 4E 20 49 50 34 20 31 37 32 2E 31 38 2E 32 35 30 2E 31 0D 0A 73 3D 2D 0D 0A 63 3D 49 4E 20 49 50 34 20 31 37 32 2E 31 38 2E 32 35 30 2E 31 0D 0A 74 3D 30 20 30 0D 0A 61 3D 69 70 62 63 70 3A 31 20 52 65 71 75 65 73 74 0D 0A 6D 3D 61 75 64 69 6F 20 31 36 33 38 32 20 52 54 50 2F 41 56 50 20 36 30 0D 0A 09 02 80 01 00

SCCP-CC(11:40:31.996213):MTP3<==USER,NAT DPC=1a SLS=a

Perform routing:MTP3==>MTP2,14B SPC(1->1a) LI=0f dstLINK=202 dstIP=172.18.253.1

CA 00 0F 83 1A 40 00 A0 02 01 00 5B 02 03 8A 02 01 00

...

log link=

Usage Guidelines

Use the log link= on command to display MTP3 message transactions on a specified link. The off form of this command disables debugging output.

Syntax Description

log link=<link> [on | off]

link | Specify a link by its ID (0-255).
on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log link= on command.

MTP3>log link=1 on

...

log linkset=

Usage Guidelines

Use the log linkset= on command to display MTP3 message transactions on a specified linkset. The off form of this command disables debugging output.

Syntax Description

log linkset=<linkset> [on | off]

linkset | Specify a linkset by its ID (0-127).
on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log linkset= on command.

MTP3>log linkset=1 on

...

list par.

Usage Guidelines

Use the list par. command to display detailed information of MTP3 configuration.

Syntax Description

list par.[opc | link | ls | int | ints | nat | nats] <32xn>

opc | Show details of originating point code attributes.
link | Show overall information of all 256 links in the system.
ls | Show overall information of all 128 linkset in the system.
int | Show overall information of all 256 routes in international network.
ints | Show overall information of all 256 routes in international spare network.
nat | Show overall information of all 256 routes in national network.
nats | Show overall information of all 256 routes in national spare network.
32xn | Set the initial item to display. Each page shows 32 items.

Examples

The following is samples output from the list par. command.

MTP3>list par.opc

Network                 SPC Len         OPC

International           14BIT           000004

International(s)        14BIT           000200

National                14BIT           000001

National(s)             14BIT           000001

International Dynamic (2):      1, 26,  0,  0,  0,  0,  0,  0

International(s) Dynamic (5):   5,  4,  7,  6, 20,  0,  0,  0

National Dynamic (0):           0,  0,  0,  0,  0,  0,  0,  0

National(s) Dynamic (2):      254,253,  0,  0,  0,  0,  0,  0

MTP3>list par.link 32

Link Attribute-->

Link    Linkset SLC     NormalMTP3      AlterMTP3       Type    SG      Cfg

032     80      00      ffffffff        ffffffff        00      00      00

033     80      00      ffffffff        ffffffff        00      00      00

034     80      00      ffffffff        ffffffff        00      00      00

035     80      00      ffffffff        ffffffff        00      00      00

036     80      00      ffffffff        ffffffff        00      00      00

037     80      00      ffffffff        ffffffff        00      00      00

038     80      00      ffffffff        ffffffff        00      00      00

039     80      00      ffffffff        ffffffff        00      00      00

040     13      00      016212ac        ffffffff        03      0a      01

...

MTP3>list par.ls

Linkset Attribute-->

Linkset Remote_SPC      Network         LoopBack

000     000000          INT             N

001     000033          NAT             N

002     000086          NAT             N

003     000006          NAT             N

004     000004          INT(s)          N

...

MTP3>list par.nat

National Routine

       SPC             Normal LS       Alternative LS

000     000000          80              80

001     000033          01              80

002     000086          02              80

003     000006          03              80

...

list route.

Usage Guidelines

Use the list route. command to display the configured route information in the specific network.

Syntax Description

list route.[0 | 1 | 2 | 3]

0 | International network
1 | International spare network
2 | National network
3 | National spare network

Examples

The following is sample output from the list route. command.

MTP3>list route.1

International Network spare

SPC             Reachable       Path            NLS     ALS

000004          Y               Linkset 04      04      --

000005          Y               Linkset 05      05      --

000006          N               No Path         11      --

000007          N               No Path         12      --

...

list log status

Usage Guidelines

Use the list log status command to list active debugging outputs for the MTP3 module.

Syntax Description

This command has no arguments or keywords.

Examples

The following is samples output from the list log status command.

MTP3>list log status

mtp3 log status-->

log isup ON

log error ON

page 2

Usage Guidelines

The MTP3 debug page 2 displays the information of link status. Each sub-page shows 16 links.

Examples

The following is page 2 sample output.

PAGE02             link mark

                   0  1  2  3  4  5  6  7  8  9  10 11 12 13 14 15

--Page--           00

link_available     EE EE EE EE 01 01 EE 01 EE EE EE 01 EE EE EE EE

link_unavailable   EE EE EE EE 01 01 EE 01 EE EE EE 01 EE EE EE EE

failed             EE EE EE EE 00 00 EE 00 EE EE EE 00 EE EE EE EE

CB_in_progress     EE EE EE EE EE EE EE 00 EE EE EE EE EE EE EE EE

CO_in_progress     EE EE EE EE EE EE EE EE EE EE EE EE EE EE EE EE

link_inhibited     EE EE EE EE EE EE EE EE EE EE EE EE EE EE EE EE

locally_inhibited  EE EE EE EE EE EE EE EE EE EE EE EE EE EE EE EE

remotely_inhibited EE EE EE EE EE EE EE EE EE EE EE EE EE EE EE EE

localInhibit_inPro EE EE EE EE EE EE EE EE EE EE EE EE EE EE EE EE

uninhibit_in_pro   EE EE EE EE EE EE EE EE EE EE EE EE EE EE EE EE

local_blocked      EE EE EE EE EE EE EE EE EE EE EE EE EE EE EE EE

remote_blocked     EE EE EE EE EE EE EE EE EE EE EE EE EE EE EE EE

local_change_over  00 00 00 00 00 00 00 00 00 00 00 02 00 00 00 00

page 6

Usage Guidelines

The MTP3 debug page 6 displays the information of route status. Each sub-page shows 16 routes in 4 networks.

Examples

The following is page 6 sample output.

PAGE06             MTP3 ROUTINE TABLE(4)

                   0  1  2  3  4  5  6  7  8  9  10 11 12 13 14 15

--PAGE--           00

0 INTERNATIONAL    8A 8A 18 18 18 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A

1 INTERNATIONAL(S) 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A

2 NATIONAL         8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A

3 NATIONAL(S)      8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A

value=             8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A

18:route:normal ls 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A

   nls:available   8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A

   als:unavailable 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A

10:route:normal ls 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A

   nls:available   8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A

   als:available   8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A

52:route=alter ls  8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A

   nls:unavailable 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A

   als:available   8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A

8A:no route        8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A

other:problem bug  8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A 8A

3.19


OPPS

OPPS Debug Commands:

· log all
· log none
· log error
· log imdm
· log opr
· log msisdn=<msisdn>
· log omc op
· list sub=<msisdn>
· list subs=<index>
· save param
· save subs data
· reload param
· reload subs data
· set periodicSync=[0 | 1]
· set dualFlag=[0 | 1]
· information pages
· page 1
· page 7

log all

Usage Guidelines

Use the log all command to turn on all of the OPPS debug commands simultaneously. It displays debugging information on all OPR and IMDX activities.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

OPPS>log all

COMMAND OK!

[port 0223] did=2525, send open response result: 2! (1227533627.625000)

[port 0223]did: 2525, Get Map opr,type:<132>, GetVlrEnquiryIMDMStatus

-- <P/DID=0000/2525> Rec. MSG <ocode: 132> @1227533627.705645

------------ Message Flow ----------------

00 24 8F 00 00 51 09 DD 00 84 02 40 01 01 00 15

30 13 80 08 64 00 92 00 00 30 01 F7 81 07 19 68

57 95 30 31 F9 00

IMDX:MO User type,imsi 460029000003107 is public

9186755903139 is not exist in the prefix table,pulbic to public

...

log none

Usage Guidelines

Use the log none command to disable all OPPS debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error command to display OPPS related messages only when errors occur. The log none command disables debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log error command.

OPPS>log error

...

log imdm

Usage Guidelines

Use the log imdm command to display debugging output of the Intelligent MAP-D Multiplexer activities. Use the log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log imdm command.

OPPS>log imdm

COMMAND OK!

IMDX:MO User type,imsi 460029000003689 is public

9186755903721 is not exist in the prefix table,pulbic to public

...

log opr

Usage Guidelines

Use the log opr command to display debugging output of the Open-to-all Public Roaming activities. Use the log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log opr command.

OPPS>log opr

...

log msisdn

Usage Guidelines

Use the log msisdn command to track the OPPS transaction processes related with a specific subscriber by given its MSISDN. Use log none command to disable tracking.

Syntax Description

log msisdn <msisdn>

msisdn

Specify a valid MSISDN in CC+NDC+SN format.

Examples

The following is sample output from the log msisdn command.

OPPS>log msisdn 86755991550

...

log omc op

Usage Guidelines

Use the log omc op command to display debugging output of the Element Management System maintenance processes. Use the log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log omc op command.

OPPS>log omc op

...

list sub=

Usage Guidelines

Use the list sub= command to display details of a specified OPPS subscriber by given its MSISDN.

Syntax Description

list sub=<msisdn>

msisdn

Specify a valid MSISDN in CC+NDC+SN format.

Examples

The following is sample output from the list sub= command.

OPPS>list sub=86755991011

<<----------- Account. Info @ <11> --------

msisdn:        86755991011

imsi:          460029000091011

imei:          460029000030830

User type:     OPR without Roaming Agreement

------------- The End ------------------->>

list subs=

Usage Guidelines

Use the list subs= command to display details of 15 consecutive OPPS subscribers by given the index number of the first one.

Syntax Description

list subs=<index>

index

Specify the index of the first OPPS subscriber to display.

Examples

The following is sample output from the list subs= command.

OPPS>list subs=2

<<----------- Account. Info @ <2> --------

msisdn:        86755991002

imsi:          460029000091002

imei:          460029000030740

User type:     OPR without Roaming Agreement

------------- The End ------------------->>

<<----------- Account. Info @ <3> --------

msisdn:        86755991003

imsi:          460029000091003

imei:          460029000030750

User type:     OPR without Roaming Agreement

------------- The End ------------------->>

...

save param

Usage Guidelines

Use the save param command to save OPPS system parameters residing in memory to hard disk.

Syntax Description

This command has no arguments or keywords.

save subs data

Usage Guidelines

Use the save subs data command to save OPPS subscriber data to hard disk.

Syntax Description

This command has no arguments or keywords.

reload param

Usage Guidelines

Use the reload param command to reload OPPS parameters and initialize OPPS status.

Syntax Description

This command has no arguments or keywords.

reload subs data

Usage Guidelines

Use the reload subs data command to reload all OPPS subscriber data from hard disk.

Syntax Description

This command has no arguments or keywords.

set periodicSync=

Usage Guidelines

Use the set periodicSync= command to change the OPPS periodic synchronization mode.

Syntax Description

set periodicSync=[0 | 1]

0 | Disable periodic sync.
1 | Enable periodic sync.

set dualFlag=

Usage Guidelines

Use the set dualFlag= command to select the OPPS server's working mode.

Syntax Description

set dualFlag=[0 | 1]

0 | Single mode
1 | Dual mode

page 1

Usage Guidelines

The OPPS debug page 1 displays the information of OPPS system parameters.

Examples

The following is page 1 sample output.

OPPS     Version R9V2_01      OPR parameters               Page 01

Parameter List

                   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F

OppsNumber         66 57 95 00 10 F2 FF FF 00 00

OprStatus          01

ImdxStatus         01

License            30 75 00 00

ReplaceableFlag    00

CdrFlag            01

AutoRegister       01

AssignedMsisdn     0F 00 00 00

TotalBusyMsisdn    04 00 00 00

ImdxAccessExclusive00

Subsystem          00

PeerOprIp          AC 12 63 01

LocalOprIp         AC 12 62 01

PrimaryOmcServer   AC 12 80 01

SecondOmcServer    00 00 00 00

PeriodicSync       01

DualFlag           01

PeriodicSync(0-no sync  1-snyc)     DualFlag(0-single  1-dual)

page 7

Usage Guidelines

The OPPS debug page 7 displays the information of OPPS server working status.

Examples

The following is page 7 sample output.

OPPS    Version  R9V2_01    OPR DUAL INFO                  Page 07

OprDualInfo

                   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F

masterFlag         01

masterIp           AC 12 62 01

sysState           00

dataSrc            02

initProgress       64

oprSyncFlag        01

Help:

    masterFlag:0-slave       1-master

    sysState:  0-normal      1-start        2-init

    3-suspend  4-shutdown

    dataSrc:   0-no source   1-from master  2-from local database

    3-from omc backup database

    initProgress: indicate the percent,100 indicate finished

    oprSyncFlag(0-no sync  1-snyc)

3.20


PPS

PPS Debug Commands:

· log all
· log none
· log error
· log message
· log procedure
· log vps
· log msisdn=<msisdn>
· list sub=<msisdn>
· list subs segno=<index>
· list card segno=<index>
· list tariff lac=<index>
· list tariff plan lac=<index>
· tariff msisdn=<prefix>
· check card=<password>
· get card index=<index>
· replace card [on | off]
· set replaceable [on | off]
· recreate index
· mt [release | control]
· pps mo [release | control]
· vms allways go, [yes | no]
· delay timer=<timer>
· activity timer=<timer>
· truncation [enable | disable]
· truncation?
· save param
· information pages
· page 1
· page 2
· page 3
· page 4

log all

Usage Guidelines

Use the log all command to turn on all of the PPS debug commands simultaneously. It displays debugging information on all PPS component activities.

This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

PPS>log all

COMMAND OK!

=====================================================

[0943] did=604 cap open received! ACN=[50.2]  @(1227542893.755118)

=====================================================

[0946] did=293 cap open received! ACN=[50.2]  @(1227542893.755118)

-- <P/DID=0000/3574> Rec. MSG @1227542893.755118

<ocode = 36>  ApplyChargingReport

----------------- Message Flow  -----------------

00 20 8a 00 00 00 0d f6 01 24 02

45 01 01 00 11 04 0F A0 0D A0 03 81 01 01 A1 03

80 01 08 82 01 00 00

=====================================================

portid=104 ApplyChargingReport Received! (1227542893.755118)

-- <P/DID=0455/0803> Snd. MSG @1227542893.755118

<ocode = 55>  ActivityTest

----------------- Message Flow  -----------------

00 11 8a 01 c7 00 03 23 00 37 01

00 01 01 00 00 10 00 00

=====================================================

portid=654, dlgid=1040 EventReportBCSM Received! (1227542893.755118)

...

log none

Usage Guidelines

Use the log none command to disable all PPS debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error command to display prepaid service related messages only when errors occur. The log none command disables debugging output.

This command is useful for troubleshooting prepaid call fail problems because it produces little output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log error command.

PPS>log error

COMMAND OK!

=====================================================

Warning: pid=411 did=3194  'cap uabort' received (Waiting for ANSWER)

-- <P/DID=0000/3194> Rec. MSG @1227542726.960078

<ocode = 253>

----------------- Message Flow  -----------------

00 0f 8a 00 00 00 0c 7a 00 fd 02

03 01 01 01 09 00

=====================================================

Warning: pid=439 did=829  'cap uabort' received (Waiting for ANSWER)

...

log message

Usage Guidelines

Use the log message command to display prepaid service message flows. Use the log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log message command.

PPS>log message

COMMAND OK!

=====================================================

[0095] did=2002 cap open received! ACN=[50.1]  @(1227542746.967076)

-- <P/DID=0087/3956> Snd. MSG @1227542746.967076

<ocode = 31>  Continue

----------------- Message Flow  -----------------

00 11 8a 00 57 00 0f 74 00 1f 01

00 01 01 00 00 10 00 00

-- <P/DID=0088/2607> Snd. MSG @1227542746.967076

<ocode = 65>  ContinueSMS

----------------- Message Flow  -----------------

00 11 8a 00 58 00 0a 2f 00 41 01

00 01 01 00 00 10 00 00

-- <P/DID=0089/2511> Snd. MSG @1227542746.967076

<ocode = 35>  ApplyCharging

----------------- Message Flow  -----------------

00 20 8a 00 59 00 09 cf 00 23 01

00 01 01 00 0F 30 0D 80 06 A0 04 80 02 23 28 A2

03 80 01 01 10 00 00

...

log procedure

Usage Guidelines

Use the log procedure command to display the basic information of prepaid activities. It produces little output. Use log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log procedure command.

PPS>log procedure

COMMAND OK!

=====================================================

[0755] did=1525 cap open received! ACN=[50.2]  @(1227542763.341849)

=====================================================

portid=206 ApplyChargingReport Received! (1227542763.341849)

=====================================================

portid=621, dlgid=439 EventReportBCSM Received! (1227542763.341849)

portid=621 EventReportBCSM (Answered)!

=====================================================

[0680] EventReportBCSM Received! (1227542763.341849)

=====================================================

[0694] EventReportSMS Received! (1227542763.341849)

mo sms submitted 0, charge:      0

type:12 charge:0 duration:0

type:12 charge:0 duration:0

=====================================================

[0761] did=626 cap open received! ACN=[50.2]  @(1227542763.386234)

=====================================================

portid=206 EventReportBCSM Received (disconnect)! (1227542763.386234)

=====================================================

< Caller disconnect >

type:0 charge:1 duration:9

Send CDR

=====================================================

...

log vps

Usage Guidelines

Use the log vps command to display message transactions between PPS and AAS. Use log none to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log vps command.

PPS>log vps

...

log msisdn=

Usage Guidelines

Use the log msisdn= command to track the prepaid transaction processes related with a specific subscriber by given its MSISDN. Use log none command to disable tracking.

Syntax Description

log msisdn=<msisdn>

msisdn

Specify a valid MSISDN in either CC+NDC+SN or SN format.

Examples

The following is sample output from the log msisdn= command.

PPS>log msisdn=86755903310

COMMAND OK!

=====================================================

MO SMS

caller: 86755903310 caller pos: 83 10 caller status: 1, cos: 0, balance:50000.0000

called: 86755903342 called pos: 83 42 called status: 1

tariff id: 104, charged prefix: 0086755903342

-- <P/DID=0114/2228> Snd. MSG @1227542939.98511

<ocode = 63>  RequestReportSMSEvent

----------------- Message Flow  -----------------

00 25 8a 00 72 00 08 b4 00 3f 01

00 01 01 00 14 30 12 A0 10 30 06 80 01 02 81 01

00 30 06 80 01 03 81 01 00 10 00 00

-- <P/DID=0114/2228> Snd. MSG @1227542939.148854

<ocode = 65>  ContinueSMS

----------------- Message Flow  -----------------

00 11 8a 00 72 00 08 b4 00 41 01

00 01 01 00 00 10 00 00

=====================================================

[0114] EventReportSMS Received! (1227542940.348269)

mo sms submitted 0, charge:      0

Send CDR

...

list sub=

Usage Guidelines

Use the list sub= command to display details of a specified PPS subscriber by given its MSISDN.

Syntax Description

list sub=<msisdn>

msisdn

Specify a valid MSISDN in CC+NDC+SN format.

Examples

The following is sample output from the list sub= command.

PPS>list sub=

...

list subs segno=

Usage Guidelines

Use the list subs segno= command to display overview of 100 PPS subscribers in a specified segment.

Syntax Description

list subs segno=<index>

index

Subscriber segment index number from 0 to 999. Each segment contains 100 sequential subscribers.

Examples

The following is sample output from the list subs segno= command.

PPS>list subs segno=0

COMMAND OK!

MSISDN                  TYPE    STATUS  BALANCE COS_ID  CUGID

86755905000             00      1       50000.000000    0       0

86755905001             00      1       50000.000000    0       0

86755905002             00      1       50000.000000    0       0

86755905003             00      1       50000.000000    0       0

...

list card segno=

Usage Guidelines

Use the list card segno= command to display overview of 100 recharge cards in a specified segment.

Syntax Description

list card segno=<index>

index

Recharge card segment index number from 0 to 1999. Each segment contains 100 sequential recharge cards.

Examples

The following is sample output from the list card segno= command.

PPS>list card segno=

...

list tariff lac=

Usage Guidelines

Use the list tariff lac= command to display detailed information of a specified tariff set.

Syntax Description

list tariff lac=<index>

index

Tariff ID from 0 to 63.

Examples

The following is sample output from the list tariff lac= command.

PPS>list tariff lac=0

=====================================================

Comm tariff:

Call forwarded unit:            00

Call forwarded charge:          0.0000

Roaming  unit:                  00

Roaming  charge:                0.0000

Conference call unit:           00

Conference call charge:         0.0000

Closed User Group unit:         00

Closed User Group charge:       0.0000

Favorite change charge:         0.0000

Favorite call unit:             00

Favorite call charge:           0.0000

=====================================================

Rent:

ID      Desc.   Type    Date    Rent

=====================================================

Baisc MO tariff:

Prefix          Aread           DID     Free    CUnit   miniCU  basicFee        LongFee Adj.

0086755               86        0       1       400     1       1.0000  0.0000  0.0000

...

list tariff plan lac=

Usage Guidelines

Use the list tariff plan lac= command to display detailed information of a specified tariff plan set.

Syntax Description

list tariff plan lac=<index>

index

Tariff plan ID from 0 to 63.

Examples

The following is sample output from the list tariff plan lac= command.

PPS>list tariff plan lac=0

=====================================================

Comm tariff:

Call forwarded unit:            00

Call forwarded charge:          0.0000

Roaming  unit:                  00

Roaming  charge:                0.0000

Conference call unit:           00

Conference call charge:         0.0000

Closed User Group unit:         00

Closed User Group charge:       0.0000

Favorite change charge:         0.0000

Favorite call unit:             00

Favorite call charge:           0.0000

=====================================================

Rent:

ID      Desc.   Type    Date    Rent

=====================================================

Baisc MO tariff:

Prefix          Aread           DID     Free    CUnit   miniCU  basicFee        LongFee Adj.

0086755               86        0       1       400     1       1.0000  0.0000  0.0000

...

tariff msisdn=

Usage Guidelines

Use the tariff msisdn= command to display the details of applied tariff for a specified prepaid subscriber.

Syntax Description

tariff msisdn=<msisdn>

msisdn

Specify a valid MSISDN in CC+NDC+SN format.

Examples

The following is sample output from the tariff msisdn= command.

PPS>tariff msisdn=86755900005

...

check card=

Usage Guidelines

Use the check card= command to display the details of a recharge card by given its password.

Syntax Description

check card=<password>

password

A 12 or 16 digits recharge card password

Examples

The following is sample output from the check card= command.

PPS>check card=

...

get card index=

Usage Guidelines

Use the get card index= command to display the details of a recharge card by given its index.

Syntax Description

get card index=<index>

index

Recharge card index number from 0 to 199999.

Examples

The following is sample output from the get card index= command.

PPS>get card index=0

...

replace card

Usage Guidelines

Use the replace card command to change the dispose mode of recharge card import.

Syntax Description

replace card [on | off]

on | Allow the new import data to overwrite the existing data with the same card number.
off | Forbid overwriting the existing recharge card data.

set replaceable

Usage Guidelines

Use the set replaceable command to change the dispose mode of PPS subscriber import.

Syntax Description

set replaceable [on | off]

on | Allow the new import data to overwrite the existing data with the same MSISDN.
off | Forbid overwriting the existing PPS subscriber data.

recreate index

Usage Guidelines

Use the recreate index command to reassign subscribers and recharge cards index number so as to put them in order again.

Syntax Description

This command has no arguments or keywords.

mt

Usage Guidelines

Use the mt command to customize the PPS disposal procedures for free mobile terminated calls.

Syntax Description

mt [release | control]

release | PPS doesn't dispose of free MT calls.
control | PPS disposes of all MT calls.

pps mo

Usage Guidelines

Use the pps mo command to customize the PPS disposal procedures for free mobile originated calls.

Syntax Description

pps mo [release | control]

release | PPS doesn't dispose of free MO calls.
control | PPS disposes of all MO calls.

vms allways go

Usage Guidelines

Use the vms allways go command to customize the PPS disposal procedures for voice mail calls.

Syntax Description

vms allways go, [yes | no]

yes | PPS doesn't dispose of voice mail calls.
no | PPS dispose of voice mail call as normal prepaid call. For example, if the caller is out of balance, then the call will be released.

delay timer=

Usage Guidelines

Use the delay timer= command to set the time interval between sending CAP messages for outbound prepaid subscribers.

CAP messages: ApplyCharging -> BCSMEventRequest -> Continue

Syntax Description

delay timer=<timer>

timer

50xn ms (n=0-10).

activity timer=

Usage Guidelines

Use the activity timer= command to set the time interval between sending activity test messages.

Syntax Description

activity timer=<timer>

timer

1 to 120 seconds. Default=18s

truncation

Usage Guidelines

Use the truncation enable command to turn on the prepaid billing truncation function. If the tariff is charged as xxx.yy in minimum charging unit, then the tariff is truncated to xxx. Use the disable form of this command to turn off billing truncation function.

Syntax Description

truncation [enable | disable]

Enable | Turn on billing truncation function.
Disable | Turn off billing truncation function.

truncation?

Usage Guidelines

Use the truncation? command to check the current truncation status.

Syntax Description

This command has no arguments or keywords.

save param

Usage Guidelines

Use the save param command to save PPS system parameters residing in memory to hard disk.

Syntax Description

This command has no arguments or keywords.

page 1

Usage Guidelines

The PPS debug page 1 displays the information of PPS system parameters.

Examples

The following is page 1 sample output.

PPS    Version R9V1_00                                     Page 01

Parameter List

                   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F

cdrFlag            01

maxRechargeNum     05

sm format          06

currencyName       01 00 00 00 00 00 00 00

srfNumber0         36 36 37 35 35 39 30 30 30 30 39 00 00 00 00 00

srfNumber1         34 34 37 38 39 32 31 39 39 39 35 37 00 00 00 00

reachable          01 00

hotline            31 32 31 00 00 00 00 00 00 00 00 00 00 00 00 00

inquiryNumber      31 32 34 00 00 00 00 00 00 00 00 00 00 00 00 00

directRecharge     31 32 33 00 00 00 00 00 00 00 00 00 00 00 00 00

creditRecNumber    00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

3rdPartyRecNumber  34 34 37 38 39 32 31 31 31 31 32 31 00 00 00 00

CustomerCare       00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

rechargeNumber1    31 32 35 00 00 00 00 00 00 00 00 00 00 00 00 00

extern IVR         6C

MNP flag           00

                   00 00 00

page 2

Usage Guidelines

The PPS debug page 2 displays the information of PPS system status.

Examples

The following is page 2 sample output.

PPS    Version R9V1_00                                     Page 02

System Status

                   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F

Master             00

System state       00

Data source        02

Init progress      64

Master IP          AC 12 63 01

Peer IP            AC 12 63 01

peer_state         10

Process used       00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

                   00 00 00 00

Define

  State:0=NORMAL,1=START,2=INIT,3=SUSPEND,4=SHUTDOWN

  Data source:0=NO DATA,1=PEER SERVER,2=LOCAL HD,3=OMC HD

page 3

Usage Guidelines

The PPS debug page 3 displays the information of PPS subscribers.

Examples

The following is page 3 sample output.

PPS    Version R9V1_00                                     Page 03

User info

                   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F

system capability  00 04 00 00

license user       00 04 00 00

user number        00 00 00 03

free index         9D 86 01 00

peer user number   06 00 00 00

send sync          00 00 00 00 00 00 00 00 03 00 00 00 00 00 00 00

recv sync          00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

index status       00

get subs. result   00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

page 4

Usage Guidelines

The PPS debug page 4 displays the information of PPS recharge cards.

Examples

The following is page 4 sample output.

PPS    Version R9V1_00                                     Page 04

Prepaid card info

                   00 01 02 03 04 05 06 07 08 09 0A 0B 0C 0D 0E 0F

card number        00 00 50 00

free card mem      B8 F9 02 00

card prefix[00-03] 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

card prefix[04-07] 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

card prefix[08-11] 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

card prefix[12-15] 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

card prefix[16-19] 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

card prefix[20-23] 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

card prefix[24-27] 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

card prefix[28-31] 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

card prefix[32-35] 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

card prefix[36-39] 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

card prefix[40-43] 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

card prefix[44-47] 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

card prefix[48-51] 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

card prefix[52-55] 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

card prefix[56-59] 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

card prefix[60-63] 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

                   00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

                   00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

3.21


SCCP

SCCP Debug Commands:

· log all
· log none
· log error [on | off]
· log addr [on | off]
· log data [on | off]
· log time [on | off]
· log udt [on | off]
· log user [on | off]
· log mtp3 [on | off]
· log aif [on | off]
· log scmg [on | off]
· log snmp [on | off]
· log cond1 [and cond2]
· list route<.index>
· list spc
· save
· reset
· information page
· page 2

log all

Usage Guidelines

Use the log all command to display all SCCP component activities in the system. This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

SCCP>log all

Command OK.

(14:22:38.899923):

User ==> SCCP: UDT Message  Unit data[8->6], SLS=02, NetID=4, msglen=73

SrcAddr: SPC=000000 SSN=8 RI=0 GTI=4 NP=1 TT=0 GT=86755920004

DstAddr: SPC=000000 SSN=6 RI=0 GTI=4 NP=1 TT=0 GT=86755903675

62 47 48 04 01 63 0D 82  6B 1E 28 1C 06 07 00 11

86 05 01 01 01 A0 11 60  0F 80 02 07 80 A1 09 06

07 04 00 00 01 00 14 03  6C 1F A1 1D 02 01 40 02

01 2D 30 15 80 07 91 68  57 95 30 76 F5 81 01 01

82 07 91 68 57 95 02 00  F4

(14:22:38.899954):

SCCP ==> MTP3:  Unit data[8->6], SLS=02, NetID=0, msglen=73

SrcAddr: SPC=000001 SSN=8 RI=0 GTI=4 NP=1 TT=0 GT=86755920004

DstAddr: SPC=000001 SSN=6 RI=0 GTI=4 NP=1 TT=0 GT=86755903675

62 47 48 04 01 63 0D 82  6B 1E 28 1C 06 07 00 11

86 05 01 01 01 A0 11 60  0F 80 02 07 80 A1 09 06

07 04 00 00 01 00 14 03  6C 1F A1 1D 02 01 40 02

01 2D 30 15 80 07 91 68  57 95 30 76 F5 81 01 01

82 07 91 68 57 95 02 00  F4

...

log none

Usage Guidelines

Use the log none command to disable all SCCP debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display SCCP related messages only when errors occur. The off form of this command disables debugging output.

This command is useful for troubleshooting call fail problems because it produces little output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

SCCP>log error on

Command OK.

SCCP Timer Out Timer ID : T_IAS_OUT  ConnID : 2783

SCCP Timer Out Timer ID : T_IAS_OUT  ConnID : 2870

SCCP Timer Out Timer ID : T_IAS_OUT  ConnID : 2789

...

log addr

Usage Guidelines

Use the log addr on command to display address information in debugging output. Use the off form of this command to forbid address information output.

Syntax Description

log addr [on | off]

on | Enable address information output.
off | Disable address information output.

log data

Usage Guidelines

Use the log data on command to display hexadecimal message data in debugging output. Use the off form of this command to forbid message data output.

Syntax Description

log data [on | off]

on | Enable message data output.
off | Disable message data output.

log time

Usage Guidelines

Use the log time on command to display time information in the debugging output. Use the off form of this command to forbid time information output.

Syntax Description

log time [on | off]

on | Enable time information output.
off | Disable time information output.

log udt

Usage Guidelines

Use the log udt on command to enable debugging output of UDT messages. Use the off form of this command to disable debugging output.

Syntax Description

log udt [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log udt on command.

SCCP>log udt on

Command OK.

USER <== SCCP: UDT Message  Unit data[8->11], SLS=01, NetID=0, msglen=40

SCCP ==> MTP3:  Unit data[146->147], SLS=08, NetID=0, msglen=144

SCCP ==> MTP3:  Unit data[146->147], SLS=02, NetID=0, msglen=39

USER <== SCCP: UDT Message  Unit data[147->146], SLS=0f, NetID=0, msglen=24

USER <== SCCP: UDT Message  Unit data[147->146], SLS=07, NetID=0, msglen=22

SCCP ==> MTP3:  Unit data[146->147], SLS=0a, NetID=0, msglen=64

SCCP ==> MTP3:  Unit data[146->147], SLS=08, NetID=0, msglen=163

...

log user

Usage Guidelines

Use the log user on command to display message transactions between SCCP and upper layer. Use the off form of this command to disable debugging output.

Syntax Description

log user [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log user on command.

SCCP>log user on

Command OK.

User ==> SCCP: UDT Message  Unit data[33->7], SLS=0f, NetID=255, msglen=75

User ==> SCCP: UDT Message  Unit data[8->8], SLS=01, NetID=4, msglen=65

User ==> SCCP: UDT Message  Unit data[8->8], SLS=02, NetID=0, msglen=58

User ==> SCCP: UDT Message  Unit data[8->8], SLS=09, NetID=4, msglen=15

User ==> SCCP ==> MNP_SRF : UDT Message  Unit data[8->6], SLS=03, NetID=4, msglen=81

User ==> SCCP: UDT Message  Unit data[147->146], SLS=0c, NetID=0, msglen=24

...

log mtp3

Usage Guidelines

Use the log mtp3 on command to display message transactions between SCCP and MTP3. Use the off form of this command to disable debugging output.

Syntax Description

log mtp3 [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log mtp3 on command.

SCCP>log mtp3 on

Command OK.

Message redirected. SCCP ==> MTP3.  Data Form 1[0->0], SLS=08, NetID=2, msglen=5

SCCP <== MTP3. UDT Message  Unit data[147->146], SLS=0f, NetID=0, msglen=39

SCCP <== MTP3. UDT Message  Unit data[146->147], SLS=05, NetID=0, msglen=165

SCCP <== MTP3. UDT Message  Unit data[147->146], SLS=03, NetID=0, msglen=22

SCCP <== MTP3. UDT Message  Unit data[147->146], SLS=03, NetID=0, msglen=39

Message redirected. SCCP ==> MTP3.  Data Form 1[0->0], SLS=0b, NetID=2, msglen=5

...

log aif

Usage Guidelines

Use the log aif on command to display debugging output of the A-Interface messages through SCCP layer. Use the off form of this command to disable debugging output.

Syntax Description

log aif [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log aif on command.

SCCP>log aif on

Command OK.

Connect Ind primitive Flag :0x4 NetID : 2 RI : 1 SSN : 254

Connect Ind primitive Flag :0x4 NetID : 2 RI : 1 SSN : 254

SCCP ==> MTP3: AIF  Data Form 1[0->0], SLS=0f, NetID=2, msglen=5

SLR = 02007F DLR = 01000E

SCCP ==> MTP3: AIF  Data Form 1[0->0], SLS=0a, NetID=2, msglen=6

SLR = 02006A DLR = 010031

SCCP ==> MTP3: AIF  Data Form 1[0->0], SLS=05, NetID=2, msglen=6

SLR = 021FD5 DLR = 01002E

...

log scmg

Usage Guidelines

Use the log scmg on command to display debugging output of the SCCP management messages. Use the off form of this command to disable debugging output.

Syntax Description

log scmg [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log scmg on command.

SCCP>log scmg on

...

log snmp

Usage Guidelines

Use the log snmp on command to display Element Management System maintenance messages. Use the off form of this command to disable debugging output.

Syntax Description

log snmp [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log snmp on command.

SCCP>log snmp on

...

log cond1 [and cond2]

Usage Guidelines

Use the log cond command to enable conditionally debugging output for the messages from/to specified subsystem number or point code. Use log none command to disable debugging output.

Syntax Description

log [src ssn=<ssn> | and dst ssn=<ssn> | and opc=<opc> | and dpc=<dpc>]

scr ssn | Specify a source subsystem number.
dst ssn | Specify a destination subsystem number.
opc | Specify an origination point code.
dpc | Specify a destination point code.

Examples

The following is sample output from the log cond command.

SCCP>log src ssn=8 and dst ssn=6

log src ssn = 0x08 and dst ssn = 0x06

command OK

SCCP ==> MTP3:  Unit data[8->6], SLS=02, NetID=0, msglen=73

USER <== SCCP: UDT Message  Unit data[8->6], SLS=09, NetID=0, msglen=73

USER <== SCCP: UDT Message  Unit data[8->6], SLS=01, NetID=4, msglen=79

USER <== SCCP: UDT Message  Unit data[8->6], SLS=03, NetID=0, msglen=81

...

list route

Usage Guidelines

Use the list route command to display the Global Title Translation (GTT) routing table.

Syntax Description

list route<.index>

index

(Optional) Specify the first route to display.

Examples

The following is sample output from the log route command.

SCCP>list route

#No NP TT StartDigits     EndDigits       NI SPC    SSN RI AI S E N Rep

0   1  -  86755900000     86755999999     0  000001 6   0  7

1   1  -  86755800001     86755800001     0  000001 7   0  7

2   1  -  86755800002     86755800002     0  000001 6   0  7

3   1  -  86755800003     86755800003     0  000001 10  0  7

4   6  -  637105200011000 637105200011999 0  000001 6   0  7

...

list spc

Usage Guidelines

Use the log spc command to display the local signaling point codes in 4 networks.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list spc command.

SCCP>list spc

NI SPC_Len  SPC

0   2       000001

1   2       000008

2   2       000001

3   2       000001

Command OK.

save

Usage Guidelines

Use the save command to save SCCP parameters residing in memory to hard disk.

Syntax Description

This command has no arguments or keywords.

reset

Usage Guidelines

Use the reset command to reload SCCP parameters and initialize its status.

Syntax Description

This command has no arguments or keywords.

page 1

Usage Guidelines

The SCCP debug page 1 displays the information of SCCP local subsystems.

Examples

The following is page 1 sample output.

SCCP-R9V1_05       Page 02 M    IB-Status Of Local Subsystem

[   SSN   ]        S1 S2 N  Lc NI RG [   IP1   ] [   IP2   ]

04-                01 01 00 00 02 00 AC 12 80 01 AC 12 81 01    # OMC

06-66755900003     03 03 00 01 02 01 AC 12 62 01 AC 12 63 01    # HLR

07-66755900002     03 03 00 01 02 01 AC 12 62 01 AC 12 63 01    # VLR

08-66755900000     03 03 00 01 02 01 AC 12 62 01 AC 12 63 01    # MSC

0A-66755900022     03 03 00 01 02 01 AC 12 62 01 AC 12 63 01    # AUC

0B-66755900004     03 03 00 01 02 01 AC 12 62 01 AC 12 63 01    # SMSC

13-66755900006     03 03 02 01 02 01 AC 12 62 01 AC 12 63 01    # SMPP-ESME

14-66755900005     03 03 02 01 02 01 AC 12 62 01 AC 12 63 01    # SMPP-SMSC

15-66755900015     01 00 00 00 02 00 AC 12 80 01 FF FF FF FF    # SMPP-OMC

16-66755900009     03 00 00 01 01 01 AC 12 62 01 FF FF FF FF    # SRF0

17-66755900016     03 00 00 00 01 00 AC 12 63 01 FF FF FF FF    # SRF1

20-66755900011     03 03 00 01 02 01 AC 12 62 01 AC 12 63 01    # SRF2

21-66755900012     03 03 00 01 02 01 AC 12 62 01 AC 12 63 01    # SRF3

92-66755900001     03 03 00 01 02 01 AC 12 62 01 AC 12 63 01    # SSF

93-66755900007     03 03 00 01 02 01 AC 12 62 01 AC 12 63 01    # SCF-CAP

99-66755900010     03 03 00 01 02 01 AC 12 62 01 AC 12 63 01    # SCF-MAP

FE-                03 03 03 01 02 01 AC 12 62 01 AC 12 63 01 # AIF

3.22


SIP

SIP Debug Commands:

· log all
· log none
· log error [on | off]
· log sip [on | off]

log all

Usage Guidelines

Use the log all command to display debugging output from the Session Initiation Protocol (SIP) routines in the system.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

SIP>log all

...

log none

Usage Guidelines

Use the log none command to disable SIP debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display SIP related information only when errors occur. The off form of this command disables debugging output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

SIP>log error on

...

log sip

Usage Guidelines

Use the log sip on command to enable SIP activity debugging. Use the off form of this command to disable debugging output.

Syntax Description

log sip [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log sip on command.

SIP>log sip on

...

3.23


SMPP

SMPP Debug Commands:

· log all
· log none
· log link=<link> [on | off]
· list par.<link>
· save
· information pages
· page 1
· page 3
· page 4

log all

Usage Guidelines

Use the log all command to display debugging output from the Short Message Peer to Peer (SMPP) protocol routines in the system. This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

SMPP>log all

smpp turn on all log items.

link 3 T1 (Enquire link timer) TIMEOUT.

SMPP==>    ENQUIRE_LINK link: 3

ENCODE:

00 00 00 10 00 00 00 15 00 00 00 00 00 00 01 B1 50 50

GTAI: 6657950000F5

GTAI: 6657950000F6

==>SMPP    ENQUIRE_LINK link: 4

00 00 00 10 00 00 00 15 00 00 00 00 00 00 01 B1

DECODE:

[Header]

command_length=0x10(hex), command_id=0x15(hex), command_status=0x0(No Error), sequence_number=433(dec)

link 4 T1 (Enquire link timer) TIMEOUT.

...

log none

Usage Guidelines

Use the log none command to disable all SMPP debugging output.

Syntax Description

This command has no arguments or keywords.

log link

Usage Guidelines

Use the log link on command to display message transactions on a specified SMPP link. The off form of this command disables debugging output.

Syntax Description

log link=<link> [on | off]

link | Specify a SMPP link.
on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log link on command.

SMPP>log link=3 on

Link 3 debug on.

link 3 T1 (Enquire link timer) TIMEOUT.

SMPP==>    ENQUIRE_LINK link: 3

ENCODE:

00 00 00 10 00 00 00 15 00 00 00 00 00 00 01 C9 50 50

==>SMPP    ENQUIRE_LINK_RESP    link: 3

00 00 00 10 80 00 00 15 00 00 00 00 00 00 01 C9

DECODE:

[Header]

command_length=0x10(hex), command_id=0x80000015(hex), command_status=0x0(No Error), sequence_number=457(dec)

...

list par.

Usage Guidelines

Use the list par. command to display detailed information of a specified SMPP link.

Syntax Description

list par.<link>

link

Specify a SMPP link.

Examples

The following is sample output from the list par. command.

SMPP>list par.1

Link 1 parameter:

link_enable: 129

link_type: 1

server_type: 1

session_type: 0

system_id: omc

password: 123456

system_type: GSM

localGTT: --

remoteGTT: --

local_ip: 172.18.98.1

remote_ip: 172.18.128.1

session_init_timer: 5

enquire_link_timer: 10

inactivity_timer: 5

response_timer: 5

service_number: 98765

localSSN: 0

remoteSSN: 0

save

Usage Guidelines

Use the save command to save SMPP parameters residing in memory to hard disk.

Syntax Description

This command has no arguments or keywords.

page 1

Usage Guidelines

The SMPP debug page 1 displays the status of all 32 SMPP links.

Examples

The following is page 1 sample output.

SMPP R9         Page 01    link status (32 links)

                0  1  2  3  4  5  6  7  8  9  10 11 12 13 14 15

link_status     00 00 01 03 03 01 00 01 01 03 03 00 00 00 00 00

                00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

daemon sock     28

tcp_client_flag 00 00 00 00 00 00 00 01 00 00 00 00 00 00 00 00

                00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

sock_fd         00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

                00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

                00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

                00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

                00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

                00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

                00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

                00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

Link status:

  00 -- Not init

  01 -- IDLE

  02 -- WAITING

  03 -- ESTABLISHED

  04 -- SUSPEND

page 3

Usage Guidelines

The SMPP debug page 3 displays the link type of SMPP link 0 to 21.

Examples

The following is page 3 sample output.

SMPP R9         Page 03    link type (link 0~21)

                type         00 -- UDP,      01 -- TCP

link 0          01

link 1          01

link 2          01

link 3          00

link 4          00

link 5          01

link 6          01

link 7          01

link 8          01

link 9          00

link 10         00

link 11         01

link 12         00

link 13         00

link 14         00

link 15         00

link 16         00

link 17         00

link 18         00

link 19         00

link 20         00

link 21         00

page 4

Usage Guidelines

The SMPP debug page 4 displays the link type of SMPP link 22 to 31.

Examples

The following is page 4 sample output.

SMPP R9         Page 04    link type (link 22~31)

                type         00 -- UDP,      01 -- TCP

link 22         00

link 23         00

link 24         00

link 25         00

link 26         00

link 27         00

link 28         00

link 29         00

link 30         00

link 31         01

3.24


SMSC

SMSC Debug Commands:

· log all
· log none
· log error [on | off]
· log debug [on | off]
· log map [on | off]
· log time [on | off]
· log smpp [on | off]
· log port <pid>
· log msisdn <msisdn>
· list parameter
· list subs
· list smpp
· del all sm
· del sm <msisdn>
· information page
· page 1
· page 2

log all

Usage Guidelines

Use the log all command to turn on all of the SMSC debug commands simultaneously. It displays debugging information on all SMSC component activities.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

SMSC>log all

SMSC trun on all log items

(2008/11/24 16:40:8.106)        (Debug)

Info:check_isdn_site2:isdn_site=0

(2008/11/24 16:40:8.120)        (Debug)

Info:smsc_get_pendsm:debugNo=10,isdn_index=0,isdn=9186755903205EEEEE

SMSC => XAPP:

(2008/11/24 16:40:8.155) [Dialogue]     Length: 69  Process ID: 936  Dialogue ID: 1710

Operation code: MAP_OPEN(255)  Operation type: MAP_REQUEST(1)

14 03 00 00 00 00 00 00 00 00 04 06 00 04 00 01 E0 04 0B 68 57 95 30 02 F5 F1 D4 DA AA 09 00 00 00 00 00 00 00 00 04 08 00 04 00 01 FF 04 0B 68 57 95 02 00 F4 F4 FF B1 00 CC 01 00

SMSC => XAPP:

(2008/11/24 16:40:8.205)        [Operation]     Length: 40      Process ID: 936 Dialogue ID: 1710

Operation code: SEND_ROUTING_INFO_FOR_SM(45)  Operation type: MAP_REQUEST(1)  Invoke ID: 64

01 01 00 17 30 15 80 07 91 68 57 95 30 02 F5 81 01 01 82 07 91 68 57 95 02 00 F4 10 00 00

(2008/11/24 16:40:8.205)        (Debug)

Info:[MT] Send SRI for SM. pid = 936, did = 1710, map_version=3

...

log none

Usage Guidelines

Use the log none command to disable all SMSC debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display SMSC related information only when errors occur. The off form of this command disables debugging output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

SMSC>log error on

Turn on error log

(Error)

Reason:SMSC receive user error 31 when MT_SM ack

(Error)

Reason:SMSC receive user error 31 when MT_SM ack

...

log debug

Usage Guidelines

Use the log debug on command to enable SMSC event debugging. Use the off form of this command to disable debugging output.

Syntax Description

log debug [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

SMSC>log debug on

Turn on debug item

(Debug)

Info:smsc_store_data:debugNo=18,data_type=2,opr_flag=2,store_flag=1

(Debug)

Info:smsc_store_sm:sm_ptr->dst_addr=9186755903205EEEEE,debugNo=0,data_type=2,local_flag=1

(Debug)

Info:assign_isdn_site1:isdn_site=FFFFFFFF

(Debug)

Info:check_isdn_site2:isdn_site=0

...

log map

Usage Guidelines

Use the log map on command to display MAP message transactions between SMSC and XAPP modules. Use the off form of this command to disable debugging output.

Syntax Description

log map [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log map on command.

SMSC>log map on

Turn on MAP Msg log

SMSC => XAPP:

[Dialogue]      Length: 69  Process ID: 936  Dialogue ID: 976

Operation code: MAP_OPEN(255)  Operation type: MAP_REQUEST(1)

14 03 00 00 00 00 00 00 00 00 04 06 00 04 00 01 E0 04 0B 68 57 95 30 02 F5 F1 D4 DA AA 09 00 00 00 00 00 00 00 00 04 08 00 04 00 01 FF 04 0B 68 57 95 02 00 F4 F4 FF B1 00 CC 01 00

SMSC => XAPP:

[Operation]     Length: 40      Process ID: 936 Dialogue ID: 976

Operation code: SEND_ROUTING_INFO_FOR_SM(45)  Operation type: MAP_REQUEST(1)  Invoke ID: 64

01 01 00 17 30 15 80 07 91 68 57 95 30 02 F5 81 01 01 82 07 91 68 57 95 02 00 F4 10 00 00

...

log time

Usage Guidelines

Use the log time on command to display time information in the debugging output. Use the off form of this command to forbid time information output.

Syntax Description

log time [on | off]

on | Enable time information output.
off | Disable time information output.

log smpp

Usage Guidelines

Use the log smpp on command to display SMPP message transactions between SMSC and SMPP modules. Use the off form of this command to disable debugging output.

Syntax Description

log smpp [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log smpp on command.

SMSC>log smpp on

...

log port

Usage Guidelines

Use the log port command to display information of a specific task process. Use the log none command to disable debugging output.

Syntax Description

log port <pid>

pid

Specify a processing task ID.

Examples

The following is sample output from the log port command.

SMSC>log port 936

[Operation]     Length: 40      Process ID: 936 Dialogue ID: 2673

Operation code: SEND_ROUTING_INFO_FOR_SM(45)  Operation type: MAP_REQUEST(1)  Invoke ID: 64

01 01 00 17 30 15 80 07 91 68 57 95 30 02 F5 81 01 01 82 07 91 68 57 95 02 00 F4 10 00 00

[Operation]     Length: 38      Process ID: 936 Dialogue ID: 2673

Operation code: SEND_ROUTING_INFO_FOR_SM(45)  Operation type: MAP_CONFIRM(4)  Invoke ID: 64

01 01 00 17 30 15 04 08 64 00 92 00 00 30 02 F5 A0 09 81 07 91 68 57 95 02 00 F0 00

[Operation]     Length: 21      Process ID: 936 Dialogue ID: 2673

Operation code: INFORM_SERVICE_CENTER(63)  Operation type: MAP_INDICATE(2)  Invoke ID: 65

01 01 00 06 30 04 03 02 02 40 00

...

log msisdn

Usage Guidelines

Use the log msisdn command to track the SMSC transaction processes related with a specific subscriber by given its MSISDN. Use log none command to disable tracking.

Syntax Description

log msisdn <msisdn>

msisdn

Specify a valid MSISDN in CC+NDC+SN format.

Examples

The following is sample output from the log misisdn command.

SMSC>log msisdn 86755903205

Sends sm to MSISDN 86755903205 from SMSC

Short message information:

Status: 0x10

Message reference: 0x17

Protocol idntifier: 0x0

Coding scheme: 0x0

Originating address: 0B916857953071F3

Destination address: 0B916857953002F5

Time stamp: 80114261024100

Data length: 11

More messages to send: 0

VP timer: 42900

Seq_num: 313186

Init timer: 1227543614

smsc_vm_ptr->seq_num: 316674

sm_ptr->release_id: 1

sm_ptr->report_flag: 0

...

list parameter

Usage Guidelines

Use the log parameter command to list further command hints for system parameters or SMPP link parameters.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list parameter command.

SMSC>list parameter

You can list parameter by the command below:

list sys param ---- List the SMSC system paramter

list smpp sccp [index (0--7)] ---- List the SMPP (sccp link) parameter by index

list smpp tcp [index (0--31)] ---- List the SMPP (tcp link) parameter by index

SMSC>list sys param

CDR flag: 1

SMSC number: 86755920004

Local IP address: 172.18.99.1

MSISDN range: from 86755900000 to 86755919999

MSISDN range: from 86755900000 to 86755919999

list subs

Usage Guidelines

Use the list subs command to display the subscribers who have pending messages.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log error on command.

SMSC>list subs

Total pending subscribers: 1

86755903205

Use command below to list the sm index of one MSISDN:

list sub detail [msisdn]

list smpp

Usage Guidelines

Use the list smpp command to display the information of all SMPP links configured in the SMSC module.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list smpp command.

SMSC>list smpp

The following is smpp link status

       Type:0-BIND_TX; 1-BIND_RX; 2-BIND_TRX

       PlatNo:0=plat0, 1=plat1, 2=ignore(for udp link)

No.     Type    PlatNo  Dcs     Smpp_num        State   ServiceNum

...

del all sm

Usage Guidelines

Use the del all sm command to delete all pending messages from the SMSC database.

Syntax Description

This command has no arguments or keywords.

del sm

Usage Guidelines

Use the del sm command to delete all pending messages of a specified subscriber.

Syntax Description

del sm <msisdn>

msisdn

Specify a valid MSISDN in CC+NDC+SN format.

page 1

Usage Guidelines

The SMSC debug page 1 displays the information of SMSC system parameters.

Examples

The following is page 1 sample output.

Page 1             SMSC information

Version            09 00 03

System ID          00

SMSC state         01

CDR flag           01

SMSC address       91 66 75 59 00 00 4E EE EE

Valid period       C0 A8 00 00

Start MSISDN       91 66 75 59 00 00 0E EE EE

End MSISDN         91 66 75 59 29 99 9E EE EE

SMPP IP

SMPP SCCP

Local IP           AC 12 62 01

Peer server IP     AC 12 63 01

Primary OMC        AC 12 80 01

Secondary OMC      00 00 00 00

Pend sm            00 00 00 00

                   00 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

                   FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

                   FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

                   02 04 06 08 0A 0C 0E 10 12 14 16 18 1A 1C 1E 20 22 24 26 28

                   01 FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

                   FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

                   FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

page 2

Usage Guidelines

The SMSC debug page 2 displays the information of 64 SMPP links.

Examples

The following is page 2 sample output.

Page 2             SMSC SMPP information

Link number        00

Link info

Service type

Connect flag

State info

Used flag

State

Send flag          00 00 00

Sequence id

data_timer

smpp timer

smpp vp_timer

CSTA index         00

System ID          00

Peer status        00

Polling User       45 DE 00 00

3.25


SNMP

SNMP Debug Commands:

· log all
· log none
· log error [on | off]
· log noreg [on | off]
· log value [on | off]
· log alarm [on | off]
· log mib [on | off]
· log sys [on | off]
· log <type> cond1 [and cond2]

log all

Usage Guidelines

Use the log all command to display all network management activities in the system. This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

SNMP>log all

Command OK

local:4957 ==> 172.18.98.1:4957 Type=Trap-V2, RID=1, Error=0, Bind=1

oid[0]=1.3.6.1.4.1.1373.2.3.3.1.6, vartype=04, msglen=1

02

Totol length(1438) exceed limit(1500):current varindex = 9

local:4957 ==> 172.18.128.1:4968 Type=Response, RID=13735566, Error=1, Bind=20

oid[0]=1.3.6.1.4.1.1373.2.3.3.1.4.3.29099224, vartype=04, msglen=108

02 04 01 BC 04 D8 A5 64 80 01 05 81 07 04 68 57 95 02 00 F0 A2 03 80 01

08 A3 03 80 01 08 84 05 81 18 00 22 12 85 05 81 18 00 32 12 A6 03 83 01

11 87 09 08 11 24 17 18 08 2B 00 00 88 09 08 11 24 17 18 11 2B 00 00 89

09 08 11 24 17 18 14 2B 00 00 8A 01 02 8C 01 00 AD 03 82 01 10 8E 02 39

A6 8F 01 00 B0 06 81 01 0A 82 01 00

oid[1]=1.3.6.1.4.1.1373.2.3.3.1.4.3.29099223, vartype=04, msglen=165

02 04 01 BC 04 D7 A0 81 9C 80 01 00 81 08 64 00 92 00 00 19 51 F6 83 07

91 68 57 95 19 51 F6 84 07 91 68 57 95 19 51 F6 85 07 91 68 57 95 19 66

F8 89 07 04 68 57 95 02 00 F0 AA 03 80 01 09 AC 06 80 01 61 81 01 09 AE

03 83 01 11 94 03 03 01 00 96 09 08 11 24 17 17 59 2B 00 00 97 09 08 11

24 17 18 05 2B 00 00 98 09 08 11 24 17 18 14 2B 00 00 99 01 08 9C 01 00

9E 01 00 BF 1F 03 82 01 10 9F 20 02 34 AF 9F 21 01 00 BF 23 06 81 01 0A

82 01 00 9F 24 07 91 68 57 95 02 10 F2 9F 25 01 00 9F 29 01 00

...

log none

Usage Guidelines

Use the log none command to disable all SNMP debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display SNMP related information only when errors occur. The off form of this command disables debugging output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

SNMP>log error on

Command OK

Totol length(1411) exceed limit(1500):current varindex = 9

Totol length(1571) exceed limit(1500):current varindex = 7

Totol length(1510) exceed limit(1500):current varindex = 8

Totol length(1512) exceed limit(1500):current varindex = 8

...

log noreg

Usage Guidelines

Use the log noreg on command to display warning information if the applied oid is not registered in the system.

Syntax Description

log noreg [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log noreg on command.

SNMP>log noreg on

...

log value

Usage Guidelines

Use the log error on command to display the value part of SNMP message.

Syntax Description

log value [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log value on command.

SNMP>log value on

...

log alarm

Usage Guidelines

Use the log alarm on command to display alarm information received from other application modules.

Syntax Description

log alarm [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log alarm on command.

SNMP>log alarm on

...

log mib

Usage Guidelines

Use the log mib on command to enable debugging output of CSTA messages. Use off form of this command to disable debugging output.

Syntax Description

log mib [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log mib on command.

SNMP>log mib on

...

log sys

Usage Guidelines

Use the log sys on command to display changes of system state, such as system time. Use the off form of this command to disable debugging output.

Syntax Description

log sys [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log sys on command.

SNMP>log sys on

...

log <type> cond1 [and cond2]

Usage Guidelines

Use the log cond command to enable conditionally debugging output for the SNMP messages meet specified conditions. Use log none command to disable debugging output.

Syntax Description

log <type> [oid=<oid> | and ip=<ip> | and local port=<port> | and remote port=<port>]

type | Select one of the types to monitor: snmp, trap, set, get, rsp
oid | Specify a SNMP object ID.
ip | Specify an IP address in x.x.x.x format.
local port | Specify a local port.
remote port | Specify a remote port.

Examples

The following is sample output from the log cond command.

SNMP>log trap oid=1.3.6.1.4.1373 and ip=172.18.98.1

...

3.26


SSF

SSF Debug Commands:

· log all
· log none
· log error

log all

Usage Guidelines

Use the log all command to display information about SSF activity.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

SSF>log all

ssf all switch open

[1155] SSF <== CCF  : Int_DP_T_Disconnect

CCF Port : 0744 Leg : 002 Type : 0

[1155] SSF ==> XAPP : Cap_ApplyChargingReport

CCF Port: 744  did = 1312 msglen = 34

00 22 8A 04 83 00 05 20  00 24 01 45 01 01 00 11

04 0F A0 0D A0 03 81 01  01 A1 03 80 01 03 82 01

00 00

[1155] SSF ==> XAPP : Cap_EventReportBCSM

CCF Port: 744  did = 1312 msglen = 32

00 20 8A 04 83 00 05 20  00 18 01 46 01 01 00 0F

30 0D 80 01 11 A3 03 81  01 02 A4 03 80 01 00 10

SSF Send Cap Message Pending: SendCap_ERB

[1155] SSF State    : SSF_WF_Ins  CCF Port: 744

[1261] SSF <== CCF  : Int_DP_T_Answer

CCF Port : 1332 Leg : 000 Type : 135304778

...

log none

Usage Guidelines

Use the log none command to disable SSF debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error command to display SSF related messages only when errors occur. Use the log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log error command.

SSF>log error

ssf error switch open

SSF Send Cap Message Pending: ACT Response

SSF Send Cap Message Pending: SendCap_InitDPMT

[1941] SSF Info: Tssf_Timer_Out uSrvType: 2 uState: 3 CCF Port: 9583 LastEvent: 17 OldState: 4

SSF Send Cap Message Pending: ACT Response

[0303][SSF ERROR] :  ssfRecvCapMsg decode message error! OperaCode = 22 CCF Port 6347 did 2289 State: 3 OldState: 4 Event: 0 lastEvent: 17

30 1B 80 07 91 68 57 95  19 37 F5 83 01 00 86 07

91 68 57 95 02 00 F0 AB  04 03 02 00 00

CapInitDP_MO

[3154] SSF Info: Tssf_Timer_Out uSrvType: 2 uState: 3 CCF Port: 24588 LastEvent: 17 OldState: 4

...

3.27


TCAP

TCAP Debug Commands:

· log all
· log none
· log error [on | off]
· log tcu
· log sccp
· log port <did>
· list para
· information page
· page 1

log all

Usage Guidelines

Use the log all command to turn on the log error, log tcu, and log sccp commands simultaneously. It displays all TCAP component activities in the system.

This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

TCAP>log all

Component tc user->tcap, time: Fri Nov 21 11:47:06 2008

Type: Invoke    Flag: Request   Dialogue id: 123, Invoke id: 64

Operation code: 55      Parameter len: 0

Component tc user->tcap, time: Fri Nov 21 11:47:06 2008

Type: Invoke    Flag: Request   Dialogue id: 124, Invoke id: 64

Operation code: 55      Parameter len: 0

Dialogue tc user->tcap, time: Fri Nov 21 11:47:06 2008

Type: Begin     Flag: Request   Dialogue id: 123

ACN is: 04 00 00 01 00 32 02

Has component

...

log none

Usage Guidelines

Use the log none command to disable all TCAP debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display errors occurring in the TCAP layer. The off form of this command disables debugging output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

TCAP>log error on

ISM warning. Invoke timer expired 1. Did: 562, Iid: 65

check_csldata, cmprecv: 161, did: 3931

TCAP_SUSPEND error. did: 3931

...

log tcu

Usage Guidelines

Use the log tcu command to display message transactions between TCAP and TCAP User layers. Use the log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log tcu command.

TCAP>log tcu

Component tcap->tc user, time: Thu Nov 20 16:33:42 2008

Type: Result_L  Flag: Indicate  Dialogue id: 1293, Invoke id: 169

Dialogue tcap->tc user, time: Thu Nov 20 16:33:42 2008

Type: Continue  Flag: Indicate  Dialogue id: 3656

Has component

...

log sccp

Usage Guidelines

Use the log sccp command to display message transactions between TCAP and SCCP layers. Use the log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log sccp command.

TCAP>log sccp

tcap monitoring sccp message switch open

sccp->tcap, len: 24, time: Thu Nov 20 16:33:53 2008

65 16 48 04 01 62 01 4F 49 04 01 63 00 EE 6C 08 A1 06 02 01 5D 02 01 37

Continue received from sccp

otid: 0162014F, dtid: 016300EE

dialogue portion len: 00, component portion len: 08

...

log port <did>

Usage Guidelines

Use the log port command to track the TCAP transaction process for a specified dialogue.

Syntax Description

log port <did>

did

Specify a processing dialogue ID.

Examples

The following is sample output from the log port command.

TCAP>log port 1

...

list para

Usage Guidelines

Use the list para command to display TCAP timer configuration.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list para command.

TCAP>list para

The TCAP system parameters are:

Invoke timer:10 s

Reject timer:2 s

page 1

Usage Guidelines

The TCAP debug page 1 displays the information of TCAP module.

Examples

The following is page 1 sample output.

Version:R9V0T6  Page 01         TCAP module information

Start time      08 0B 0C 07 1D 23

Current time    08 0B 0C 07 26 2A

Invoke timer    0A

Reject timer    02

Monitor did     00 00 00 00

Tcap status     09 00 06 01 00 00 00 04

                AC 12 62 01 AC 12 63 01

3.28


UES

UES Debug Commands:

· log all
· log none
· log error [on | off]
· log func [on | off]
· log state [on | off]

log all

Usage Guidelines

Use the log all command to turn on all of the UES debug commands simultaneously. It displays debugging information on all UES component activities.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

UES>log all

...

log none

Usage Guidelines

Use the log none command to disable all UES debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display UES related messages only when errors occur in the network. The off form of this command disables debugging output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

PALIM>log error on

...

log func

Usage Guidelines

Use the log func command to display the basic information of UES activities. It produces little output. The off form of this command disables debugging output.

Syntax Description

log func [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log func on command.

UES>log func on

...

log state

Usage Guidelines

Use the log state on command to display UES state information. The off form of this command disables debugging output.

Syntax Description

log state [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log state on command.

UES>log state on

...

3.34


VLR

VLR Debug Commands:

· log all
· log none
· log error [on | off]
· log mapb [on | off]
· log mapd [on | off]
· log sync [on | off]
· log port=<pid>
· log imsi=<imsi>
· log msisdn=<msisdn>
· list subs <index>
· list index <index>
· list imsi=<imsi>
· list para
· list status
· del imsi=<imsi>
· get <oid>
· set <oid>=<value>
· reserve [private | public]
· purge <imsi>
· save
· reset
· information pages
· page 1
· page 7

log all

Usage Guidelines

Use the log all command to turn on all of the VLR debug commands simultaneously. It displays debugging information on all VLR component activities.

This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

VLR>log all

Command OK

mscPutMessage: srcPort = 30367, dstPort = 699.

LocalVLR ==> PeerVLR: Set subscriber 460029000091003 status to 0x00(pid=28430)

mscPutMessage: srcPort = 30355, dstPort = 947.

mscPutMessage: srcPort = 30356, dstPort = 669.

PeerVLR ==> LocalVLR: set subscriber 460029000091710 status to 0xC1(pid=22034)

LocalVLR ==> PeerVLR: Release MSRN 876

LocalVLR ==> PeerVLR: Release MSRN 1788

LocalVLR ==> PeerVLR: Set subscriber 460029000091050 status to 0xC3(pid=29598)

mscPutMessage: srcPort = 30362, dstPort = 108.

Receive MapB Message. oCode=0x82

MSC ==> VLR: PAR

CM service type = 0x00

Access Conn Status = 0x00

SCI  = 0009

IMSI = 460029000091705

CKSN = 7

mscPutMessage: srcPort = 30377, dstPort = -1.

Apply for new port. PortNum = 855

Receive MapB Message. oCode=0x86

...

log none

Usage Guidelines

Use the log none command to disable all VLR debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display VLR related information only when errors occur. The off form of this command disables debugging output.

This command is useful for troubleshooting call fail problems because it produces little output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

VLR>log error on

Command OK

Release Connection to MAPP, did = 2545

Release Connection to MAPP, did = 996

Release Connection to MAPP, did = 1327

Release Connection to MAPP, did = 1425

Release Connection to MAPP, did = 4035

Release Connection to MAPP, did = 3475

...

log mapb

Usage Guidelines

Use the log mapb on command to display the message transactions between VLR and MSC. The off form of this command disables debugging output.

Syntax Description

log mapb [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log mapb on command.

VLR>log mapb on

Command OK

mscPutMessage: srcPort = 24974, dstPort = 913.

mscPutMessage: srcPort = 25005, dstPort = -1.

Apply for new port. PortNum = 320

mscPutMessage: srcPort = 25012, dstPort = -1.

Apply for new port. PortNum = 150

mscPutMessage: srcPort = 25015, dstPort = -1.

Apply for new port. PortNum = 737

mscPutMessage: srcPort = 25005, dstPort = 320.

...

log mapd

Usage Guidelines

Use the log mapd on command to display the message transactions between VLR and HLR. The off form of this command disables debugging output.

Syntax Description

log mapd [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log mapd on command.

VLR>log mapd on

...

log sync

Usage Guidelines

Use the log sync on command to display subscriber data synchronization processing between two VLR servers. The off form of this command disables debugging output.

Syntax Description

log sync [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log sync on command.

VLR>log sync on

Command OK

LocalVLR ==> PeerVLR: Set subscriber 460029000091351 status to 0x00(pid=32676)

LocalVLR ==> PeerVLR: Set subscriber 460029000091855 status to 0xC3(pid=1544)

PeerVLR ==> LocalVLR: Release MSRN 57

PeerVLR ==> LocalVLR: set subscriber 460029000091003 status to 0x00(pid=24412)

PeerVLR ==> LocalVLR: set subscriber 460029000091349 status to 0xC3(pid=25620)

...

log port=

Usage Guidelines

Use the log port= command to display the information of a processing VLR task. Use the log none command to disable debugging output.

Syntax Description

log port=<pid>

pid

Specify a processing task ID.

Examples

The following is sample output from the log port= command.

VLR>log port=1000

...

log imsi=

Usage Guidelines

Use the log imsi= command to track the VLR transaction processes related with a specific subscriber by given its IMSI. Use log none command to disable tracking.

Syntax Description

log imsi=<imsi>

imsi

Specify a 15-digit IMSI.

Examples

The following is sample output from the log imsi= command.

VLR>log imsi=

...

log msisdn=

Usage Guidelines

Use the log msisdn= command to track the VLR transaction processes related with a specific subscriber by given its MSISDN. Use log none command to disable tracking.

Syntax Description

log msisdn=<msisdn>

msisdn

Specify a valid MSISDN in CC+NDC+SN format.

Examples

The following is sample output from the log msisdn= command.

VLR>log msisdn=

...

list subs

Usage Guidelines

Use the list subs command to display basic information of 16 VLR subscribers.

Syntax Description

list subs <index>

index

(Optional) Specify the first subscriber to be displayed by its index.

Examples

The following is sample output from the list subs command.

VLR>list subs 25

2716 Record in VLR now. 25 - 50:

NO     IMSI             MSISDN           OPT_MSISDN       TMSI     CNF Det NRF LNA OCSI OPRFG

25     460029000001027  86755901027      ----------       ffffffff  Y   N   N   N   Y    7

26     460029000001028  86755901028      ----------       ffffffff  Y   N   N   N   Y    7

27     460029000001029  86755901029      ----------       ffffffff  Y   N   N   N   Y    7

28     460029000001030  86755901030      ----------       ffffffff  Y   N   N   N   Y    7

...

list index

Usage Guidelines

Use the list index command to display detailed information of a VLR subscriber by given its index.

Syntax Description

list index <index>

index

Specify a VLR subscriber by its index.

Examples

The following is sample output from the list index command.

VLR>list index 25

IMSI:460029000001027    MSISDN:86755901027        TMSI:FFFFFFFF

LAI: 6420000007         Cell ID:0009

Data Confirmed: Y       Loc Confirmed:  Y       Radio Confirmed:Y

IMSI Detached:  N       MNRF:           N       Roaming Rest:   N

LA Not Allow:   N       MS Status(MSC):0xC3(pid=10671,plane=0)

Active Sec:     1227539387      SecToBePurged:  3229    now:1227539758

----------------------------------------------------------------

MS Category:    0a              Subscriber Status:      00

ODB_General:    00000000        ODB_Specific:   00000000

Provision_bs:   07ffff07

Provision_ts:   (000F) Telephony  Emergency Call SMS-MT  SMS-MO

----------------------------------------------------------------

Service   Status     Service   Status     Service   Status

AllBar    ----       BAOC      -P--       BOIC      -P--

BOICexHC  ----       BAIC      -P--       BICRoam   -P--

CLIP      -P--       CLIR      ----       CallWait  -P--

COLP      -P--       COLR      ----       CallHold  -P--

ECT       -P--       MPTY      -P--

CFU       -P--

CFB       -P--

CFNRc     -P--

CFNRy     -P--                        0

----------------------------------------------------------------

No  RAND                                RES         Kc

AuthSetsNum:0   AuthSetsIndex:  0       CKSN:0x00       AucSuccessFlag:0

-----------------------------Camel Information-----------------------------

CSI     ServiceKey  SCF Address         Def-Handle  CamelCap-Handle

O-CSI   0           1986755920012       0           2

SMS-CSI 0           1986755920012       0

----------------------------Regional Subcription----------------------------

Zone :

Allow:

list imsi=

Usage Guidelines

Use the list imsi= command to display detailed information of a VLR subscriber by given its IMSI.

Syntax Description

list imsi=<imsi>

imsi

Specify a 15-digit IMSI.

Examples

The following is sample output from the list imsi= command.

VLR>list imsi=460029000001027

IMSI:460029000001027    MSISDN:86755901027        TMSI:FFFFFFFF

LAI: 6420000007         Cell ID:0009

Data Confirmed: Y       Loc Confirmed:  Y       Radio Confirmed:Y

IMSI Detached:  N       MNRF:           N       Roaming Rest:   N

LA Not Allow:   N       MS Status(MSC):0xC3(pid=10671,plane=0)

Active Sec:     1227539387      SecToBePurged:  3229    now:1227539758

----------------------------------------------------------------

MS Category:    0a              Subscriber Status:      00

ODB_General:    00000000        ODB_Specific:   00000000

Provision_bs:   07ffff07

Provision_ts:   (000F) Telephony  Emergency Call SMS-MT  SMS-MO

----------------------------------------------------------------

Service   Status     Service   Status     Service   Status

AllBar    ----       BAOC      -P--       BOIC      -P--

BOICexHC  ----       BAIC      -P--       BICRoam   -P--

CLIP      -P--       CLIR      ----       CallWait  -P--

COLP      -P--       COLR      ----       CallHold  -P--

ECT       -P--       MPTY      -P--

CFU       -P--

CFB       -P--

CFNRc     -P--

CFNRy     -P--                        0

----------------------------------------------------------------

No  RAND                                RES         Kc

AuthSetsNum:0   AuthSetsIndex:  0       CKSN:0x00       AucSuccessFlag:0

-----------------------------Camel Information-----------------------------

CSI     ServiceKey  SCF Address         Def-Handle  CamelCap-Handle

O-CSI   0           1986755920012       0           2

SMS-CSI 0           1986755920012       0

----------------------------Regional Subcription----------------------------

Zone :

Allow:

list para

Usage Guidelines

Use the list para command to display the information of VLR system parameters.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list para command.

VLR>list para

VLR R9 Parameter.OID Prefix=1.3.6.1.4.1.1373.2.3.3.2

OID      Name                Value

===========================================================

2.1.1    OptAuthReq          0

2.1.2    OptReUseTriplets    0

2.1.3    OptCipReq           0

2.1.4    OptCipthAlgo        3

2.1.5    OptTmsiAllocReq     0

2.1.6    OptOSBdefinition    0

2.1.7    OptEsSetUpAllow     0

2.1.8    OptCheckIMEI        0

2.1.9    OptVlrPurge         0

2.1.10   IdlePeriod2Purge    3600 (Sec)

2.1.11   CDRFlag             1

2.1.13   MSRN Start          86755920020

2.1.14   MSRN End            86755922019

list status

Usage Guidelines

Use the list status command to display the current status of two VLRs in the network.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list status command.

VLR>list status

Local VLR(016312ac) status: 4

Peer VLR(016212ac) status: 4

Command OK

del imsi=

Usage Guidelines

Use the del imsi= command to delete a specified subscriber's record from VLR database.

Syntax Description

del imsi=<imsi>

imsi

Specify a 15-digit IMSI.

get

Usage Guidelines

Use the get command to audit a VLR parameter value by given its object ID.

Syntax Description

get <oid>

oid

Specify a VLR object ID.

Examples

The following is sample output from the get command.

VLR>get 1.3.6.1.4.1.1373.2.3.3.2.2.1.1

Value = 00

set

Usage Guidelines

Use the set command to modify a VLR parameter value by given its object ID.

Syntax Description

set <oid>=<value>

oid | Specify a VLR object ID.
value | Specify a new value.

Examples

The following is sample output from the set command.

VLR>set 1.3.6.1.4.1.1373.2.3.3.2.2.1.1=0

Command OK.

reserve

Usage Guidelines

Use the reserve command to change the default subscriber attribute when insert a new subscriber data. This command is designed for IMDX applications.

Syntax Description

reserve [private | public]

private | Set default attribute to private user.
public | Set default attribute to public user.

Examples

The following is sample output from the reserve command.

VLR>reserve public

Command OK.

purge

Usage Guidelines

Use the purge command to perform purging procedures on a specified subscriber.

Syntax Description

purge <imsi>

imsi

Specify a 15-digit IMSI.

Examples

The following is sample output from the purge command.

VLR>purge 460029000001027

Command OK.

save

Usage Guidelines

Use the save command to save VLR system parameters residing in memory to hard disk.

Syntax Description

This command has no arguments or keywords.

reset

Usage Guidelines

Use the reset command to reload VLR parameters and initialize its status.

Syntax Description

This command has no arguments or keywords.

page 1

Usage Guidelines

The VLR debug page 1 displays the information of VLR system status.

Examples

The following is page 1 sample output.

VLR System OverView                                         Page 01

SysID           |  00

VLR Status      |  04(00-Init/01-Search/02-Sync/03-Single/04-Dual)

Peer VLR Status |  04(FF-Offline)

Free Buf(r/w)   |  01 00 00 00 9F 86 01 00

-------------------------------------------------------------------

[Resource]      |  [Capability][ In-use  ]

Port            |  00 04 00 00 00 00 00 00

Subscriber      |  20 4E 00 00 01 00 00 00 00 00 00 00

Roaming Number  |  31 00 00 00 00 00 00 00

TMSI            |  A0 86 01 00 00 00 00 00

-------------------------------------------------------------------

[performance]   |  [  Attemp ] [ Success ] [   Fail  ] [ Barring ]

Location Update |  02 00 00 00 00 00 00 00 02 00 00 00

MO Call         |  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

MT Call         |  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

PRN             |  00 00 00 00 00 00 00 00 00 00 00 00

MO SMS          |  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

MT SMS          |  00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

Register SS     |  00 00 00 00 00 00 00 00 00 00 00 00

PSI                00 00|00 00 00 00 00 00 00 00 00 00

-------------------------------------------------------------------

Remark: To Clear all the measurement, type 'clear'

page 7

Usage Guidelines

The VLR debug page 7 displays the information of OPPS setting.

Examples

The following is page 7 sample output.

VLR System OPR IMDM Parameters                      Page 07

OPR flag        |  01(00-Disabled/01-Enabled)

IMDM flag       |  01(00-Disabled/01-Enabled)

IMDM save flag  |  01(00-reserve private/01-reserve public)

IMSI prefix     |  34 36 30 30 33

3.29


XAPP

XAPP Debug Commands:

· log all
· log none
· log error
· log map
· log cap
· list parameter
· reset
· reload acn
· information page
· page 1

log all

Usage Guidelines

Use the log all command to turn on the log error, log map, and log cap commands simultaneously. It displays all XAPP component activities in the system.

This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

XAPP>log all

XAP all switch open

[0116]User ==> CAP CAP_ApplyCharging Operation-23(Req)  iid=66

00 20 8A 03 A1 00 00 74 00 23 01 42 01 01 00 0F 30 0D 80 06 A0 04 80 02

23 28 A2 03 80 01 01 10 00 00

[0233]User ==> CAP CAP_Continue Operation-1F(Req)       iid=67

00 11 8A 03 9D 00 00 E9 00 1F 01 43 01 01 00 00 10 00 00

[1313]User ==> CAP Xap_Open_Rsp ACN = 50 , Version = 1

00 10 8A 00 00 00 05 21 00 FF 03 02 01 01 02 32 01 00

[1313]User ==> CAP CAP_RequestReportBCSMEvent Operation-17(Req) iid=65

00 61 8A 03 A4 00 05 21 00 17 01 41 01 01 00 50 30 4E A0 4C 30 0B 80 01

09 81 01 01 A2 03 80 01 01 30 0B 80 01 09 81 01 00 A2 03 80 01 02 30 06

80 01 04 81 01 01 30 06 80 01 05 81 01 00 30 0B 80 01 0A 81 01 01 A2 03

80 01 01 30 0B 80 01 06 81 01 00 BE 03 81 01 28 30 06 80 01 07 81 01 01

10 00 00

...

log none

Usage Guidelines

Use the log none command to disable all XAPP debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error command to display errors occurring in the XAPP module. Use the log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log error command.

XAPP>log error

XAP error switch open

[3610]User ==> MAP Xap_UAbort   user reason=NetworkPathRelease

00 0C 8F 03 CF 00 0E 1A 00 FD 01 05 00 00

requesting_ssm: flag != INVOKED

[2324]User ==> MAP Xap_UAbort   user reason=NetworkPathRelease

00 0C 8F 01 D5 00 09 14 00 FD 01 05 00 00

...

log map

Usage Guidelines

Use the log map command to display MAP message transactions in the system. Use the log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log map command.

XAPP>log map

XAP monitor map switch open

[1606]User <== MAP Xap_Open_Ind ACN = 3 , Version = 3

00 45 8F 00 00 00 06 46 B0 FF 02 03 03 01 63 12 AC 00 00 00 00 04 06 00

04 00 01 00 04 0B 68 57 95 02 00 F2 00 01 00 A0 D8 01 63 12 AC 00 00 00

01 04 07 01 04 00 01 00 04 0B 68 57 95 02 00 F1 B0 B4 E3 BF B0 01 00

[1606]User ==> MAP Xap_Open_Rsp

00 0C 8F 03 33 00 06 46 00 FF 03 02 00 00

[1357]User ==> MAP MAP_PROVIDE_ROAMING_NUMBER Operation-04(Rsp) iid=64

00 1A 8F 00 21 00 05 4D 00 04 03 40 01 01 00 0B 30 09 04 07 91 68 57 95

12 81 F7 00

[1357]User ==> MAP Xap_Close    method=1

00 0C 8F 00 21 00 05 4D 00 FE 01 01 00 00

[1857]User <== MAP Xap_Open_Cnf ACN = 210 , Version = 2

00 10 8F 01 A9 00 07 41 00 FF 04 02 01 01 02 D2 02 00

...

log cap

Usage Guidelines

Use the log map command to display CAP message transactions in the system. Use the log none command to disable debugging output.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log cap command.

XAPP>log cap

XAP monitor cap switch open

[2295]User <== CAP Xap_Open_Ind ACN = 50 , Version = 1

00 45 8A 00 00 00 08 F7 1C FF 02 32 01 01 62 12 AC 00 00 00 01 00 92 00

04 00 01 01 04 0B 68 57 95 02 10 01 7C 4E 73 B6 88 01 63 12 AC 00 00 00

01 00 93 01 04 00 01 01 04 0B 68 57 95 02 10 02 81 07 91 68 01 01 00

[0403]User <== CAP Xap_Delimeter

00 09 8A 00 00 00 01 93 AC FA 02

[0403]User <== CAP MCAP_OC_ActivityTest Operation-37(Cnf)       iid=89

00 0C 8A 00 00 00 01 93 AC 37 04 59 01 00

[2295]User <== CAP CAP_InitialDP Operation-00(Ind)      iid=64

00 7F 8A 00 00 01 08 F7 0B 00 02 40 01 01 00 70 30 6E 80 01 00 82 08 84

10 68 57 95 30 87 F9 83 08 84 10 68 57 95 30 57 F7 85 01 0A 88 01 03 8A

02 17 00 9C 01 0C 9F 32 08 64 00 92 00 00 30 87 F9 BF 33 02 80 00 BF 34

17 02 01 00 81 07 91 68 57 95 02 00 F1 A3 09 80 07 64 20 00 00 08 00 09

BF 35 03 83 01 11 9F 36 02 01 6B 9F 37 07 91 68 57 95 02 00 F0 9F 39 08

02 80 11 62 02 04 40 00 00

...

list parameter

Usage Guidelines

Use the list parameter command to display XAPP configuration.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the list parameter command.

XAPP>list parameter

The XAP provider system parameter is:

MCC(Mobile Country Code): 460

MNC(Mobile Network Code): 02

CC(Country Code): 86

NDC(National Destination Code): 755

International prefix: 00

National prefix: 0

reset

Usage Guidelines

Use the reset command to reload XAPP parameters and initialize its status.

Syntax Description

This command has no arguments or keywords.

reload acn

Usage Guidelines

Use the reload acn command to reload Application Context Name (ACN) configuration from map_acn.conf and cap_acn.conf.

Syntax Description

This command has no arguments or keywords.

page 1

Usage Guidelines

The XAPP debug page 1 displays the information of XAPP system parameters.

Examples

The following is page 1 sample output.

Page 1          XAP system parameter

Version         09 02 00

MCC             46 0E

MNC             02 EE

CC              66 EE

NDC             75 5E EE

Inter prefix    00 EE

National prefix 0E EE

Register SSN    93 16 92 07 08 06 0A 09 20 0B 21 99 00 00 00 00

3.30


XUA

XUA Debug Commands:

· log all
· log none
· log error [on | off]
· log mtp3 [on | off]
· log maup [on | off]
· log m2ua [on | off]
· log sctp [on | off]
· log sg-<sg> [on | off]
· log lk-<link> [on | off]

log all

Usage Guidelines

Use the log all command to display all XUA component activities in the system. This command generates a great deal of output and can jam other activities when it is invoked.

Syntax Description

This command has no arguments or keywords.

Examples

The following is sample output from the log all command.

XUA>log all

Command OK!

Recv M2UA_LKSCTP_DATA_IND from SCTP, sg=263, data len=36

01 00 06 01 00 00 00 24 00 01 00 08 00 00 00 0D 03 00 00 13 83 01 80 00 D0 06 02 0A 97 00 01 03 00 01 21 00

Recv M2UA_MAUP_DATA from The Peer, sg=263, len=36

01 00 06 01 00 00 00 24 00 01 00 08 00 00 00 0D 03 00 00 13 83 01 80 00 D0 06 02 0A 97 00 01 03 00 01 21 00

Send MSG to MTP3, sg=263, lk=181, len=18

B5 00 0F 83 01 80 00 D0 06 02 0A 97 00 01 03 00 01 21

Recv MSG from MTP3, sg=264, lk=184, len=21

B8 00 12 83 03 40 00 00 06 01 00 0A 00 01 06 00 04 20 04 01 09

Send M2UA_MAUP_DATA to The Peer, sg=264, lk=184, sid=1, len=40

01 00 06 01 00 00 00 28 00 01 00 08 00 00 00 08 03 00 00 16 83 03 40 00 00 06 01 00 0A 00 01 06 00 04 20 04 01 09 00 00

Recv MSG from MTP3, sg=263, lk=176, len=18

B0 00 0F 83 02 40 00 70 04 01 02 7D 02 0A 97 00 01 00

...

log none

Usage Guidelines

Use the log none command to disable all XUA debugging output.

Syntax Description

This command has no arguments or keywords.

log error

Usage Guidelines

Use the log error on command to display XUA related messages only when errors occur. The off form of this command disables debugging output.

Syntax Description

log error [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log error on command.

XUA>log error on

...

log mtp3

Usage Guidelines

Use the log mtp3 on command to display message transacts between XUA and MTP3 modules. The off form of this command disables debugging output.

Syntax Description

log mtp3 [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log mtp3 on command.

XUA>log mtp3 on

...

log maup

Usage Guidelines

Use the log maup on command to display MTP2 User Adaptation messages. The off form of this command disables debugging output.

Syntax Description

log maup [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log maup on command.

XUA>log maup on

...

log m2ua

Usage Guidelines

Use the log m2ua on command to display information about M2UA activities in the system. The off form of this command disables debugging output.

Syntax Description

log m2ua [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log m2ua on command.

XUA>log m2ua on

...

log sctp

Usage Guidelines

Use the log sctp on command to display information about Stream Control Transmission Protocol (SCTP) activities in the system. The off form of this command disables debugging output.

Syntax Description

log sctp [on | off]

on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log sctp on command.

XUA>log sctp on

...

log sg-

Usage Guidelines

Use the log sg- on command to display message transactions through a specified signaling gateway. Use the off form of this command to disable debugging output.

Syntax Description

log sg-<sg> [on | off]

sg | Specify a signaling gateway by its index.
on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log sg- on command.

XUA>log sg-1 on

...

log lk-

Usage Guidelines

Use the log lk- on command to display message transactions on a specified link. Use the off form of this command to disable debugging output.

Syntax Description

log lk-<link> [on | off]

link | Specify a link by its index.
on | Enable debugging output.
off | Disable debugging output.

Examples

The following is sample output from the log lk- on command.

XUA>log lk-2 on

...

3.31


Annex

 Top Previous

Message Reference:

· AIF
· ISUP
· MAP

AIF Messages

BSSAP    CR (BSSMAP) Complete Layer 3 Information (DTAP) (MM) CM Service Request
BSSAP

Message Type: BSS Management [00]

Length: 31 [1F]
GSM A-I/F BSSMAP - Complete Layer 3 Information
Message Type Complete Layer 3 Information [57]
Cell Identifier - LAC/CI

Element ID: 5 [05]

Length: 8 [08]

0000 .... | Spare
.... xxxx | Cell identification discriminator: 0000: cell global identification(CGI) is used 0001: cell identified with LAC + CI 0010: cell identified with CI 0011: no cell identity 1000: target RNC identify with PLMN-ID, LAC, RNC-ID 1001: target RNC identify with RNC-ID 1010: target RNC identify with RNC-ID + LAC 1011: Serving Area of UE identify with PLMN-ID, LAC, SAC

Mobile Country Code (MCC): 552, Mobile Network Code (MNC): 01 [55 F2 10]

Cell LAC: 100 [00 64]

Cell CI: 100 [00 64]
Layer 3 Information

Element ID: 23 [17]

Length: 16 [10]

Layer 3 Information value: GSM A-I/F DTAP
Chosen Channel

Element ID: 33 [21]

xxxx .... | Channel mode: 0000: no channel mode indication 0001: data, 29.0 kbit/s 0010: data, 32.0 kbit/s 0011: data, 43.5 kbit/s 0100: data, 43.5 kbit/s downlink and 14.5 kbit/s uplink 0101: data, 29.0 kbit/s downlink and 14.5 kbit/s uplink 0110: data, 43.5 kbit/s downlink and 29.0 kbit/s uplink 0111: data, 14.5 kbit/s downlink and 43.5 kbit/s uplink 1000: signaling only 1001: speech 1010: data, 14.5 kbit/s downlink and 29.0 kbit/s uplink 1011: data, 12.0 kbit/s 1100: data, 6.0 kbit/s 1101: data, 3.6 kbit/s 1110: data, 14,5 kbit/s 1111: data, 29.0 kbit/s downlink and 43.5 kbit/s uplink
.... xxxx | Channel: 0000: none 0001: SDCCH 0100: 8 full rate TCH 1000: 1 full rate TCH 1001: 1 half rate TCH 1010: 2 full rate TCH 1011: 3 full rate TCH 1100: 4 full rate TCH 1101: 5 full rate TCH 1110: 6 full rate TCH 1111: 7 full rate TCH
GSM A-I/F DTAP - CM Service Request
Protocol Discriminator: Mobility Management messages [05]
xxxx .... | Skip Indicator
.... xxxx | Protocol discriminator: 0101: Mobility Management messages
Message Type CM Service Request [24]
Ciphering Key Sequence Number [71]
0... .... | Spare
.xxx .... | Ciphering Key Sequence Number: 000~110: Possible values for the ciphering key 111: No key is available
CM Service Type [71]

.... xxxx

Service Type:

0001: Mobile originating call establishment or packet mode connection establishment

0010: Emergency call establishment

0100: Short message transfer

1000: Supplementary service activation

1001: Voice group call establishment

1010: Voice broadcast call establishment

1011: Location services

Others: Reserved
Mobile Station Classmark 2

Length: 3 [03]

0... .... | Spare
.xx. .... | Revision Level: 00: Reserved for GSM phase 1 01: Used by GSM phase 2 mobile stations 10: Used by mobile stations supporting R99 or later versions of the protocol 11: Reserved for future use
...x .... | ES IND: 0: Controlled Early Classmark Sending option is not implemented in the MS 1: Controlled Early Classmark Sending option is implemented in the MS
.... x... | A5/1 algorithm supported: 0: encryption algorithm A5/1 available 1: encryption algorithm A5/1 not available
.... .xxx | RF Power Capability: 000: class 1 001: class 2 010: class 3 011: class 4 100: class 5
0... .... | Spare
.x.. .... | PS capability (pseudo-synchronization capability): 0: PS capability not present 1: PS capability present
..xx .... | SS Screening Indicator: 01: Capability of handling of ellipsis notation and phase 2 error handling
.... x... | SM capability (MT SMS pt to pt capability): 0: Mobile station does not support mobile terminated point to point SMS 1: Mobile station supports mobile terminated point to point SMS
.... .x.. | VBS notification reception: 0: no VBS capability or no notifications wanted 1: VBS capability and notifications wanted
.... ..x. | VGCS notification reception: 0: no VGCS capability or no notifications wanted 1: VGCS capability and notifications wanted
.... ...x | FC Frequency Capability: 1: The MS does not support the E-GSM or R-GSM 1: The MS does support the E-GSM or R-GSM
x... .... | CM3: 0: The MS does not support any options that are indicated in CM3 1: The MS supports options that are indicated in classmark 3 IE
.0.. .... | Spare
..x. .... | LCS value added) capability: 0: LCS VA location request notification capability not supported 1: LCS VA location request notification capability supported
...x .... | UCS2 treatment: 0: The ME has a preference for the default alphabet 1: The ME has no preference between the use of the default alphabet and UCS2
.... x... | SoLSA: 0: The ME does not support SoLSA 1: The ME supports SoLSA
.... .x.. | CM Service Prompt: 0: Network initiated MO CM connection request not supported 1: Network initiated MO CM connection request supported for at least one CM protocol.
.... ..x. | A5/3 algorithm supported: 0: encryption algorithm A5/3 not available 1: encryption algorithm A5/3 available
.... ...x | A5/2 algorithm supported: 0: encryption algorithm A5/2 not available 1: encryption algorithm A5/2 available
Mobile Identity - IMSI

Length: 8 [08]

xxxx .... | Identity Digit 1
.... x... | Odd/even indication: 0: Even number of identity digits and also when the TMSI/P-TMSI is used 1: Odd number of identity digits
.... .xxx | Mobile Identity Type: 000: No Identity 001: IMSI 010: IMEI 011: IMEISV 100: TMSI/P-TMSI

BCD Digits: 552010100011281 [59 25 10 10 00 10 21 18]

BSSAP    DT1 (DTAP) (MM) Authentication Request
BSSAP
Message Type: Direct Transfer [01]
Data Link Connection Identifier [00]
xx.. .... | Control Channel: 00: not further specified
..00 0... | Spare
.... .xxx | SAPI: 000: RR/MM/CC
Length: 19 [13]
GSM A-I/F DTAP - Authentication Request
Protocol Discriminator: Mobility Management messages [05]
xxxx .... | Skip Indicator
.... xxxx | Protocol discriminator: 0101: Mobility Management messages
Message Type Authentication Request [12]
Ciphering Key Sequence Number [00]
0000 0... | Spare
.... .xxx | Ciphering Key Sequence Number
RAND value [D7 B0 C0 55 18 93 90 12 44 53 D0 4C 0D 29 7E 3D]

BSSAP    DT1 (DTAP) (MM) Authentication Response
BSSAP
Message Type: Direct Transfer [01]
Data Link Connection Identifier [00]
xx.. .... | Control Channel: 00: not further specified
..00 0... | Spare
.... .xxx | SAPI: 000: RR/MM/CC
Length: 6 [06]
GSM A-I/F DTAP - Authentication Response
Protocol Discriminator: Mobility Management messages [05]
xxxx .... | Skip Indicator
.... xxxx | Protocol discriminator: 0101: Mobility Management messages
Message Type Authentication Response [14]
SRES value [67 D2 11 F6]

BSSAP    DT1 (BSSMAP) Cipher Mode Command
BSSAP

Message Type: BSS Management [00]

Length: 12 [0C]
GSM A-I/F BSSMAP - Cipher Mode Command
Message Type Cipher Mode Command [53]
Encryption Information

Element ID: 10 [0A]

Length: 9 [09]

0000 .... | Spare
.... xxx. | Algorithm identifier: 000: cipher with algorithm A5/1 001: cipher with algorithm A5/2 010: cipher with algorithm A5/3 011: cipher with algorithm A5/4 100: cipher with algorithm A5/5 101: cipher with algorithm A5/6 110: cipher with algorithm A5/7
.... ...x | Stream ciphering: 0: No ciphering 1: Start ciphering

Key [D1 59 82 21 39 3B 0B 03]

BSSAP    DT1 (BSSMAP) Cipher Mode Complete
BSSAP

Message Type: BSS Management [00]

Length: 5 [05]
GSM A-I/F BSSMAP - Cipher Mode Complete
Message Type Cipher Mode Complete [55]
Layer 3 Message Contents

Element ID: 32 [20]

Length: 0 [00]
Chosen Encryption Algorithm - GSM A5/1

Element ID: 44 [2C]

Algorithm Identifier: GSM A5/1 [02]

BSSAP    DT1 (DTAP) (CC) Setup (Caller)
BSSAP
Message Type: Direct Transfer [01]
Data Link Connection Identifier [00]
xx.. .... | Control Channel: 00: not further specified
..00 0... | Spare
.... .xxx | SAPI: 000: RR/MM/CC
Length: 18 [12]
GSM A-I/F DTAP - Setup
Protocol Discriminator: Call Control; call related SS messages [03]
x... .... | TI flag: 0: allocated by sender
.xxx .... | TIO
.... xxxx | Protocol discriminator: 0011: Call Control; call related SS messages
Message Type Setup [05]
Bearer Capability 1 - (Speech)

Element ID: 4 [04]

Length: 4 [04]

x... ....

Extension:

0: Extended

1: No Extension

.xx. ....

Radio channel requirement:

00: reserved value

01: the mobile station supports at least full rate speech version 1 but does not support half rate speech version 1.

10: The mobile station supports at least full rate speech version 1 and half rate speech version 1. The mobile station has a greater preference for half rate speech version 1 than for full rate speech version 1.

11: The mobile station supports at least full rate speech version 1 and half rate speech version 1. The mobile station has a greater preference for full rate speech version 1 than for half rate speech version 1.

...x ....

Coding standard:

0: GSM standardized coding

1: reserved value

.... x...

Transfer mode:

0: circuit

1: packet mode

.... .xxx

Information transfer capability:

000: speech

001: unrestr. digital

010: 3.1 kHz audio

011: facsimile group 3

100: speech, then unrestr. digital

101: other ITC

111: reserved: alternate speech/facsimile group 3

x... ....

Extension:

0: Extended

1: No Extension

.x.. ....

Coding:

0: octet used for transfer capability

1: octet used for other extension

..00 ....

Spare

.... xxxx

Speech version indication:

0000: GSM full rate speech version 1

0001: GSM half rate speech version 1

0010: GSM full rate speech version 2

x... ....

Extension:

0: Extended

1: No Extension

.x.. ....

Coding:

0: octet used for transfer capability

1: octet used for other extension

..00 ....

Spare

.... xxxx

0000: GSM full rate speech version 1

0001: GSM half rate speech version 1

0010: GSM full rate speech version 2

x... ....

Extension:

0: Extended

1: No Extension

.x.. ....

Coding:

0: octet used for transfer capability

1: octet used for other extension

..00 ....

Spare

.... xxxx

0000: GSM full rate speech version 1

0001: GSM half rate speech version 1

0010: GSM full rate speech version 2
Called Party BCD Number

Element ID: 94 [5E]

Length: 5 [05]

x... .... | Extension: 0: Extended 1: No Extension
.xxx .... | Type of number: 000: unknown 001: international 010: national 011: network specific 100: dedicate PAD access
.... xxxx | Numbering plan identification: 0000: unknown 0001: ISDN/telephony 0011: data (X.121) 0100: telex (F.69) 1000: national 1001: private

BCD Digits: 7760282 [77 06 82 F2]
Call Control Capabilities

Element ID: 21 [15]

Length: 1 [01]

0000 00.. | Spare
.... ..x. | PCP: 0: the mobile station does not support the Prolonged Clearing Procedure 1: the mobile station supports the Prolonged Clearing Procedure
.... ...x | DTMF: 0: the mobile station does not support DTMF 1: the mobile station supports DTMF

BSSAP    DT1 (DTAP) (CC) Setup (Called)
BSSAP
Message Type: Direct Transfer [01]
Data Link Connection Identifier [00]
xx.. .... | Control Channel: 00: not further specified
..00 0... | Spare
.... .xxx | SAPI: 000: RR/MM/CC
Length: 9 [09]
GSM A-I/F DTAP - Setup
Protocol Discriminator: Call Control; call related SS messages [03]
x... .... | TI flag: 0: allocated by sender
.xxx .... | TIO
.... xxxx | Protocol discriminator: 0011: Call Control; call related SS messages
Message Type Setup [05]
Calling Party BCD Number

Element ID: 92 [5C]

Length: 5 [05]

x... .... | Extension: 0: Extended 1: No Extension
.xxx .... | Type of number: 000: unknown 001: international 010: national 011: network specific 100: dedicate PAD access
.... xxxx | Numbering plan identification: 0000: unknown 0001: ISDN/telephony 0011: data (X.121) 0100: telex (F.69) 1000: national 1001: private
x... .... | Extension: 0: Extended 1: No Extension
.xx. .... | Presentation indicator: 00: presentation allowed 01: presentation restricted 10: number not available 11: unknown presentation indicator
...1 01.. | Spare
.... ..xx | Screening indicator: 00: user-provided, not screened 01: user-provided, verified and passed 10: user-provided, verified and failed 11: network provided

BCD Digits: 60281 [06 82 F1]

BSSAP    DT1 (BSSMAP) Assignment Request
BSSAP

Message Type: BSS Management [00]

Length: 11 [0B]
GSM A-I/F BSSMAP - Assignment Request
Message Type Assignment Request [01]
Channel Type - (Speech)

Element ID: 11 [0B]

Length: 5 [01]

0000 .... | Spare
.... xxxx | Speech/Data Indicator: 0001: speech 0010: data 0011: signalling Others: unknown
xxxx xxxx | Channel Rate and Type (Speech): 0000 1000: TCH/FR 0000 1001: TCH/HR 0000 1010: TCH/FR or HR, FR preferred, changes allowed 0000 1011: TCH/FR or HR, HR preferred, changes allowed 0000 1111: TCH/FR or HR, changes allowed 0001 1010: TCH/FR or HR, FR preferred, changes not allowed 0001 1011: TCH/FR or HR, HR preferred, changes not allowed 0001 1111: TCH/FR or HR, changes not allowed Others: unknown
x... .... | Extension: 0: no extension, indicates the last octet 1: extension, indicates that at least one additional octet is included
.xxx xxxx | Speech version identifier: 000 0001: speech full rate version 1 000 0101: speech half rate version 1 001 0001: speech full rate version 2 001 0101: speech half rate version 2 010 0001: speech full rate version 3 010 0101: speech half rate version 3
x... .... | Extension: 0: no extension, indicates the last octet 1: extension, indicates that at least one additional octet is included
.xxx xxxx | Speech version identifier: 000 0001: speech full rate version 1 000 0101: speech half rate version 1 001 0001: speech full rate version 2 001 0101: speech half rate version 2 010 0001: speech full rate version 3 010 0101: speech half rate version 3
x... .... | Extension: 0: no extension, indicates the last octet 1: extension, indicates that at least one additional octet is included
.xxx xxxx | Speech version identifier: 000 0001: speech full rate version 1 000 0101: speech half rate version 1 001 0001: speech full rate version 2 001 0101: speech half rate version 2 010 0001: speech full rate version 3 010 0101: speech half rate version 3
Circuit Identity Code

Element ID: 1 [01]

xxxx xxxx xxx | PCM Multiplexer
...x xxxx | Timeslot

BSSAP    DT1 (BSSMAP) Assignment Complete
BSSAP

Message Type: BSS Management [00]

Length: 07 [07]
GSM A-I/F BSSMAP - Assignment Complete
Message Type Assignment Complete [02]
Chosen Channel

Element ID: 33 [21]

xxxx .... | Channel mode: 0000: no channel mode indication 0001: data, 29.0 kbit/s 0010: data, 32.0 kbit/s 0011: data, 43.5 kbit/s 0100: data, 43.5 kbit/s downlink and 14.5 kbit/s uplink 0101: data, 29.0 kbit/s downlink and 14.5 kbit/s uplink 0110: data, 43.5 kbit/s downlink and 29.0 kbit/s uplink 0111: data, 14.5 kbit/s downlink and 43.5 kbit/s uplink 1000: signaling only 1001: speech 1010: data, 14.5 kbit/s downlink and 29.0 kbit/s uplink 1011: data, 12.0 kbit/s 1100: data, 6.0 kbit/s 1101: data, 3.6 kbit/s 1110: data, 14,5 kbit/s 1111: data, 29.0 kbit/s downlink and 43.5 kbit/s uplink
.... xxxx | Channel: 0000: none 0001: SDCCH 0100: 8 full rate TCH 1000: 1 full rate TCH 1001: 1 half rate TCH 1010: 2 full rate TCH 1011: 3 full rate TCH 1100: 4 full rate TCH 1101: 5 full rate TCH 1110: 6 full rate TCH 1111: 7 full rate TCH
Chosen Encryption Algorithm - GSM A5/1

Element ID: 44 [2C]

xxxx xxxx

Algorithm Identifier:

0000 0001: no encryption used

0000 0010: GSM user data encryption version 1 (A5/1)

0000 0011: GSM A5/2

0000 0100: GSM A5/3

0000 0101: GSM A5/4

0000 0110: GSM A5/5

0000 0111: GSM A5/6

0000 1000: GSM A5/7
Speech Version (Chosen) - (FR2)

Element ID: 44 [2C]

0... .... | Spare
.xxx xxxx | Speech version identifier: 000 0001: speech full rate version 1 000 0101: speech half rate version 1 001 0001: speech full rate version 2 001 0101: speech half rate version 2 010 0001: speech full rate version 3 010 0101: speech half rate version 3

BSSAP    UDT (BSSMAP) Paging
BSSAP

Message Type: BSS Management [00]

Length: 14 [0E]
GSM A-I/F BSSMAP - Paging
Message Type Paging [52]
IMSI

Element ID: 8 [08]

Length: 8 [08]

xxxx .... | Identity Digit 1
.... x... | Odd/even indication: 0: Even number of identity digits 1: Odd number of identity digits
.... .xxx | Mobile Identity Type: 000: no identity included 001: IMSI 010: IMEI 100: TMSI

BCD Digits: 552010100011282 [59 25 10 10 00 10 21 28]
Cell Identifier List

Element ID: 26 [1A]

Length: 1 [01]

0000 .... | Spare
.... xxxx | Cell identification discriminator: 0000: cell global identification(CGI) is used 0001: cell identified with LAC + CI 0010: cell identified with CI 0011: no cell identity 0100: LAI identifies all cells within LA 0101: LAC identifies all cells within LA 0110: all cells on the BSS are identified 1000: target RNC identify with PLMN-ID, LAC, RNC-ID 1001: target RNC identify with RNC-ID 1010: target RNC identify with RNC-ID + LAC

BSSAP    CR (BSSMAP) Complete Layer 3 Information (DTAP) (RR) Paging Response
BSSAP

Message Type: BSS Management [00]

Length: 31 [1F]
GSM A-I/F BSSMAP - Complete Layer 3 Information
Message Type Complete Layer 3 Information [57]
Cell Identifier - LAC/CI

Element ID: 5 [05]

Length: 8 [08]

0000 .... | Spare
.... xxxx | Cell identification discriminator: 0000: cell global identification(CGI) is used 0001: cell identified with LAC + CI 0010: cell identified with CI 0011: no cell identity 1000: target RNC identify with PLMN-ID, LAC, RNC-ID 1001: target RNC identify with RNC-ID 1010: target RNC identify with RNC-ID + LAC 1011: Serving Area of UE identify with PLMN-ID, LAC, SAC

Mobile Country Code (MCC): 552, Mobile Network Code (MNC): 01 [55 F2 10]

Cell LAC: 100 [00 64]

Cell CI: 100 [00 64]
Layer 3 Information

Element ID: 23 [17]

Length: 16 [10]

Layer 3 Information value: A-I/F DTAP
Chosen Channel

Element ID: 33 [21]

xxxx .... | Channel mode: 0000: no channel mode indication 0001: data, 29.0 kbit/s 0010: data, 32.0 kbit/s 0011: data, 43.5 kbit/s 0100: data, 43.5 kbit/s downlink and 14.5 kbit/s uplink 0101: data, 29.0 kbit/s downlink and 14.5 kbit/s uplink 0110: data, 43.5 kbit/s downlink and 29.0 kbit/s uplink 0111: data, 14.5 kbit/s downlink and 43.5 kbit/s uplink 1000: signaling only 1001: speech 1010: data, 14.5 kbit/s downlink and 29.0 kbit/s uplink 1011: data, 12.0 kbit/s 1100: data, 6.0 kbit/s 1101: data, 3.6 kbit/s 1110: data, 14,5 kbit/s 1111: data, 29.0 kbit/s downlink and 43.5 kbit/s uplink
.... xxxx | Channel: 0000: none 0001: SDCCH 0100: 8 full rate TCH 1000: 1 full rate TCH 1001: 1 half rate TCH 1010: 2 full rate TCH 1011: 3 full rate TCH 1100: 4 full rate TCH 1101: 5 full rate TCH 1110: 6 full rate TCH 1111: 7 full rate TCH
A-I/F DTAP - Paging Response
Protocol Discriminator: Radio Resources Management messages
0000 .... | Spare
.... xxxx | Protocol discriminator: 0110: Radio Resources Management messages
Message Type Paging Response [27]
Ciphering Key Sequence Number
0000 0... | Spare
.... .xxx | Ciphering Key Sequence Number: 000~110: Possible values for the ciphering key 111: No key is available
Mobile Station Classmark 2

Length: 3 [03]

0... .... | Spare
.xx. .... | Revision Level: 00: Reserved for GSM phase 1 01: Used by GSM phase 2 mobile stations 10: Used by mobile stations supporting R99 or later versions of the protocol 11: Reserved for future use
...x .... | ES IND: 0: Controlled Early Classmark Sending option is not implemented in the MS 1: Controlled Early Classmark Sending option is implemented in the MS
.... x... | A5/1 algorithm supported: 0: encryption algorithm A5/1 available 1: encryption algorithm A5/1 not available
.... .xxx | RF Power Capability: 000: class 1 001: class 2 010: class 3 011: class 4 100: class 5
0... .... | Spare
.x.. .... | PS capability (pseudo-synchronization capability): 0: PS capability not present 1: PS capability present
..xx .... | SS Screening Indicator: 01: Capability of handling of ellipsis notation and phase 2 error handling
.... x... | SM capability (MT SMS pt to pt capability): 0: Mobile station does not support mobile terminated point to point SMS 1: Mobile station supports mobile terminated point to point SMS
.... .x.. | VBS notification reception: 0: no VBS capability or no notifications wanted 1: VBS capability and notifications wanted
.... ..x. | VGCS notification reception: 0: no VGCS capability or no notifications wanted 1: VGCS capability and notifications wanted
.... ...x | FC Frequency Capability: 1: The MS does not support the E-GSM or R-GSM 1: The MS does support the E-GSM or R-GSM
x... .... | CM3: 0: The MS does not support any options that are indicated in CM3 1: The MS supports options that are indicated in classmark 3 IE
.0.. .... | Spare
..x. .... | LCS value added) capability: 0: LCS VA location request notification capability not supported 1: LCS VA location request notification capability supported
...x .... | UCS2 treatment: 0: The ME has a preference for the default alphabet 1: The ME has no preference between the use of the default alphabet and UCS2
.... x... | SoLSA: 0: The ME does not support SoLSA 1: The ME supports SoLSA
.... .x.. | CM Service Prompt: 0: Network initiated MO CM connection request not supported 1: Network initiated MO CM connection request supported for at least one CM protocol.
.... ..x. | A5/3 algorithm supported: 0: encryption algorithm A5/3 not available 1: encryption algorithm A5/3 available
.... ...x | A5/2 algorithm supported: 0: encryption algorithm A5/2 not available 1: encryption algorithm A5/2 available
Mobile Identity - IMSI

Length: 8 [08]

xxxx .... | Identity Digit 1
.... x... | Odd/even indication: 0: Even number of identity digits and also when the TMSI/P-TMSI is used 1: Odd number of identity digits
.... .xxx | Mobile Identity Type: 000: No Identity 001: IMSI 010: IMEI 011: IMEISV 100: TMSI/P-TMSI

BCD Digits: 552010100011282 [59 25 10 10 00 10 21 28]

BSSAP    DT1 (DTAP) (CC) Call Confirmed
BSSAP
Message Type: Direct Transfer [01]
Data Link Connection Identifier [00]
xx.. .... | Control Channel: 00: not further specified
..00 0... | Spare
.... .xxx | SAPI: 000: RR/MM/CC
Length: 11 [0B]
GSM A-I/F DTAP - Call Confirmed
Protocol Discriminator: Call Control; call related SS messages [03]
x... .... | TI flag: 1: allocated by receiver
.xxx .... | TIO
.... xxxx | Protocol discriminator: 0011: Call Control; call related SS messages
Message Type Call Confirmed [48]
Bearer Capability 1 - (Speech)

Element ID: 4 [04]

Length: 4 [04]

x... ....

Extension:

0: Extended

1: No Extension

.xx. ....

Radio channel requirement:

00: reserved value

01: the mobile station supports at least full rate speech version 1 but does not support half rate speech version 1.

10: The mobile station supports at least full rate speech version 1 and half rate speech version 1. The mobile station has a greater preference for half rate speech version 1 than for full rate speech version 1.

11: The mobile station supports at least full rate speech version 1 and half rate speech version 1. The mobile station has a greater preference for full rate speech version 1 than for half rate speech version 1.

...x ....

Coding standard:

0: GSM standardized coding

1: reserved value

.... x...

Transfer mode:

0: circuit

1: packet mode

.... .xxx

Information transfer capability:

000: speech

001: unrestr. digital

010: 3.1 kHz audio

011: facsimile group 3

100: speech, then unrestr. digital

101: other ITC

111: reserved: alternate speech/facsimile group 3

x... ....

Extension:

0: Extended

1: No Extension

.x.. ....

Coding:

0: octet used for transfer capability

1: octet used for other extension

..00 ....

Spare

.... xxxx

Speech version indication:

0000: GSM full rate speech version 1

0001: GSM half rate speech version 1

0010: GSM full rate speech version 2

x... ....

Extension:

0: Extended

1: No Extension

.x.. ....

Coding:

0: octet used for transfer capability

1: octet used for other extension

..00 ....

Spare

.... xxxx

0000: GSM full rate speech version 1

0001: GSM half rate speech version 1

0010: GSM full rate speech version 2

x... ....

Extension:

0: Extended

1: No Extension

.x.. ....

Coding:

0: octet used for transfer capability

1: octet used for other extension

..00 ....

Spare

.... xxxx

0000: GSM full rate speech version 1

0001: GSM half rate speech version 1

0010: GSM full rate speech version 2
Call Control Capabilities

Element ID: 21 [15]

Length: 5 [01]

0000 00.. | Spare
.... ..x. | PCP: 0: the mobile station does not support the Prolonged Clearing Procedure 1: the mobile station supports the Prolonged Clearing Procedure
.... ...x | DTMF: 0: the mobile station does not support DTMF 1: the mobile station supports DTMF

BSSAP    DT1 (DTAP) (CC) Alerting
BSSAP
Message Type: Direct Transfer [01]
Data Link Connection Identifier [00]
xx.. .... | Control Channel: 00: not further specified
..00 0... | Spare
.... .xxx | SAPI: 000: RR/MM/CC
Length: 6 [06]
GSM A-I/F DTAP - Alerting
Protocol Discriminator: Call Control; call related SS messages [03]
x... .... | TI flag: 1: allocated by receiver
.xxx .... | TIO
.... xxxx | Protocol discriminator: 0011: Call Control; call related SS messages
Message Type Alerting [01]
Progress Indicator - 1

Element ID: 30 [1E]

Length: 2 [02]

x... .... | Extension: 0: no extension, indicates the last octet 1: extension, indicates that at least one additional octet is included
.xx. .... | Coding standard: 00: CCITT Q.931 01: other international 10: national 11: GSM
...0 .... | Spare
.... xxxx | Location: 0000: user 0001: private network, local user 0010: public network, local user 0011: transit network 0100: public network, remote user 0101: private network, remote user 0111: international network 1010: network beyond interworking point
x... .... | Extension: 0: no extension, indicates the last octet 1: extension, indicates that at least one additional octet is included
.xxx xxxx | Progress Description: 000 0001: non end-to-end PLMN/ISDN call 000 0010: destination address in non-PLMN/ISDN 000 0011: origination address in non-PLMN/ISDN 000 0100: call has returned to the PLMN/ISDN 000 1000: in-band info or pattern now available 010 0000: call is end-to-end PLMN/ISDN 100 0000: progress: queueing

BSSAP    DT1 (DTAP) (CC) Connect
BSSAP
Message Type: Direct Transfer [01]
Data Link Connection Identifier [00]
xx.. .... | Control Channel: 00: not further specified
..00 0... | Spare
.... .xxx | SAPI: 000: RR/MM/CC
Length: 9 [09]
GSM A-I/F DTAP - Connect
Protocol Discriminator: Call Control; call related SS messages [03]
x... .... | TI flag: 1: allocated by receiver
.xxx .... | TIO
.... xxxx | Protocol discriminator: 0011: Call Control; call related SS messages
Message Type Connect [07]
Connected Number

Element ID: 76 [4C]

Length: 5 [05]

x... .... | Extension: 0: Extended 1: No Extension
.xxx .... | Type of number: 000: unknown 001: international 010: national 011: network specific 100: dedicate PAD access
.... xxxx | Numbering plan identification: 0000: unknown 0001: ISDN/telephony 0011: data (X.121) 0100: telex (F.69) 1000: national 1001: private
x... .... | Extension: 0: Extended 1: No Extension
.xx. .... | Presentation indicator: 00: presentation allowed 01: presentation restricted 10: number not available 11: unknown presentation indicator
...1 01.. | Spare
.... ..xx | Screening indicator: 00: user-provided, not screened 01: user-provided, verified and passed 10: user-provided, verified and failed 11: network provided

BCD Digits: 60281 [06 82 F2]

BSSAP    DT1 (DTAP) (CC) Connect Acknowledge
BSSAP
Message Type: Direct Transfer [01]
Data Link Connection Identifier [00]
xx.. .... | Control Channel: 00: not further specified
..00 0... | Spare
.... .xxx | SAPI: 000: RR/MM/CC
Length: 2 [02]
GSM A-I/F DTAP - Connect Acknowledge
Protocol Discriminator: Call Control; call related SS messages [03]
x... .... | TI flag: 0: allocated by sender
.xxx .... | TIO
.... xxxx | Protocol discriminator: 0011: Call Control; call related SS messages
Message Type Connect Acknowledge [4F]

BSSAP    DT1 (DTAP) (CC) Disconnect
BSSAP
Message Type: Direct Transfer [01]
Data Link Connection Identifier [00]
xx.. .... | Control Channel: 00: not further specified
..00 0... | Spare
.... .xxx | SAPI: 000: RR/MM/CC
Length: 5 [05]
GSM A-I/F DTAP - Disconnect
Protocol Discriminator: Call Control; call related SS messages [03]
x... .... | TI flag: 1: allocated by receiver
.xxx .... | TIO
.... xxxx | Protocol discriminator: 0011: Call Control; call related SS messages
Message Type Disconnect [25]
Cause

Length: 2 [02]

x... ....

Extension:

0: Extended

1: No Extension

.xx. ....

Coding standard:

00: CCITT Q.931

01: other international

10: national

11: GSM

...0 ....

Spare

.... xxxx

Location:

0000: user

0001: private network, local user

0010: public network, local user

0011: transit network

0100: public network, remote user

0101: private network, remote user

0111: international network

1010: network beyond interworking point

x... ....

Extension:

0: Extended

1: No Extension

.xxx xxxx

Cause class + cause value:

000 ....: normal event

000 0001: unassigned number

000 0011: no route to destination

000 0110: channel unacceptable

000 1000: operator determined barring (only in the phase 2)

001 ....: normal event

001 0000: normal clearing

001 0001: user busy

001 0010: no user responding

001 0011: user alerting, no answer

001 0101: call rejected

001 0110: number changed

001 1010: non selected user clearing

001 1011: destination out of order

001 1100: invalid number format

001 1101: facility rejected

001 1110: response to STATUS ENQUIRY

001 1111: unspecified

010 ....: resource unavailable

010 0010: no circuit or channel

010 0110: network out of order

010 1001: temporary failure

010 1010: switching equipment congestion

010 1011: access information discarded

010 1100: no requested circuit or channel

010 1111: unspecified

011 ....: service or option not available

011 0001: quality of service unavailable

011 0010: requested facility not subscribed

011 0111: incoming calls barred within CUG (in the phase 2)

011 1001: bearer capability unauthorized

011 1010: bearer capability unavailable

011 1111: unspecified

100 ....: service or option not implemented

100 0001: bearer service not implemented

100 0101: requested facility not implemented

100 0110: only restricted digital info bearer

100 1111: unspecified

101 ....: invalid message

101 0001: invalid transaction identifier value

101 0111: user not member of CUG (only in the phase 2)

101 1000: incompatible destination

101 1011: invalid transit network selection

101 1111: unspecified

110 ....: protocol error

110 0000: mandatory info element error

110 0001: msg non-existing or not implemented

110 0010: msg incompatible with control state

110 0011: IE non-existent or not implemented

110 0100: invalid info element contents

110 0101: msg incompatible with call state

110 0110: recovery on timer expiry

110 1111: unspecified

111 ....: interworking

111 1111: unspecified

BSSAP    DT1 (DTAP) (CC) Release
BSSAP
Message Type: Direct Transfer [01]
Data Link Connection Identifier [00]
xx.. .... | Control Channel: 00: not further specified
..00 0... | Spare
.... .xxx | SAPI: 000: RR/MM/CC
Length: 2 [02]
GSM A-I/F DTAP - Connect Acknowledge
Protocol Discriminator: Call Control; call related SS messages [03]
x... .... | TI flag: 0: allocated by sender
.xxx .... | TIO
.... xxxx | Protocol discriminator: 0011: Call Control; call related SS messages
Message Type Release [2D]

BSSAP    DT1 (DTAP) (CC) Release Complete
BSSAP
Message Type: Direct Transfer [01]
Data Link Connection Identifier [00]
xx.. .... | Control Channel: 00: not further specified
..00 0... | Spare
.... .xxx | SAPI: 000: RR/MM/CC
Length: 2 [02]
GSM A-I/F DTAP - Connect Acknowledge
Protocol Discriminator: Call Control; call related SS messages [03]
x... .... | TI flag: 1: allocated by receiver
.xxx .... | TIO
.... xxxx | Protocol discriminator: 0011: Call Control; call related SS messages
Message Type Release Complete [6A]

BSSAP    DT1 (BSSMAP) Clear Command
BSSAP

Message Type: BSS Management [00]

Length: 4 [04]
GSM A-I/F BSSMAP - Clear Command
Message Type Clear Command [20]
Cause

Element ID: 4 [04]

Length: 1 [01]

x... ....

Extension:

0: no extension, indicates the last octet

1: extension, indicates that at least one additional octet is included

.xxx xxxx

Cause value:

000 0000: radio interface msg failure

000 0001: radio interface failure

000 0010: uplink quality

000 0011: uplink strength

000 0100: downlink quality

000 0101: downlink strength

000 0110: distance

000 0111: O&M intervention

000 1000: response to MSC invocation

000 1001: call control

000 1010: radio itf. failure, back to old ch

000 1011: handover successful

000 1100: better cell

000 1101: directed retry (in the phase 2 only)

000 1110: joined group call channel (in the phase 2 only)

000 1111: traffic (in the phase 2 only)

010 0000: equipment failure

010 0001: no radio resource available

010 0010: terrestrial resource unavailable

010 0011: CCCH overload

010 0100: processor overload

010 0101: BSS not equipped

010 0110: MS not equipped

010 0111: invalid cell (in the phase 2 only)

010 1001: preemption (in the phase 2 only)

011 0000: transcoding/rate adaption unavailable

011 0001: circuit pool mismatch (in the phase 2 only)

011 0010: switch circuit pool (in the phase 2 only)

011 0011: requested speech version unavailable (in the phase 2 only)

100 0000: ciphering not supported

101 0000: terrestrial circuit already allocated

101 0001: invalid message contents (in the phase 2 only)

101 0010: information element or field missing (in the phase 2 only)

101 0011: incorrect value (in the phase 2 only)

101 0100: unknown message type (in the phase 2 only)

101 0101: unknown information element (in the phase 2 only)

110 0000: protocol error between BSC and MSC

110 0001: VGCS/VBS call non existent

BSSAP    DT1 (BSSMAP) Clear Complete
BSSAP

Message Type: BSS Management [00]

Length: 1 [01]
GSM A-I/F BSSMAP - Clear Complete

Message Type Clear Complete [21]

ISUP Messages

ISUP(ITU) IAM
ISDN User Part
CIC: 67 [43 00]
Message type: Initial address [01]
Nature of Connection Indicators [00]
000. .... | Spare
...x .... | Echo Control Device Indicator: 0: outgoing echo control device not included 1: outgoing echo control device included
.... xx.. | Continuity Check Indicator: 00: cont check not required 01: cont check required on this circuit 10: cont check required in a previous circuit 11: unknown
.... ..xx | Satellite Indicator: 00: no satellite circuit in the connection 01: one satellite circuit in the connection 10: two satellite circuits in the connection 11: unknown
Forward Call Indicators [21 01]
xx.. .... | ISDN user part preference indicator: 00: ISUP preferred all the way 01: ISUP not required all the way 10: ISUP required all the way 11: unknown
..x. .... | ISDN user part indicator: 0: ISUP not used all the way 1: ISUP used all the way
...x .... | End-to-end information indicator: 0: no end-to-end info available 1: end-to-end info available
.... x... | Interworking indicator: 0: no interworking (all SS7) 1: interworking encountered
.... .xx. | End-to-end method indicator: 00: no end-to-end method available 01: pass along method available 10: SCCP method available 11: pass along and SCCP methods available
.... ...x | National/international call indicator: 0: national call 1: international call
xx.. .... | Outgoing call barring indicator: 00: no indication available 01: no barring active 10: barring active 11: unknown outgoing call barring ind.
..x. .... | Query on Release attempt indicator: 0: no QoR routing attempt in progress 1: QoR routing attempt in progress
...x .... | Ported number translation indicator: 0: number not translated 1: number translated
.... 0... | Spare
.... .xx. | SCCP method indicator: 00: no SCCP method indication 01: connection less method available 10: connection oriented method available 11: connection less and -oriented methods
.... ...x | ISDN access indicator: 0: originating access non-ISDN 1: originating access ISDN
Calling Party's category [0A]

xxxx xxxx

0000 0000: unknown

0000 0001: French

0000 0010: English

0000 0011: German

0000 0100: Russian

0000 0101: Spanish

0000 0110~1000: mutually selected

0000 1001: reserved for Q.104

0000 1010: ordinary calling subscriber

0000 1011: calling subscriber with priority

0000 1100: voice band data call

0000 1101: test call

0000 1111: payphone

1110 0000~1111 1110: national
Transmission medium requirement [03]

xxxx xxxx

0000 0000: speech

0000 0010: 64 kbit/s unrestricted

0000 0011: 3.1 kHz audio

0000 0100: alternate speech and 64 kbit/s unrestricted

0000 0101: alternate 64 kbit/s unrestricted and speech

0000 0110: 64 kbit/s preferred (in ITU-T -97, Finnish and UK ISUP)

0000 0111: 2x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0000 1000: 384 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0000 1001: 1536 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0000 1010: 1920 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0001 0000: 3x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0001 0001: 4x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0001 0010: 5x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0001 0100: 7x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0001 0101: 8x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0001 0110: 9x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0001 0111: 10x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0001 1000: 11x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0001 1001: 12x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0001 1010: 13x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0001 1011: 14x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0001 1100: 15x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0001 1101: 16x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0001 1110: 17x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0001 1111: 18x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0010 0000: 19x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0010 0001: 20x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0010 0010: 21x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0010 0011: 22x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0010 0100: 23x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0010 0110: 25x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0010 0111: 26x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0010 1000: 27x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0010 1001: 28x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)

0010 1010: 29x64 kbit/s unrestricted (in ITU-T -97 and UK ISUP)
Pointer to Parameter: 6 [06]
Called Party Number

Parameter length: 7 [07]

x... .... | Odd/even indicator: 0: even number of address signals 1: odd number of address signals
.xxx xxxx | Nature of address indicator: 000 0001: subscriber number 000 0010: national nature indicator (in CCITT-88) or unknown nature of address (in ITU-T -97 and UK ISUP) 000 0011: national significant number 000 0100: international number 000 0101: network specific number, (in ITU-T -97 and UK ISUP)
x... .... | INN indicator: 0: routing to internal network number allowed 1: routing to internal network number not allowed
.xxx .... | Numbering plan indicator: 000: unknown 001: ISDN/telephony (E.163, 164) 011: data (X.121) 100: telex (F.69) 101: national plan 110: national plan
.... 0000 | Spare

E.164 Called party number digits: 6805878746 [86 50 78 78 64]
Pointer to start of optional part: 13 [0D]
Calling Party Number

Optional Parameter: 10 (Calling party number)

Parameter length: 7 [07]

x... .... | Odd/even indicator: 0: even number of address signals 1: odd number of address signals
.xxx xxxx | Nature of address indicator: 000 0001: subscriber number 000 0010: national nature indicator (in CCITT-88) or unknown nature of address (in ITU-T -97 and UK ISUP) 000 0011: national significant number 000 0100: international number 000 0101: network specific number, (in ITU-T -97 and UK ISUP)
x... .... | INN indicator: 0: routing to internal network number allowed 1: routing to internal network number not allowed
.xxx .... | Numbering plan indicator: 000: unknown 001: ISDN/telephony (E.163, 164) 011: data (X.121) 100: telex (F.69) 101: national plan 110: national plan
.... xx.. | Address presentation restricted indicator: 00: address presentation allowed 01: address presentation restricted 10: address not available 11: unknown presentation indicator
.... ..xx | Screening indicator: 00: user provided, not verified 01: user provided, verified and passed 10: user provided, verification failed 11: network provided

E.164 Calling party number digits: 6807760282 [86 70 67 20 28]
End of optional parameters [00]

ISUP(ITU) ACM
ISDN User Part
CIC: 67 [43 00]
Message type: Address complete [06]
Backward Call Indicators: [16 14]
xx.. .... | End-to-end method indicator: 00: no end-to-end method available 01: pass along method available 10: SCCP method available 11: pass along and SCCP methods available
..xx .... | Called party's category indicator: 00: no category indication 01: ordinary subscriber 10: payphone 11: unknown
.... xx.. | Called party's status indicator: 00: no status indication 01: subscriber free 10: connect when free (not used in UK ISUP, treated as 0h) 11: unknown
.... ..xx | Charge indicator: 00: no charge indication 01: no charge 10: charge 11: unknown
xx.. .... | SCCP method indicator: 00: no SCCP method indication 01: connection less method available 10: connection oriented method available 11: connection less and -oriented methods
..x. .... | Echo Control Device Indicator: 0: echo control device not included 1: echo control device included
...x .... | ISDN access indicator: 0: terminating access non-ISDN 1: terminating access ISDN
.... x... | Holding indicator: 0: holding not requested 1: holding requested
.... .x.. | ISDN user part indicator: 0: ISUP not used all the way 1: ISUP used all the way
.... ..x. | End-to-end information indicator: 0: no end-to-end information available 1: end-to-end information available
.... ...x | Interworking indicator: 0: no interworking encountered 1: interworking encountered
No optional parameter present [00]

ISUP(ITU) ANM
ISDN User Part

CIC: 67 [43 00]

Message type: Answer [09]

No optional parameter present [00]

ISUP(ITU) CPG
ISDN User Part

CIC: 67 [43 00]

Message type: Call progress [2C]

Event information:

x... .... | Event presentation restricted indicator: 0: no indication 1: restricted
.xxx xxxx | Event indicator: 000 0001: ALERTING 000 0010: PROGRESS 000 0011: in-band info or pattern now available 000 0100: call forwarded on busy 000 0101: call forwarded on no reply 000 0110: call forwarded unconditional

No optional parameter present [00]

ISUP(ITU) REL
ISDN User Part
CIC: 67 [43 00]
Message type: Release [0C]
Pointer to Parameter: 2 [02]
Cause indicators: [85 90]

Parameter length: 2 [02]

x... ....

Extension indicator:

0: Extended

1: No Extension

.xx. ....

Coding standard:

00: CCITT coding as follows

01: other international standard

10: national standard

11: standard of specified location

...0 ....

Spare

.... xxxx

Cause location:

0000: user

0001: private network, local user

0010: public network, local user

0011: transit network

0100: public network, remote user

0101: private network, remote user

0111: international network

1010: network beyond iw-point

x... ....

Extension indicator:

0: Extended

1: No Extension

.xxx xxxx

Cause indicator:

000 0001: unallocated (unassigned) number

000 0010: no route to specified transit network

000 0011: no route to destination

000 0100: send special information tone

000 0101: misdialled trunk prefix

001 0000: normal call clearing

001 0001: user busy

001 0010: no user responding

001 0011: no answer from user (user alerted)

001 0101: call rejected

001 0110: number changed

001 1011: destination out of order

001 1100: address incomplete

001 1101: facility rejected

001 1111: normal - unspecified

010 0010: no circuit available

010 0110: network out of order

010 1001: temporary failure

010 1010: switching equipment congestion

010 1100: requested channel not available

010 1111: resource unavailable - unspecified

011 0010: requested facility not subscribed

011 0111: incoming calls barred within CUG

011 1001: bearer capability not authorized

011 1010: bearer capability not presently available

011 1111: service/option not available - unspecified

100 0001: bearer capability not implemented

100 0101: requested facility not implemented

100 0110: only restricted digital info bearer cap.

100 1111: service/option not implem. - unspecified

101 0111: called user not member of CUG

101 1000: incompatible destination

101 1011: invalid transit network selection

101 1111: invalid message - unspecified

110 0001: message type non-existent or not implem.

110 0011: parm non-existent/not implem. - discarded

110 0101: parm non-existent/not implem. - passed on

110 1111: protocol error - unspecified

111 1111: interworking unspecified
No optional parameter present [00]

ISUP(ITU) RLC
ISDN User Part

CIC: 67 [43 00]

Message type: Release complete [10]

No optional parameter present [00]

MAP Messages

GSM MAP  Invoke Register SS
BSSAP
Message Type: Direct Transfer [01]
Data Link Connection Identifier [00]
xx.. .... | Control Channel: 00: not further specified
..00 0... | Spare
.... .xxx | SAPI: 000: RR/MM/CC
Length: 30 [1E]
GSM A-I/F DTAP - Register
Protocol Discriminator: Call Control; call related SS messages [1B]
x... .... | TI flag: 0: allocated by sender 1: allocated by receiver
.xxx .... | TIO
.... xxxx | Protocol discriminator: 1011: Non call related SS messages
Message Type Register [3B]
Facility

Element ID: 28 [1C]

Length: 23 [17]
SS Version Indicator

Element ID: 127 [7F]

Length: 1 [01]

SS Version 0: Phase 2 service, ellipsis notation, and phase 2 error handling is supported
GSM Mobile Application
Component: invoke [A1]
Invoke
Invoke ID: 1 [01]
Operation Code

0A: Register SS

0B: Erase SS

0C: Activate SS

0D: Deactivate SS

0E: Interrogate SS

10: Notify SS

11: Register Password

12: Get Password

13: Process Unstructured SS Data

26: Forward Check SS Indication

3B: Process Unstructured SS Request

3C: Unstructured SS Request

3D: Unstructured SS Notify

4D: Erase CC Entry

77: Access Register CC Entry

78: Forward CUG Info

79: Split MPTY

7A: Retrieve MPTY

7B: Hold MPTY

7C: Build MPTY

7D: Forward Charge Advice

7E: Explicit CT
SS Code

00: All SS

10: All Line Identification SS

11: CLIP - Calling Line Identification Presentation

12: CLIR - Calling Line Identification Restriction

13: COLP - Connected Line Identification Presentation

14: COLR - Connected Line Identification Restriction

15: MCI - Malicious Call Identification

18: All Name Identification SS

19: CNAP - Calling Name Presentation

20: All Forwarding SS

21: CFU - Call Forwarding Unconditional

28: All Conditional Forwarding SS

29: CFB - Call Forwarding Busy

2A: CFNRy - Call Forwarding on No Reply

2B: CFNRc - Call Forwarding on Mobile Subscriber Not Reachable

24: CD - Call Deflection

30: All Call Offering SS Includes Also All Forwarding SS

31: ECT - Explicit Call Transfer

32: MAH - Mobile Access Hunting

40: All Call Completion SS

41: Call Waiting

42: Call Hold

43: Completion of Call to Busy Subscribers, Originating Side

44: Completion of Call to Busy Subscribers, Destination Side

45: Multi Call

50: All Multi-Party SS

51: Multi-Party

60: All Community of Interest SS

61: CUG - Closed User Group

70: All Charging SS

71: Advice of Charge Information

72: Advice of Charge Charging

80: All Additional Information Transfer SS

81: UUS1 User-to-User Signalling

82: UUS2 User-to-User Signalling

83: UUS3 User-to-User Signalling

90: All Barring SS

91: Barring of Outgoing Calls

92: BAOC - Barring of All Outgoing Calls

93: BOIC - Barring of Outgoing International Calls

94: BOIC-ExHPLMN

99: Barring of Incoming Calls

9A: BAIC - Barring of All Incoming Calls

9B: BIC-Roam - Barring of Incoming Calls When Roaming Outside Home PLMN Country
Basic Service: Teleservice (All Speech Transmission Services) [10]
Forwarded to Number [81 85 87 47 F6]
x... .... | Extension: 0: Extended 1: No Extension
.xxx .... | Nature of number: 000: unknown
.... xxxx | Number plan: 0001: ISDN/Telephony Numbering (Rec ITU-T E.164)

Address digits: 5878746

GSM MAP  Return Result Last Register SS
BSSAP
Message Type: Direct Transfer [01]
Data Link Connection Identifier [00]
xx.. .... | Control Channel: 00: not further specified
..00 0... | Spare
.... .xxx | SAPI: 000: RR/MM/CC
Length: 43 [2B]
GSM A-I/F DTAP - Release Complete
Protocol Discriminator: Call Control; call related SS messages [9B]
x... .... | TI flag: 0: allocated by sender 1: allocated by receiver
.xxx .... | TIO
.... xxxx | Protocol discriminator: 1011: Non call related SS messages
Message Type Release Complete [2A]
Cause

Element ID: 8 [08]

Length: 2 [02]

x... ....

Extension:

0: Extended

1: No Extension

.xx. ....

Coding standard:

00: CCITT Q.931

01: other international

10: national

11: GSM

...0 ....

Spare

.... xxxx

Location:

0000: user

0001: private network, local user

0010: public network, local user

0011: transit network

0100: public network, remote user

0101: private network, remote user

0111: international network

1010: network beyond interworking point

x... ....

Extension:

0: Extended

1: No Extension

.xxx xxxx

Cause class + cause value:

000 ....: normal event

000 0001: unassigned number

000 0011: no route to destination

000 0110: channel unacceptable

000 1000: operator determined barring (only in the phase 2)

001 ....: normal event

001 0000: normal clearing

001 0001: user busy

001 0010: no user responding

001 0011: user alerting, no answer

001 0101: call rejected

001 0110: number changed

001 1010: non selected user clearing

001 1011: destination out of order

001 1100: invalid number format

001 1101: facility rejected

001 1110: response to STATUS ENQUIRY

001 1111: unspecified

010 ....: resource unavailable

010 0010: no circuit or channel

010 0110: network out of order

010 1001: temporary failure

010 1010: switching equipment congestion

010 1011: access information discarded

010 1100: no requested circuit or channel

010 1111: unspecified

011 ....: service or option not available

011 0001: quality of service unavailable

011 0010: requested facility not subscribed

011 0111: incoming calls barred within CUG (in the phase 2)

011 1001: bearer capability unauthorized

011 1010: bearer capability unavailable

011 1111: unspecified

100 ....: service or option not implemented

100 0001: bearer service not implemented

100 0101: requested facility not implemented

100 0110: only restricted digital info bearer

100 1111: unspecified

101 ....: invalid message

101 0001: invalid transaction identifier value

101 0111: user not member of CUG (only in the phase 2)

101 1000: incompatible destination

101 1011: invalid transit network selection

101 1111: unspecified

110 ....: protocol error

110 0000: mandatory info element error

110 0001: msg non-existing or not implemented

110 0010: msg incompatible with control state

110 0011: IE non-existent or not implemented

110 0100: invalid info element contents

110 0101: msg incompatible with call state

110 0110: recovery on timer expiry

110 1111: unspecified

111 ....: interworking

111 1111: unspecified
Facility

Element ID: 28 [1C]

Length: 35 [23]
GSM Mobile Application
Component: Return Result Last [A2]
Invoke
Invoke ID: 1 [01]
Operation Code

0A: Register SS

0B: Erase SS

0C: Activate SS

0D: Deactivate SS

0E: Interrogate SS

10: Notify SS

11: Register Password

12: Get Password

13: Process Unstructured SS Data

26: Forward Check SS Indication

3B: Process Unstructured SS Request

3C: Unstructured SS Request

3D: Unstructured SS Notify

4D: Erase CC Entry

77: Access Register CC Entry

78: Forward CUG Info

79: Split MPTY

7A: Retrieve MPTY

7B: Hold MPTY

7C: Build MPTY

7D: Forward Charge Advice

7E: Explicit CT
Basic Service: Teleservice (All Speech Transmission Services) [10]
Forwarding Info
SS Code

00: All SS

10: All Line Identification SS

11: CLIP - Calling Line Identification Presentation

12: CLIR - Calling Line Identification Restriction

13: COLP - Connected Line Identification Presentation

14: COLR - Connected Line Identification Restriction

15: MCI - Malicious Call Identification

18: All Name Identification SS

19: CNAP - Calling Name Presentation

20: All Forwarding SS

21: CFU - Call Forwarding Unconditional

28: All Conditional Forwarding SS

29: CFB - Call Forwarding Busy

2A: CFNRy - Call Forwarding on No Reply

2B: CFNRc - Call Forwarding on Mobile Subscriber Not Reachable

24: CD - Call Deflection

30: All Call Offering SS Includes Also All Forwarding SS

31: ECT - Explicit Call Transfer

32: MAH - Mobile Access Hunting

40: All Call Completion SS

41: Call Waiting

42: Call Hold

43: Completion of Call to Busy Subscribers, Originating Side

44: Completion of Call to Busy Subscribers, Destination Side

45: Multi Call

50: All Multi-Party SS

51: Multi-Party

60: All Community of Interest SS

61: CUG - Closed User Group

70: All Charging SS

71: Advice of Charge Information

72: Advice of Charge Charging

80: All Additional Information Transfer SS

81: UUS1 User-to-User Signalling

82: UUS2 User-to-User Signalling

83: UUS3 User-to-User Signalling

90: All Barring SS

91: Barring of Outgoing Calls

92: BAOC - Barring of All Outgoing Calls

93: BOIC - Barring of Outgoing International Calls

94: BOIC-ExHPLMN

99: Barring of Incoming Calls

9A: BAIC - Barring of All Incoming Calls

9B: BIC-Roam - Barring of Incoming Calls When Roaming Outside Home PLMN Country
Forwarding Feature List: 1 item
Item
Basic Service: Teleservice (All Speech Transmission Services) [10]
SS Status [07]
0000 .... | Spare
.... x... | Operative
.... .x.. | Provisioned
.... ..x. | Registered
.... ...x | Active
Forwarded to Number [81 85 87 47 F6]
x... .... | Extension: 0: Extended 1: No Extension
.xxx .... | Nature of number: 000: unknown
.... xxxx | Number plan: 0001: ISDN/Telephony Numbering (Rec ITU-T E.164)

Address digits: 5878746
Forwarding Options [0C]
x... .... | Notification to forwarding party
.x.. .... | Redirecting presentation
..x. .... | Notification to calling party
...0 .... | Spare
.... xx.. | Forwarding reason
.... ..00 | Spare

4